Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 554924

Summary: phantom package mask for dev-util/boost-build-1.56.0
Product: Gentoo Linux Reporter: ta2002 <throw_away_2002>
Component: Current packagesAssignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: ag+services, alexander, eric.chatellier, garth, gentoo
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Output of: grep -r boost /usr/portage/profiles

Description ta2002 2015-07-15 02:59:11 UTC
# emerge -Dpu world 

 These are the packages that would be merged, in order: 

 Calculating dependencies... done! 

 Total: 0 packages, Size of downloads: 0 KiB 

 !!! The following update has been skipped due to unsatisfied dependencies: 

 dev-libs/boost:0 

 !!! All ebuilds that could satisfy "=dev-util/boost-build-1.56*" have been masked. 
 !!! One of the following masked packages is required to complete your request: 
 - dev-util/boost-build-1.56.0::gentoo (masked by: ) 

 (dependency required by "dev-libs/boost-1.56.0-r1::gentoo" [ebuild]) 
 For more information, see the MASKED PACKAGES section in the emerge 
 man page or refer to the Gentoo Handbook. 



 # emerge -p boost 

 These are the packages that would be merged, in order: 

 Calculating dependencies... done! 
 [ebuild     U  ] dev-util/boost-build-1.56.0::gentoo [1.55.0::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="-python2_7%" 92,557 KiB 
 [ebuild  r  U  ] dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo [1.55.0-r2:0/1.55.0::gentoo] USE="nls threads -context -debug -doc -icu -mpi -python -static-libs -tools" PYTHON_TARGETS="python3_4 -python2_7 -python3_3" 0 KiB 
 [ebuild  rR    ] media-libs/qt-gstreamer-1.2.0::gentoo  USE="{-test}" 0 KiB 

 Total: 3 packages (2 upgrades, 1 reinstall), Size of downloads: 92,557 KiB 

 The following packages are causing rebuilds: 

   (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) causes rebuilds for: 
     (media-libs/qt-gstreamer-1.2.0:0/0::gentoo, ebuild scheduled for merge)


Either boost-build-1.56.0 is masked or it is not (it can't be masked in the first instance, but not in the second). I suspect the latter, because no source was given for the claimed mask.


# emerge --info
Portage 2.2.20 (python 3.3.5-final-0, default/linux/amd64/13.0/no-multilib, gcc-4.8.4, glibc-2.20-r2, 4.0.5-gentoo x86_64)
=================================================================
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8400_@_2.66GHz-with-gentoo-2.2
KiB Mem:     8016936 total,   2363760 free
KiB Swap:    1047548 total,   1047548 free
Timestamp of repository gentoo: Tue, 14 Jul 2015 02:30:01 +0000
sh bash 4.2_p53
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo, 3.4.1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -fomit-frame-pointer -pipe -march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -mfpmath=sse"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -fomit-frame-pointer -pipe -march=core2 -mcx16 -msahf -msse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit R X a52 aac aalib accessibility acoustid acpi additions adobe-cff aio alsa amd64 ap asf aspell audio audiofile avcodec avformat blksha1 bluray bookmarks bwscheduler bzip2 cacert cairo caps cdda cdio cdr chm chroot cli client consolekit cpumining cracklib crypt cryptsetup css cups cxx dbus device-mapper dga directfb djvu downloadorder dri dri3 dvbpsi dvd dvdnav dvdr ebook egl eigen encode espeak exceptions exif expat fam fbcon ffmpeg filecaps flac fluidsynth fontconfig fortran gbm gcj gcrypt ggi gif git glamor glib glibc-omitfp gmp gpg gphoto2 gpm gsm gstreamer gtk handbook hardcoded-tables hddtemp hpn iconv idea imap infowidget inotify iostats ipc ipfilter ipv6 jabber jbig jit joystick jpeg jsbsim kdcraw kde kmod kscreen lame lcms less libass libkms libmpv libwww live lm_sensors logviewer lzma mad matroska mbox mdns-bundled memlimit midi minizip mmx mmxext mp3 mp4 mpeg mta mudflap nas ncurses net netapi network nls no-old-linux nodrm npm nptl ntfsprogs ntp ocamlopt offlinehelp ofx ogg okular opengl openmedia openmp oscar osdmenu p2p pcre pdf pm-utils png policykit portmon postproc ps qt3support quotes raptor readline real recursion-limit redland rtc rtmp savedconfig scanfolder scanner scrypt sdl search secure-delete sensord shared-glapi shm silc smbclient smtp snapshot sndfile sound speex spell sse sse2 sse2_4way sse2check sse4 ssl ssse3 stats subversion svg swscale sysfs taglib tcmalloc tcpd theora threads threadsafe tiff tls-heartbeat truetype udev udisks unicode upower urandom usb userlocales utils v4l2 vdpau video vorbis wav webdav-neon webinterface x264 xcb xinerama xml xmp xpdf-headers xslt xv xvid yahoo zlib zrtp" ABI_X86="64" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="author braindump flow karbon krita sheets stage words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Eric Chatellier 2015-07-16 10:04:44 UTC
Same problem for me:
"dev-util/boost-build-1.56.0::gentoo (masked by: )"
Comment 2 Amy Liffey gentoo-dev 2015-07-17 11:30:39 UTC
*** Bug 555108 has been marked as a duplicate of this bug. ***
Comment 3 Garth 2015-07-18 07:06:07 UTC
I've hit the same bug, however I was given the following suggestion from the IRC channel, and it seems to have resolved it. Both boost & boos-build got updated, and they no longer cause trouble in the @world set.

Here's what I've done:
emerge -1 boost-build boost
Comment 4 Sergey Popov gentoo-dev 2015-07-22 08:38:28 UTC
Please, give us output of your:

grep -r boost /usr/portage/profiles


@portage guys: any ideas why reason is not printed?
Comment 5 Garth 2015-07-22 15:30:00 UTC
Created attachment 407420 [details]
Output of: grep -r boost /usr/portage/profiles

Here's the requested info.

Note that I have since solved the issue with the previously provided fix.
Also, I performed a 'sync' twice since then.

Also note that: grep -ir boost /etc/portage   , doesn't return anything.
Comment 6 Garth 2015-07-22 15:40:10 UTC
I'd like to mention, that 3 other machines I have never got the problem (they share the portage tree from a nfs share on the one that did get the issue). (There's 3 more I haven't try to update in a while, I don't know if they'll hit the issue or not yet).


I also realised I never sent my: emerge --info  , from the machine that got the issue:


Portage 2.2.20 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.20-r2, 4.0.5-gentoo x86_64)
=================================================================
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-gentoo-2.2
KiB Mem:     2040516 total,    139188 free
KiB Swap:     786364 total,    770640 free
Timestamp of repository gentoo: Wed, 22 Jul 2015 06:45:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p33-r2::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo
dev-util/cmake:           3.2.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.15::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.namerica.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=atom -mtune=atom -O2 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=atom -mtune=atom -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/local/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirrors.tera-byte.com/pub/gentoo ftp://gentoo.arcticnetwork.ca/pub/gentoo/ ftp://gentoo.mirrors.pair.com/ http://gentoo.mirrors.pair.com/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="a52 aac alsa amd64 bash-completion berkdb bzip2 cddb clamav cli cracklib crypt cups cxx encode fam fame ffmpeg foomaticdb fortran gif iconv imagemagick imlib jpeg jpeg2k lame lzma lzo mad matroska mikmod mjpeg mmx mmx2 mmxext modules mp3 mpeg mpi mplayer multilib ncurses network network-cron nls nptl nptlonly ogg openmp pcre png ppds qt3support qt4 quicktime readline real rtc samba session speex sse sse2 sse3 ssl ssse3 tcpd theora threads tiff truetype unicode usb vorbis x264 xanim xcb xml xmms xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="none" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 7 Zac Medico gentoo-dev 2015-07-22 18:00:34 UTC

*** This bug has been marked as a duplicate of bug 554838 ***
Comment 8 Zac Medico gentoo-dev 2015-07-23 04:43:04 UTC
(In reply to Sergey Popov from comment #4)
> @portage guys: any ideas why reason is not printed?

It means that the dependency resolver masked it while backtracking, due to having trouble trying to satisfy its dependencies.