Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 550502

Summary: x11-libs/libX11-1.6.3: large file support needs to be enabled
Product: Gentoo Linux Reporter: Zac Medico <zmedico>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: normal CC: alexander
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 471102    
Attachments: build log showing failure on xfs with 64-bit inode numbers
fix ebuild to call append-lfs-flags from flag-o-matic.eclass

Description Zac Medico gentoo-dev 2015-05-26 23:18:52 UTC
Created attachment 404036 [details]
build log showing failure on xfs with 64-bit inode numbers

The new QA check for bug 471102 reports this issue:

 * QA Notice: The following files were not built with LFS support:
 *   Please see https://bugs.gentoo.org/471102 for details.
 * mmap@@GLIBC_2.2.5,__xstat@@GLIBC_2.2.5,__fxstat@@GLIBC_2.2.5,open@@GLIBC_2.2.5,fopen@@GLIBC_2.2.5 usr/lib64/libX11.so.6.3.0
 * __xstat@@GLIBC_2.0,__fxstat@@GLIBC_2.0,open@@GLIBC_2.0,mmap@@GLIBC_2.0,fopen@@GLIBC_2.1 usr/lib32/libX11.so.6.3.0


I can confirm that this is a real problem, because it makes the build fail on an xfs filesystem due to 64-bit inode numbers. The problem is solved after adding an append-lfs-flags (from flag-o-matic.eclass) call at the beginning of src_configure.
Comment 1 Zac Medico gentoo-dev 2015-05-26 23:23:09 UTC
Created attachment 404038 [details, diff]
fix ebuild to call append-lfs-flags from flag-o-matic.eclass
Comment 2 SpanKY gentoo-dev 2015-05-27 03:00:32 UTC
the 64bit check is wrong (and we're dealing with that in bug 550482), but the 32bit check is accurate

an alternative would be to update configure.ac in all the X packages to use AC_SYS_LARGEFILE everywhere
Comment 3 Larry the Git Cow gentoo-dev 2019-06-17 15:25:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=6e63e33be6eb1f152b27c00a81494e85b3152709

commit 6e63e33be6eb1f152b27c00a81494e85b3152709
Author:     Matt Turner <mattst88@gentoo.org>
AuthorDate: 2019-06-17 14:54:52 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2019-06-17 15:18:51 +0000

    x11-libs/libX11: Version bump to 1.6.8
    
    Closes: https://bugs.gentoo.org/299654
    Closes: https://bugs.gentoo.org/550502
    Closes: https://bugs.gentoo.org/616140
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 x11-libs/libX11/Manifest            |  1 +
 x11-libs/libX11/libX11-1.6.8.ebuild | 28 ++++++++++++++++++++++++++++
 2 files changed, 29 insertions(+)