Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 548422

Summary: mail-client/mailx-support: Compile with musl libc
Product: Gentoo Linux Reporter: Felix Janda <felix.janda>
Component: Current packagesAssignee: Net-Mail Packages <net-mail+disabled>
Status: RESOLVED FIXED    
Severity: normal CC: blueness
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 430702    

Description Felix Janda 2015-05-02 20:26:14 UTC
The file open_with_exlock.c of mail-client/mailx-support fails to
compile on the musl profiles because LOCK_EX is not exposed without
including <sys/file.h>. So we currently use the patch

https://cgit.gentoo.org/proj/hardened-dev.git/tree/mail-client/mailx-support/files/mailx-support-20060102-add-sys_file_h.patch?h=musl&id=48555b66e063e01be80c2c0941e6c46187b30e31

to add the missing include. (The man page says that flock() needs
<sys/file.h>.)


The file open_with_exlock.c has been added by gentoo to the OpenBSD
utilities. So I ask for a new mailx-support tarball to be shipped with
this change.


Reproducible: Always
Comment 1 Anthony Basile gentoo-dev 2015-06-12 21:52:09 UTC
This packages seems pretty dead both upstream and downstream.  So I am going to go ahead and added this patch to -r2 and bumped the ebuild to EAPI=5 while I at it.  We should stabilize it in a month.
Comment 2 Felix Janda 2015-12-07 18:24:04 UTC
-r2 has been stabilized some time ago and mailx-support has been removed from the musl overlay.