Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 548020

Summary: =net-irc/weechat-1.1.1 with USE="-nls" fails test TEST(String, FormatSize) - expected <1 byte> but was <1 bytes>
Product: Gentoo Linux Reporter: eroen <gentoo>
Component: Current packagesAssignee: Tim Harder <radhermit>
Status: RESOLVED OBSOLETE    
Severity: normal CC: net-irc, scarabeus
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build/Testing/Temporary/LastTest.log

Description eroen 2015-04-28 14:32:17 UTC
Created attachment 402162 [details]
build.log

occam ~ # ~eroen/repos/freshstage3/freshstage3.bash all -c ~eroen/repos/freshstage3/cmdfiles/weechat
Will create fresh stage3 in /tmp/testroot
Running setup() ...
Current stage3: 20150423/stage3-amd64-20150423.tar.bz2
Tree timestamp: 1430201101 Tue 28 Apr 2015 06:05:01 AM UTC
+ tar xpf ../stage3-amd64-20150423.tar.bz2
+ mkdir usr/portage
+ mount --bind /usr/portage/ usr/portage
++ portageq envvar DISTDIR
+ mount --bind /var/distfiles usr/portage/distfiles
+ mount -t proc none proc
+ mount -t sysfs none sys
+ mount --rbind /dev dev
+ cp /etc/resolv.conf etc/resolv.conf
Enabling FEATURES="-news noclean test" ...
Removing bindist from USE ...
Populating with template/ ...
+ cp /home/eroen/repos/freshstage3/freshstage3.bash ./testscript.bash
+ cp /home/eroen/repos/freshstage3/cmdfiles/weechat ./
Chrooting ...
+ env -i TERM=xterm-256color chroot . /bin/bash /testscript.bash build -c /home/eroen/repos/freshstage3/cmdfiles/weechat
Running build() ...
+ env-update
PORTAGE_BZIP2_COMMAND setting is invalid: 'bzip2'
PORTAGE_BZIP2_COMMAND setting from make.globals is invalid: 'bzip2'
>>> Regenerating /etc/ld.so.cache...
Sourcing /etc/profile quietly ...
++ echo 'FEATURES="$FEATURES -test -noclean"'
++ mkdir -p /etc/portage/package.use
++ echo 'net-irc/weechat -nls'
++ echo =net-irc/weechat-1.1.1::gentoo
++ echo =dev-util/cpputest-3.6
++ emerge --noreplace -v -1 --onlydeps =net-irc/weechat-1.1.1::gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] net-dns/libidn-1.29::gentoo  USE="nls -doc -emacs -java -mono -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-libs/nettle-2.7.1-r1:0/4::gentoo  USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-scheme/guile-1.8.8-r1:12::gentoo  USE="deprecated nls regex threads -debug -debug-freelist -debug-malloc -discouraged -emacs -networking" 0 KiB
[ebuild  N     ] net-misc/curl-7.42.0::gentoo  USE="ipv6 ssl -adns -idn -kerberos -ldap -metalink -rtmp -samba -ssh -static-libs {-test} -threads" ABI_X86="(64) -32 (-x32)" CURL_SSL="openssl -axtls -gnutls -nss -polarssl (-winssl)" 0 KiB
[ebuild  N     ] sys-devel/autogen-5.18.1::gentoo  USE="-libopts -static-libs" 0 KiB
[ebuild  N     ] dev-libs/libtasn1-4.4:0/6::gentoo  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] app-arch/libarchive-3.1.2-r1:0/13::gentoo  USE="acl bzip2 e2fsprogs iconv lzma zlib -expat -lzo -nettle -static-libs -xattr" 0 KiB
[ebuild  N     ] dev-util/cmake-2.8.12.2-r1::gentoo  USE="ncurses -emacs -qt4 (-qt5) {-test}" 0 KiB
[ebuild  N     ] net-libs/gnutls-3.3.10-r2::gentoo  USE="crywrap cxx nls zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="(64) -32 (-x32)" LINGUAS="-cs -de -en -fi -fr -it -ms -nl -pl -sv -uk -vi -zh_CN" 0 KiB
[ebuild  N     ] app-text/aspell-0.60.6.1-r1::gentoo  USE="nls" LINGUAS="-af -be -bg -br -ca -cs -cy -da -de -el -en -eo -es -et -fi -fo -fr -ga -gl -he -hr -is -it -la -lt -nl -no -pl -pt -pt_BR -ro -ru -sk -sl -sr -sv -uk -vi" 0 KiB
[ebuild  N     ] app-dicts/aspell-en-7.1.0::gentoo  0 KiB
< snip >
++ emerge --noreplace -v -1 dev-util/cpputest

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] dev-util/cpputest-3.6::gentoo  USE="{-test}" 0 KiB
< snip >
++ echo 'FEATURES="$FEATURES test noclean"'
++ emerge -v -1 =net-irc/weechat-1.1.1::gentoo

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] net-irc/weechat-1.1.1::gentoo  USE="alias charset exec fifo irc logger perl python relay scripts spell ssl {test} trigger xfer -doc -guile -lua -nls -ruby -tcl" LINGUAS="-cs -de -es -fr -hu -it -ja -pl -pt_BR -ru -tr" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4" 0 KiB
< snip >
>>> Test phase: net-irc/weechat-1.1.1
>>> Working in BUILD_DIR: "/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build"
Test project /var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build
    Start 1: unit
1/1 Test #1: unit .............................***Failed   16.47 sec

0% tests passed, 1 tests failed out of 1

Total Test time (real) =  16.47 sec

The following tests FAILED:
	  1 - unit (Failed)
Errors while running CTest
 * ERROR: net-irc/weechat-1.1.1::gentoo failed (test phase):
 *   Tests failed. When you file a bug, please attach the following file: 
 * 	/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build/Testing/Temporary/LastTest.log
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_test
 *   environment, line 3611:  Called cmake-utils_src_test
 *   environment, line  863:  Called _execute_optionally 'src_test'
 *   environment, line  275:  Called enable_cmake-utils_src_test
 *   environment, line 1209:  Called die
 * The specific snippet of code:
 *               die "Tests failed. When you file a bug, please attach the following file: 
 * 	${BUILD_DIR}/Testing/Temporary/LastTest.log";
 * 
 * If you need support, post the output of `emerge --info '=net-irc/weechat-1.1.1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-irc/weechat-1.1.1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/net-irc/weechat-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-irc/weechat-1.1.1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build'
 * S: '/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1'
Comment 1 eroen 2015-04-28 14:34:15 UTC
Created attachment 402164 [details]
/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1_build/Testing/Temporary/LastTest.log

TEST(String, FormatSize)
/var/tmp/portage/net-irc/weechat-1.1.1/work/weechat-1.1.1/tests/unit/core/test-string.cpp:931: er
ror: Failure in TEST(String, FormatSize)
        expected <1 byte>
        but was  <1 bytes>
        difference starts at position 6 at: <    1 bytes         >
                                                       ^

 - 1 ms
Comment 2 eroen 2015-04-28 14:34:48 UTC
occam / # emerge --info '=net-irc/weechat-1.1.1::gentoo'
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.20-r2, 3.18.2.e0-occam0+ x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.18.2.e0-occam0+-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.2
KiB Mem:     7944088 total,   1474740 free
KiB Swap:   16777212 total,  16776584 free
Timestamp of repository gentoo: Tue, 28 Apr 2015 06:30:01 +0000
sh bash 4.2_p53
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.3.5-r1::gentoo
dev-util/cmake:           2.8.12.2-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.13.4::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync noclean parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx mmxext modules multilib ncurses nls nptl openmp pam pcre readline session sse sse2 ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

occam / # emerge -pqv '=net-irc/weechat-1.1.1::gentoo'
[ebuild  N    ] net-irc/weechat-1.1.1  USE="alias charset exec fifo irc logger perl python relay scripts spell ssl {test} trigger xfer -doc -guile -lua -nls -ruby -tcl" LINGUAS="-cs -de -es -fr -hu -it -ja -pl -pt_BR -ru -tr" PYTHON_SINGLE_TARGET="python2_7 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 python3_3 -python3_4"
Comment 3 eroen 2015-04-28 14:37:29 UTC
See the two different definitions of NG_ in https://github.com/weechat/weechat/blob/b42ae05a65/src/core/weechat.h
Comment 4 Tim Harder gentoo-dev 2017-09-11 05:22:57 UTC
Closing as obsolete since I can't reproduce this with newer releases in the tree and tests are currently restricted until plugin testing is fixed.