Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 547834

Summary: sys-apps/paludis still uses ruby19
Product: Gentoo Linux Reporter: Hans de Graaff <graaff>
Component: Current packagesAssignee: Michał Górny <mgorny>
Status: RESOLVED FIXED    
Severity: normal CC: mgorny, ruby
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 536852    

Description Hans de Graaff gentoo-dev 2015-04-26 18:13:11 UTC
Upstream support for Ruby 1.9 ended, therefore we'd like to remove ruby1.9 soon.

Your package depends on ruby:1.9, please use a recent ruby implementation and get this version stable, if the ruby:1.9 version had stable keywords.

Further reading:
https://wiki.gentoo.org/wiki/Project:Ruby/Ruby_1.9_deprecation
Comment 1 Hans de Graaff gentoo-dev 2015-07-10 07:05:11 UTC
*paludis-2.4.0 (04 Apr 2015)

  04 Apr 2015; Michał Górny <mgorny@gentoo.org> +paludis-2.4.0.ebuild:
  Version bump. Switch to ruby:2.0 which is the newer version in profile
  defaults, until we are provided with better tools to handle Ruby.
Comment 2 Manuel Rüger (RETIRED) gentoo-dev 2015-08-27 13:47:19 UTC
2.4.0 is stable, can you please cleanup the old versions?
Comment 3 Manuel Rüger (RETIRED) gentoo-dev 2015-09-07 10:03:03 UTC
USE=ruby was masked for <2.4.0
Comment 4 Hans de Graaff gentoo-dev 2016-08-14 06:42:24 UTC
(In reply to Manuel Rüger from comment #3)
> USE=ruby was masked for <2.4.0

Closing this bug due to this fix.