Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 547772

Summary: net-misc/termtter still uses ruby19
Product: Gentoo Linux Reporter: Hans de Graaff <graaff>
Component: Current packagesAssignee: Naohiro Aota <naota>
Status: RESOLVED FIXED    
Severity: normal CC: ruby
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 536852    

Description Hans de Graaff gentoo-dev 2015-04-26 08:11:09 UTC
Upstream support for Ruby 1.9 ended, therefore we'd like to remove ruby1.9 soon.

Your package depends on ruby:1.9, please use a recent ruby implementation and get this version stable, if the ruby:1.9 version had stable keywords.

Further reading:
https://wiki.gentoo.org/wiki/Project:Ruby/Ruby_1.9_deprecation
Comment 1 Manuel RĂ¼ger (RETIRED) gentoo-dev 2015-08-27 13:40:43 UTC
Please provide a version that is working with a later ruby, otherwise it will be masked for removal with ruby19 in two weeks.
Comment 2 Hans de Graaff gentoo-dev 2015-12-28 07:47:44 UTC
I've added termtter 2.2.3 with support for ruby20 and ruby21, and removed the broken ruby19 version.