Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 54681

Summary: livecd detects drive on /dev/hda not /dev'hde as it should
Product: Gentoo Release Media Reporter: john lowell <johnlowell>
Component: EverythingAssignee: Gentoo LiveCD Package Maintainers <livecd>
Status: VERIFIED FIXED    
Severity: major    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description john lowell 2004-06-21 12:54:28 UTC
Running a PII 333Mhz with a Promise 100 TX-2 IDE Controller. My hard drive is connected to the Promise card, naturally. The live cd detects the drive at /dev/hda when it should detect it at /dev/hde. Starting the install, fdisk sees /dev/hda also. Complete install results in kernel panic, "please append correct root option" error yet /dev/hde when searched for brings "could not find" type response. 

Reproducible: Always
Steps to Reproduce:
1.Boot up livecd
2./dev/hda only device detected for partitioning yet drive is connected to /dev/hde 
3.Full install fails with kernel panic
Actual Results:  
Kernel panic, please append correct root option

Expected Results:  
If it had detected the right device it would have found it and permitted 
partitioning at the right place. 

PII 333 Mhz on Intel AL440LX system board
256 MB SDRAM
Promise Ultra 100-TX2 IDE controller
WD 40 GB HDD
Comment 1 john lowell 2004-06-21 16:14:57 UTC
Just to mention that I just tried to boot up with KNOPPIX and it reads the devices correctly, that is to say as /dev/hde. There is really a pronounced need to improve this livecd. I've reported more than one bug for this version: (1) cd hangs at Dell laptop, solved by using the new test cd and, (2) this one, yet to be addressed.  
Comment 2 Chris Gianelloni (RETIRED) gentoo-dev 2004-06-22 05:27:46 UTC
Which CD did this occur on?

Have you tried any of the pre-release or test CDs?  You can find my test CD at your local Gentoo mirror in the /experimental/x86/livecd folder.
Comment 3 john lowell 2004-06-25 20:27:37 UTC
Chris,

I regret to tell you that the detection problem afflicts both the 2004.1 livecd and the test livecd, gentoo-2004.2-test4.iso, that is on the mirrors. I get "unable to open" errors running fdisk /dev/hde but fdisk /dev/hda, oddly, responds. I have a Promise IDE controller on this box as I'd mentioned. fdisk shouldn't be opening /dev/hda and should be opening /dev/hde. The Knoppix CD gets it right. 

jlowell
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2004-06-26 06:37:02 UTC
Are the on-board controllers disabled?  What kind of chipset is the on-board controller?
Comment 5 john lowell 2004-06-29 18:53:17 UTC
Hello Chris,

A check of the machine's BIOS would seem to indicate that I'd shut off the on-board controllers, except for Secondary Master on which the CD reader is installed. The BIOS indicates [NONE] for both Primary Master and Slave and for Secondary Slave. 

As to the chipset, the systemboard is an Intel AL440LX, a popular board in the late nineties.

I hope this information is helpful.

jlowell
Comment 6 Chris Gianelloni (RETIRED) gentoo-dev 2004-06-30 05:16:37 UTC
With the on-board controllers disabled, the add-in card *should* be /dev/hda and not /dev/hde, since there are no "other" controllers to be /dev/hda.  Perhaps it is Knoppix that is doing it wrong?

It is my understanding that a controller should *not* be initialized and assigned device nodes if it is disabled.
Comment 7 john lowell 2004-06-30 07:03:24 UTC
Hi Chris,

Interesting. The options in the BIOS would give you the clear impression that something must be attached to an on-board controller in order for it to be properly configured as active in some way. More than anything else, [NONE] would seem to imply the absence of a device and, in this case, the proper setting. That notwithstanding, I've run both Arch Linux and earlier versions of Gentoo, 1.4 specifically, on this machine with the drive being detected at /dev/hde!! Not to challenge your undoubtedly high level of expertise but these latter are facts. I have a Debian install disk here. I'll see how it reports the drives and get back to you. 

jlowell
Comment 8 Chris Gianelloni (RETIRED) gentoo-dev 2004-06-30 07:33:59 UTC
You'll also have to consider differences in kernel versions.  I know for a fact that older kernels would assign device nodes for controller channels that were disabled, provided it detected the controller.
Comment 9 john lowell 2004-06-30 09:29:48 UTC
Chris,

Well, I've run the Debian install CD and their hardware detection picks things up as /dev/hde! I mean, can forty million Frenchmen be wrong? As far as kernels are involved, I feel reasonably comfortable in making the assertion that nothing any more dated than 2.4.21 has been utilized on these various CDs. Truthfully, Chris, I think we have a problem here; I have no axe to grind in reporting these details, of course. Has the CD actually been tested on set-ups similar to mine?

jlowell 
Comment 10 Chris Gianelloni (RETIRED) gentoo-dev 2004-06-30 10:50:13 UTC
I'm not saying that there isn't a problem, but more that I think that our CD is doing what I would expect.  Also, which kernel are you using?  gentoo?  smp?  Are you using any kernel command line options?  If so, which ones?

I would really like to get this resolved.
Comment 11 john lowell 2004-06-30 11:39:29 UTC
Hello Chris,

The history here is somewhat sordid, actually. :-)

Initially, I installed stage1 with this livecd on three workstations. There were ethernet device  detection difficulties in all three instances despite the fact that previous Gentoo livecds had had no such difficulty and manual configuration had to be used. The installations were otherwise entirely successful.

With the machine in question, one slated to be a webserver, the initial installation got no further than than the Dell laptop line and hung. This problem with the livecd appears to have been rather well known. I found I could boot with the smp kernel, not that it's detection of /dev/hda offered me any encouragement, so, ultimately, I used the test cd then available instead. No difference; /dev/hda here too. As you know, I made the Gentoo installation successfully in this case only after resorting to the Knoppix CD. 

You mention that the cd is merely living up to the expectations you have for it. My experience would indicate - and I say this with sincere respect for your technical competence -  that it would be wise to question those expectations at this point.

jlowell
Comment 12 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-20 19:28:11 UTC
Have you tried this with one of the more recent -test series LiveCD's? something like -test5 or -test6?

There's also an _rc1 at http://dev.gentoo.org/~wolf31o2/2004.2-test
Comment 13 john lowell 2004-07-20 19:51:36 UTC
Hi, Chris,

I've been so focused on other things that it never occured to me that more recent test resources might be available for trial. I'll take a look at them and get back to you as soon as I can. After our recent interchange, I wasn't certain what your thoughts might have been respecting a way forward on this question. Maybe one of the new test cds will help us reach  an end. 

Best regards.

jlowell



Comment 14 john lowell 2004-07-20 21:00:00 UTC
Chris, 

Since the 2004.2_rc1 was the most recent vehicle available and, therefore, the one most likely to have included any modifications that might effect the problem in question, I chose it. Sorry to report, fdisk /dev/hde still brings up "can't open" failures. No such problem with fdisk /dev/hda. So nothing's changed. KNOPPIX and at least one other livecd based on KNOPPIX pick up fdisk /dev/hde just fine. I continue to hold that the problem well may have to do with our underlying presuppositions about the proper circumstances for designating a device /dev/hde or /dev/hda. I really think we'd be wise to question them at this point. If we're giving the cd the wrong instructions, naturally, it's going to deliver wrong outcomes. Until these issues are addressed, it makes little sense either to test further cds or, for me on this particular machine anyway, to rely upon Gentoo hardware detection properly to guide what is always a very arduous installation process. Earlier Gentoo livecds didn't act this way on this machine. There is something new here.

jlowell
Comment 15 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-21 03:58:28 UTC
Yeah, I want to apologize about that.  After our last set of comments, I decided it best to step back from this and take some time to cool off.  I'm back... new and improved, so to speak... and under less stress from outside sources.  Now, that being said, you really need to watch what words you use when dealing with people.  There's only so much "you need to re-evaluate X" a person can take.

The 2004.2 CD is finalized, so we won't be able to do much there as I ran out of time.  I'm going to find out what is going on, though, and resolve the problem.
Comment 16 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-21 05:25:16 UTC
Also, try booting with the "smp" kernel.
Comment 17 john lowell 2004-07-21 05:35:27 UTC
Chris,

For God's sake, man, you were offended by

"You mention that the cd is merely living up to the expectations you have for it. My experience would indicate - and I say this with sincere respect for your technical competence -  that it would be wise to question those expectations at this point."

and you allowed that to cause you "to step back from this and take some time to cool off"?

Would you have preferred me to have said something along these lines:

"Look, dunderhead, I've tested fdisk /dev/hde and /dev/hda with KNOPPIX, Arch Linux, and Debian. They read the matter as /dev/hde. You need to go back to school. You're wasting my time with your stupidity about controllers."

Would that have been either appropriate or justified? I don't know what pressures from the outside that you may be under, and I really don't much care, but understand clearly that with such as 

"Now, that being said, you really need to watch what words you use when dealing with people."

I really don't wish them to be made mine.

Now, since we still have no resolution of this problem, and, I might add, no direct answer to the question I'd raised earlier about whether you folks have actually tested the cd with a setup like mine, am I to conclude, as have so many on the forums and mailing lists, that the latest Gentoo livecd is a piece of junk and that it is the work product of amateurs, or can you take your pride off for a moment and work with me toward a helpful outcome? I know for one thing that I have no further time to set aside to test cds on which no revisions have been made to correct this bug.

jlowell 
Comment 18 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-21 05:51:37 UTC
Hi... thank you for turning into a complete prick.

I've located the problem and it'll be fixed in the production release.  I honestly would thank you to never file a bug again, since you obviously have zero tact nor consideration for someone who spends a very large amount of his free time volunteering to make your computing experience better.

Thank you..... and have a nice day.
Comment 19 Chris Gianelloni (RETIRED) gentoo-dev 2004-07-21 05:52:12 UTC
CLOSING, since there's no need for a response.