Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 543728

Summary: media-libs/FusionSound-1.1.1-r1 - ifusionsoundmusicprovider_ffmpeg.c:610:11: error: implicit declaration of function ‘avcodec_decode_audio3’
Product: Gentoo Linux Reporter: Toralf Förster <toralf>
Component: Current packagesAssignee: Joerg Bornkessel <hd_brummy>
Status: RESOLVED WONTFIX    
Severity: normal CC: sound, treecleaner
Priority: Normal Keywords: PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: Masked for removal on 2017-03-18
Package list:
Runtime testing required: ---
Bug Depends on: 596534    
Bug Blocks: 574788    
Attachments: emerge log

Description Toralf Förster gentoo-dev 2015-03-18 20:14:49 UTC
Created attachment 399212 [details]
emerge log

libtool: link: ( cd ".libs" && rm -f "libifusionsoundmusicprovider_playlist.la" && ln -s "../libifusionsoundmusicprovider_playlist.la" "libifusionsoundmusicprovider_playlist.la" )
/bin/sh ../../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include -I../../src -D_REENTRANT -I/usr/include/directfb       -D_GNU_SOURCE  -Dattribute_deprecated=\; -Wall  -march=native -O2 -pipe -Werror-implicit-function-declaration -c -o libifusionsoundmusicprovider_ffmpeg_la-ifusionsoundmusicprovider_ffmpeg.lo `test -f 'ifusionsoundmusicprovider_ffmpeg.c' || echo './'`ifusionsoundmusicprovider_ffmpeg.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../../include -I../../include -I../../src -D_REENTRANT -I/usr/include/directfb -D_GNU_SOURCE "-Dattribute_deprecated=;" -Wall -march=native -O2 -pipe -Werror-implicit-function-declaration -c ifusionsoundmusicprovider_ffmpeg.c  -fPIC -DPIC -o .libs/libifusionsoundmusicprovider_ffmpeg_la-ifusionsoundmusicprovider_ffmpeg.o
ifusionsoundmusicprovider_ffmpeg.c: In function ‘av_read_callback’:
ifusionsoundmusicprovider_ffmpeg.c:121:33: warning: comparison between ‘DirectResult’ and ‘enum <anonymous>’ [-Wenum-compare]
                     return (ret == DFB_EOF) ? 0 : -1;
                                 ^
ifusionsoundmusicprovider_ffmpeg.c: In function ‘av_seek_callback’:
ifusionsoundmusicprovider_ffmpeg.c:159:14: warning: comparison between ‘DirectResult’ and ‘enum <anonymous>’ [-Wenum-compare]
      if (ret != DFB_OK)
              ^
ifusionsoundmusicprovider_ffmpeg.c: In function ‘FFmpegStreamThread’:
ifusionsoundmusicprovider_ffmpeg.c:610:11: error: implicit declaration of function ‘avcodec_decode_audio3’ [-Werror=implicit-function-declaration]
           decoded = avcodec_decode_audio3( data->codec, 
           ^
ifusionsoundmusicprovider_ffmpeg.c: In function ‘Construct’:
ifusionsoundmusicprovider_ffmpeg.c:1235:33: warning: assignment from incompatible pointer type [enabled by default]
      thiz->AddRef               = IFusionSoundMusicProvider_FFmpeg_AddRef;
                                 ^
ifusionsoundmusicprovider_ffmpeg.c:1236:33: warning: assignment from incompatible pointer type [enabled by default]
      thiz->Release              = IFusionSoundMusicProvider_FFmpeg_Release;
                                 ^
ifusionsoundmusicprovider_ffmpeg.c: At top level:
ifusionsoundmusicprovider_ffmpeg.c:106:1: warning: ‘av_read_callback’ defined but not used [-Wunused-function]
 av_read_callback( void *opaque, uint8_t *buf, int size )
 ^
ifusionsoundmusicprovider_ffmpeg.c:132:1: warning: ‘av_seek_callback’ defined but not used [-Wunused-function]
 av_seek_callback( void *opaque, int64_t offset, int whence )
 ^
cc1: some warnings being treated as errors
Makefile:628: recipe for target 'libifusionsoundmusicprovider_ffmpeg_la-ifusionsoundmusicprovider_ffmpeg.lo' failed
make[3]: *** [libifusionsoundmusicprovider_ffmpeg_la-ifusionsoundmusicprovider_ffmpeg.lo] Error 1
make[3]: Leaving directory '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/work/FusionSound-1.1.1/interfaces/IFusionSoundMusicProvider'
Makefile:387: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/work/FusionSound-1.1.1/interfaces'
Makefile:505: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/work/FusionSound-1.1.1'
Makefile:412: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: media-libs/FusionSound-1.1.1-r1::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=media-libs/FusionSound-1.1.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-libs/FusionSound-1.1.1-r1::gentoo'`.
 * The complete build log is located at '/var/log/portage/media-libs:FusionSound-1.1.1-r1:20150318-195728.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/work/FusionSound-1.1.1'
 * S: '/var/tmp/portage/media-libs/FusionSound-1.1.1-r1/work/FusionSound-1.1.1'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/DirectFB-1.4.9-r1
 *  - /usr/lib64/libfusion-1.7.so.6
 *  - /usr/lib64/libfusion-1.7.so.6.0.0
 *  - /usr/lib64/libdirectfb-1.7.so.6
 *  - /usr/lib64/libdirectfb-1.7.so.6.0.0
 *      used by /usr/bin/dfbsee (media-video/dfbsee-0.7.4-r1)
 *      used by /usr/lib64/gpac/gm_directfb_out.so (media-video/gpac-0.5.1_pre5456)
 *  - /usr/lib64/libdirect-1.7.so.6
 *  - /usr/lib64/libdirect-1.7.so.6.0.0
Use emerge @preserved-rebuild to rebuild packages using these libraries


This is an amd64 unstable chroot image at a hardened host acting as a tinderbox.
The log is stored in amd64-unstable_20150314//var/log/portage/_emerge_20150318-205801.log
quick search: https://bugs.gentoo.org/buglist.cgi?quicksearch=media-libs%2FFusionSound


Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.3, glibc-2.20-r2, 3.19.1-hardened x86_64)
=================================================================
System uname: Linux-3.19.1-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164756 total,   2802692 free
KiB Swap:   16777212 total,  16767036 free
Timestamp of repository gentoo: Tue, 17 Mar 2015 21:00:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.25 p1.0) 2.25
ccache version 3.2.1 [disabled]
app-shells/bash:          4.3_p33-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo
dev-util/ccache:          3.2.1-r1::gentoo
dev-util/cmake:           3.1.0::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.8.3::gentoo, 4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner --tree --quiet-build --jobs 1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 apache2 avx avx2 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit corefonts cracklib crypt cups cxx dbus declarative dnssec dot dri drmkms dts dvd dvdr ecc emboss encode exif extraengine fam ffmpeg firefox flac fontconfig fortran fpm gd gdbm gif glamor gpm gtk gudev gui iconv icu isag jadetex jpeg kde kipi kvm lapack lcms libav libkms libnotify libvirtd logrotate macvtap mad mbox minizip mmx mng modules mp3 mp4 mpeg multilib mysql ncurses nls nptl ogg opengl openmp openssl pam pango pax_kernel pcre pcre16 pdf phonon plasma png policykit ppds python qemu qt3support qt4 readline sdl session spell spice sqlite sse sse2 sse4 sse4_1 sse4_2 ssh-askpass ssl ssse3 startup-notification svg tcpd theora thinkpad threads tiff tk tls truetype udev udisks uml unicode upower usb usbredir uxa v4l v4l2 video vorbis wxwidgets x264 xa xcb xcomposite xinerama xkb xml xmp xscreensaver xslt xv xvfb xvid xvmc zenmap zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldsty le oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Rafał Mużyło 2015-03-18 20:34:54 UTC
Given the error, it's most likely "your ffmpeg is too recent, please port" case.

(well, technically, the function is still there, hidden behind a compatibility define, but avcodec_decode_audio4 has been around for quite awhile)
Comment 2 Pacho Ramos gentoo-dev 2016-09-30 16:28:34 UTC
FusionSound was merged in DirectFB
Comment 3 Toralf Förster gentoo-dev 2016-10-08 09:24:59 UTC
*** Bug 596244 has been marked as a duplicate of this bug. ***
Comment 4 Michael Palimaka (kensington) gentoo-dev 2017-03-18 06:19:49 UTC
Package removed.