Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 538922

Summary: [kde overlay] kde-base/kdepim-common-libs-4.14.5 fails to build
Product: Gentoo Linux Reporter: Rinaldus <forreg>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: ab4bd, b.buschinski, david, devurandom, eugene.shalygin, gentoobugs, info, klaus818, M4rkusXXL, paolo.pedroni, rossi.f, sir_tuam, Tanktalus, ua_gentoo_bugzilla, zeekec
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
emerge --info
build.log.gz
build.log kde-base/konsolekalendar-4.14.5
build.log kde-base/korganizer-4.14.5
kde.patch
konsolekalendar-4.14.5.ebuild.patch
konsolekalendar-4.14.5.ebuild.patch
kde-4.14.5.patch

Description Rinaldus 2015-02-05 12:10:52 UTC
I can't build kdepim-common-libs-4.14.5, because it gives error during building. Please, see my build.log in attachment.

Reproducible: Always
Comment 1 Rinaldus 2015-02-05 12:17:49 UTC
Created attachment 395588 [details]
build.log
Comment 2 Rinaldus 2015-02-05 12:18:29 UTC
Created attachment 395590 [details]
emerge --info
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-05 12:26:00 UTC
Comment on attachment 395588 [details]
build.log

Please attach the entire build log to this bug report.
Comment 4 Rinaldus 2015-02-05 12:37:39 UTC
(In reply to Jeroen Roovers from comment #3)
> Comment on attachment 395588 [details]
> build.log
> 
> Please attach the entire build log to this bug report.

I tried to attach the entire build log, but size is 2.5 MB, you have 1000 KB restriction. I compressed it by gzip.
Comment 5 Rinaldus 2015-02-05 12:38:00 UTC
Created attachment 395592 [details]
build.log.gz
Comment 6 Till Schäfer 2015-02-05 13:00:34 UTC
i can conform that bug. i have exactly the same problem here.
Comment 7 Till Schäfer 2015-02-05 13:05:07 UTC
Created attachment 395596 [details]
build.log kde-base/konsolekalendar-4.14.5
Comment 8 Till Schäfer 2015-02-05 13:09:07 UTC
Created attachment 395598 [details]
build.log kde-base/korganizer-4.14.5
Comment 9 Till Schäfer 2015-02-05 13:13:05 UTC
the same failure occurs for 
- kde-base/konsolekalendar-4.14.5
- kde-base/korganizer-4.14.5
and some more packages.. i do not know if this is a following bug because i skipped kdepim-common-libs
Comment 10 Michael Palimaka (kensington) gentoo-dev 2015-02-06 18:09:00 UTC
*** Bug 539130 has been marked as a duplicate of this bug. ***
Comment 11 Coacher 2015-02-07 11:17:11 UTC
Same here. Please fix.
Comment 12 Markus 2015-02-07 11:54:55 UTC
I had some build and link errors for kde-base/kdepim-common-libs-4.14.5, too.

Modified the ebuild:
Removed "mailcommon/" from KMEXTRACTONLY and added "agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml" and "korganizer/org.kde.Korganizer.Calendar.xml".

Added KMCOMPILEONLY with "mailcommon/" and "mailimporter/".

I dont know if thats a valid way to fix it but for me it built successfully.
(kmail updated fine afterwards.)
Comment 13 Michael Palimaka (kensington) gentoo-dev 2015-02-07 14:18:07 UTC
It's a tricky issue. A solution like comment #12 fixes build for kdepim-common-libs, but then other kdepim packages fail to build for me.
Comment 14 Markus 2015-02-08 11:53:56 UTC
Its seems fixed now, for others too?
Comment 15 Till Schäfer 2015-02-08 14:26:03 UTC
nope. no change here. still fails to build with the same error.
Comment 16 Coacher 2015-02-08 20:45:40 UTC
(In reply to Markus from comment #12)
> I had some build and link errors for kde-base/kdepim-common-libs-4.14.5, too.
> 
> Modified the ebuild:
> Removed "mailcommon/" from KMEXTRACTONLY and added
> "agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml" and
> "korganizer/org.kde.Korganizer.Calendar.xml".
> 
> Added KMCOMPILEONLY with "mailcommon/" and "mailimporter/".
> 
> I dont know if thats a valid way to fix it but for me it built successfully.
> (kmail updated fine afterwards.)

IMHO, "mailcommon/" should be added to KMEXTRA (together with its dependency "mailimporter/") as otherwise libcalendarsupportcollectionpage.so.4.14.5 library provided by kdepim-common-libs package will have dangling shared library dependency (mailcommon is also a link target according to calendarsupport/CMakeLists.txt):

# readelf -d libcalendarsupportcollectionpage.so | grep mail
0x0000000000000001 (NEEDED)             Shared library: [libmailcommon.so.4]

# readelf -d libmailcommon.so | grep import
0x0000000000000001 (NEEDED)             Shared library: [libmailimporter.so.4]

And if these two are added to KMEXTRA in kdepim-common-libs ebuild, they should be also moved to KMCOMPILEONLY in kmail ebuild. Also a blocker or stricter version dependency should be added somewhere in the said ebuilds so portage won't complain about file collisions.

Currently building kdepim-common-libs and other kdepim stuff with these changes:

diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.5.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.5.ebuild
index 0492008..23d42b5 100644
--- a/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.5.ebuild
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.14.5.ebuild
@@ -31,6 +31,7 @@ RDEPEND="${DEPEND}
        !=kde-base/kmail-4.12.0
        !=kde-base/kmail-4.12.1
        !<kde-base/kmail-4.13.60
+       !<kde-base/kmail-4.14.5
        !<kde-base/korganizer-4.5.67:4
        app-crypt/gnupg
        $(add_kdebase_dep kdepim-runtime)
@@ -58,6 +59,8 @@ KMEXTRA="
        messagecore/
        messagelist/
        messageviewer/
+       mailcommon/
+       mailimporter/
        noteshared/
        pimcommon/
        templateparser/
@@ -67,8 +70,9 @@ KMEXTRACTONLY="
        kmail/
        knode/org.kde.knode.xml
        korgac/org.kde.korganizer.KOrgac.xml
+       korganizer/org.kde.Korganizer.Calendar.xml
        korganizer/org.kde.korganizer.Korganizer.xml
-       mailcommon/
+       agents/mailfilteragent/org.freedesktop.Akonadi.MailFilterAgent.xml
 "
 KMSAVELIBS="true"

diff --git a/kde-base/kmail/kmail-4.14.5.ebuild b/kde-base/kmail/kmail-4.14.5.ebuild
index 628a010..dcc25b6 100644
--- a/kde-base/kmail/kmail-4.14.5.ebuild
+++ b/kde-base/kmail/kmail-4.14.5.ebuild
@@ -48,6 +48,8 @@ KMCOMPILEONLY="
        messagecore/
        messagelist/
        messageviewer/
+       mailcommon/
+       mailimporter/
        pimcommon/
        templateparser/
        incidenceeditor-ng/
@@ -63,8 +65,6 @@ KMEXTRA="
        ksendemail/
        importwizard/
        libksieve/
-       mailcommon/
-       mailimporter/
        mboximporter/
        pimsettingexporter/
        plugins/messageviewer/

Will report when the build is finished, but my machine is a bit slow.
Comment 17 Coacher 2015-02-09 00:54:47 UTC
(In reply to Michael Palimaka (kensington) from comment #13)
> It's a tricky issue. A solution like comment #12 fixes build for
> kdepim-common-libs, but then other kdepim packages fail to build for me.

akregator builds fine as it is.

kaddressbook builds fine as it is.

kmail builds fine with these changes.

korganizer fails to build because it needs collectioncalendar compiled, which needs mailcommon to be extracted, but it is not enough. Need more time to figure out how to make this one to build.
Comment 18 Coacher 2015-02-10 06:46:01 UTC
Created attachment 396046 [details, diff]
kde.patch

OK, here's a patch for ebuilds in kde overlay that makes kdepim stuff compile happily on my amd64 machine. kdepim stuff that was tested to build fine with this patch: kdepimlibs, kdepim-common-libs, kontact, akregator, korganizer, kmail, kaddressbook.

3 ebuilds in total require changes: kdepim-common-libs, kmail, korganizer.

kdepim-common-libs now provides mailcommon and its dependency mailimporter through KMEXTRA. This is needed to make calendarsupport, which is also provided through KMEXTRA, compile happily. Also a couple of additional xml files are extracted in order to allow successful compilation of calendarsupport with mailcommon. Thanks for the ideas to Markus. A kmail blocker is added as well, see below for more info about this.

kmail now doesn't need to provide mailcommon and mailimporter, so move them to KMCOMPILEONLY. Otherwise file collisions appear for obvious reasons. I've also removed extra calendarsupport entry from KMEXTRACTONLY, since it is present in KMCOMPILEONLY.

korganizer is the most problematic thing. I was not able make it compile without adding lots of stuff to KMCOMPILEONLY and KMEXTRACTONLY. One thing requires another, which adds up to a whole bunch. The problem is with incidenceeditor-ng and calendarsupport requiring compilation of many other things. I've tried to add the least necessary amount of additional stuff. I've also removed pimcommon and korgac/org.kde.korganizer.KOrgac.xml from KMEXTRACTONLY, since pimcommon is in KMCOMPILEONLY now and that korgac xml file is extracted anyway as korgac in KMEXTRA.
Comment 19 Paolo Pedroni 2015-02-11 15:44:08 UTC
(In reply to Coacher from comment #18)
> Created attachment 396046 [details, diff] [details, diff]
> kde.patch
> 
> OK, here's a patch for ebuilds in kde overlay that makes kdepim stuff
> compile happily on my amd64 machine. kdepim stuff that was tested to build
> fine with this patch: kdepimlibs, kdepim-common-libs, kontact, akregator,
> korganizer, kmail, kaddressbook.

I had to tweak the baloo dependency in kdepim-common-libs to:

$(add_kdebase_dep baloo "" 4.14.3)

otherwise it wanted to emerge a nonexistent kde-base/baloo-4.14.5.

Then kde-base/konsolekalendar-4.14.5 fails with:

/var/tmp/portage/kde-base/konsolekalendar-4.14.5/work/konsolekalendar-4.14.5/calendarsupport/collectiongeneralpage.cpp:22:36: fatal error: pimcommon/util/pimutil.h: No such file or directory
 #include "pimcommon/util/pimutil.h"
Comment 20 Paolo Pedroni 2015-02-11 16:15:45 UTC
After adding mailcommon and pimcommon to KMEXTRACTONLY in konsolekalendar ebuild I still get:

*** No rule to make target 'lib/libcalendarsupport.so.4.14.5', needed by 'lib/libcalendarsupportcollectionpage.so.4.14.5'.  Stop.
make[2]: *** Waiting for unfinished jobs....

I'm stumped.
Comment 21 Paolo Pedroni 2015-02-11 17:03:59 UTC
Created attachment 396192 [details, diff]
konsolekalendar-4.14.5.ebuild.patch

This is a patch with the modification I had to make to successfully build konsolekalendar. I'm sure that some modules are superfluous, but at the moment I don't have the time to take them out one by one and see if it still compiles.
Comment 22 Coacher 2015-02-11 18:38:35 UTC
(In reply to Paolo Pedroni from comment #19)
> (In reply to Coacher from comment #18)
> > Created attachment 396046 [details, diff] [details, diff] [details, diff]
> > kde.patch
> > 
> > OK, here's a patch for ebuilds in kde overlay that makes kdepim stuff
> > compile happily on my amd64 machine. kdepim stuff that was tested to build
> > fine with this patch: kdepimlibs, kdepim-common-libs, kontact, akregator,
> > korganizer, kmail, kaddressbook.
> 
> I had to tweak the baloo dependency in kdepim-common-libs to:
> 
> $(add_kdebase_dep baloo "" 4.14.3)
> 
> otherwise it wanted to emerge a nonexistent kde-base/baloo-4.14.5.
> 
> Then kde-base/konsolekalendar-4.14.5 fails with:
> 
> /var/tmp/portage/kde-base/konsolekalendar-4.14.5/work/konsolekalendar-4.14.5/
> calendarsupport/collectiongeneralpage.cpp:22:36: fatal error:
> pimcommon/util/pimutil.h: No such file or directory
>  #include "pimcommon/util/pimutil.h"

Sorry, I don't use konsolekalendar. Basically all things that require calendarsupport compilation need fixes. konsolekalendar is the only such thing missing from my list above.
Comment 23 Paolo Pedroni 2015-02-12 15:59:52 UTC
Created attachment 396256 [details, diff]
konsolekalendar-4.14.5.ebuild.patch

This is a new version of the konsolekalendar patch, with the least possible modules extracted and/or compiled and still successfully building.

Hope it helps.
Comment 24 Coacher 2015-02-13 21:00:42 UTC
Created attachment 396414 [details, diff]
kde-4.14.5.patch

I've updated my previous patch to reduce the number of additional KMCOMPILEONLY entries for korganizer. Some of them were removed, others were moved to KMEXTRACTONLY. korganizer builds fine.

Thanks to Paolo Pedroni for his patch. He had noticed more things that do not require compilation.
Comment 25 Till Schäfer 2015-02-17 07:06:21 UTC
someone seems to have fixed kde-base/kdepim-common-libs-4.14.5 in the overlay. However, kde-base/konsolekalendar-4.14.5 and kde-base/korganizer-4.14.5 still do not compile.
Comment 26 Coacher 2015-02-20 21:50:37 UTC
Johannes Huber decided to mask kdepim-4.14.5 in the overlay [0]. He also mentioned that there are some runtime problems with kdepim-4.14.5. I have no such problems with my usual workflow, e.g. reading RSS feeds, reading/sending e-mails, using kontact, after I've built kdepim with the patch I've attached above. Does anybody have any runtime problems with kdepim-4.14.5 that can be related to this bug?

[0]: https://github.com/gentoo/kde/commit/18bcccdca840fc4acd8be2e8462799c24ba565e1
Comment 27 Till Schäfer 2015-02-20 22:36:57 UTC
i don't know it this is related, but i have noticed that kontact-4.14.5 crashes whenever i open the properties of my calendar. 4.15.3 did not.
Comment 28 Coacher 2015-02-20 23:06:19 UTC
(In reply to Till Schäfer from comment #27)
> i don't know it this is related, but i have noticed that kontact-4.14.5
> crashes whenever i open the properties of my calendar. 4.15.3 did not.

Hmm, kontact opens calendar fine and I can open calendar's properties without any problems via Settings->Configure KOrganizer->General->Calendars->(select my calendar in list by clicking)->Modify. Did you mean these properties?
Comment 29 Coacher 2015-02-20 23:14:51 UTC
(In reply to Coacher from comment #28)
> (In reply to Till Schäfer from comment #27)
> > i don't know it this is related, but i have noticed that kontact-4.14.5
> > crashes whenever i open the properties of my calendar. 4.15.3 did not.
> 
> Hmm, kontact opens calendar fine and I can open calendar's properties
> without any problems via Settings->Configure
> KOrganizer->General->Calendars->(select my calendar in list by
> clicking)->Modify. Did you mean these properties?

This is of course when 'Calendar' is selected in the Kontact toolbar. Another way is via Settings->Configure kontact->Calendar and then continue as above starting from General.
Comment 30 George L. Emigh 2015-02-21 00:20:05 UTC
(In reply to Coacher from comment #26)
> Johannes Huber decided to mask kdepim-4.14.5 in the overlay [0]. He also
> mentioned that there are some runtime problems with kdepim-4.14.5. I have no
> such problems with my usual workflow, e.g. reading RSS feeds,
> reading/sending e-mails, using kontact, after I've built kdepim with the
> patch I've attached above. Does anybody have any runtime problems with
> kdepim-4.14.5 that can be related to this bug?
> 
> [0]:
> https://github.com/gentoo/kde/commit/18bcccdca840fc4acd8be2e8462799c24ba565e1

I made use of that patch, had to point korganizer at kde-apps/ktimezoned and
I am not having any issues with kdepim-4.14.5 that I can tell other than konsolekalendar not building, but I don't use it.

Mail, Contacts, To-do, Feeds, Usenet all seem to work like before.
Comment 31 Paolo Pedroni 2015-02-21 09:07:56 UTC
I have no problems either with these ebuilds, once I can get them to build.
Comment 32 Maciej Mrozowski gentoo-dev 2015-02-22 22:44:06 UTC
Thanks for the patches. I'll test them and if all are fine, apply them to overlay. I fixed kmail myself and had no runtime problem since then.
Comment 33 Maciej Mrozowski gentoo-dev 2015-02-25 21:43:49 UTC
Thanks Coacher and Paolo.
I incorporated your patches, sorted KM* entries amnd pushed to overlay.
I don't exhibit any runtime issues so I unmasked them as well for testing.
Comment 34 Paolo Pedroni 2015-02-26 08:00:05 UTC
(In reply to Maciej Mrozowski from comment #33)
> Thanks Coacher and Paolo.
> I incorporated your patches, sorted KM* entries amnd pushed to overlay.
> I don't exhibit any runtime issues so I unmasked them as well for testing.

What about bug #538638? It still applies to 4.14.5 and it causes blockers between kde-base/ktimezoned and kde-apps/ktimezoned.
Comment 35 Coacher 2015-02-26 20:47:51 UTC
(In reply to Maciej Mrozowski from comment #33)
> Thanks Coacher and Paolo.
> I incorporated your patches, sorted KM* entries amnd pushed to overlay.
> I don't exhibit any runtime issues so I unmasked them as well for testing.

Thank you!