Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 538474

Summary: dev-libs/libgamin with sys-libs/musl - error: ‘PTHREAD_MUTEX_RECURSIVE_NP’ undeclared
Product: Gentoo Linux Reporter: Fredric Johansson <fredric.miscmail>
Component: [OLD] LibraryAssignee: Freedesktop bugs <freedesktop-bugs>
Status: IN_PROGRESS ---    
Severity: normal CC: gentoo
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 430702    
Attachments: Fix for building on musl
Patch against gamin git

Description Fredric Johansson 2015-02-01 21:46:57 UTC
Created attachment 395350 [details, diff]
Fix for building on musl

libgamin fails with "error: ‘PTHREAD_MUTEX_RECURSIVE_NP’ undeclared"
Attached patch from Alpine linux against hardened-dev:musl branch fixes this
Comment 1 Jeroen Roovers gentoo-dev 2015-02-02 10:38:19 UTC
Comment on attachment 395350 [details, diff]
Fix for building on musl

That doesn't look like the patch you wanted to attach.
Comment 2 Felix Janda 2015-02-02 19:15:57 UTC
Created attachment 395408 [details, diff]
Patch against gamin git
Comment 3 Anthony Basile gentoo-dev 2015-05-13 17:37:52 UTC
(In reply to Felix Janda from comment #2)
> Created attachment 395408 [details, diff] [details, diff]
> Patch against gamin git

has this gone upstream?

(In reply to Fredric Johansson from comment #0)
> Created attachment 395350 [details, diff] [details, diff]
> Fix for building on musl
> 
> libgamin fails with "error: ‘PTHREAD_MUTEX_RECURSIVE_NP’ undeclared"
> Attached patch from Alpine linux against hardened-dev:musl branch fixes this

@Fredric.  In case you haven't noticed, I added this to the overlay long ago.
Comment 4 Pacho Ramos gentoo-dev 2015-05-13 18:31:37 UTC
@blueness, feel free to commit to the tree if you want
Comment 5 Felix Janda 2015-05-14 16:25:43 UTC
The patch didn't go upstream because I didn't feel like signing up for
another bugzilla at the time. Please feel free to take it upstream.
Comment 6 Felix Janda 2016-01-09 12:39:55 UTC
There is actually already an upstream bug report about a similar problem:

https://bugzilla.gnome.org/show_bug.cgi?id=588337