Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 536984 (gcc-5)

Summary: [TRACKER] sys-devel/gcc-5
Product: Gentoo Linux Reporter: Kacper Kowalik (Xarthisius) (RETIRED) <xarthisius>
Component: Current packagesAssignee: Gentoo Toolchain Maintainers <toolchain>
Status: RESOLVED OBSOLETE    
Severity: normal CC: ab4bd, ahferroin7, ansla80, anton.kochkov, ar, asturm, bugzie, carlphilippreh, casey.webster, chainsaw, cruzki123, devurandom, email, evan.teran, gentoo, guillaume, jaak, jackdachef, jadamcze, jesse, jlp.bugs, mail, mrueg, nheghathivhistha, norbeet, O01eg, pacho, phmagic, qbt937, sandino, spider.ch, tdalman, theli.ua, ua_gentoo_bugzilla, vivo75, whissi, ziebell_marco, zorry
Priority: Normal Keywords: Tracker
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://wiki.gentoo.org/wiki/Upgrading_from_gcc-4.x_to_gcc-5.x
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 517774, 542482, 545114, 545176, 545254, 546636, 546642, 546738, 546740, 546742, 546744, 546746, 546882, 547470, 547528, 547626, 547638, 547662, 547722, 547950, 548042, 548094, 548306, 548310, 548312, 548314, 548316, 548320, 548322, 548324, 548326, 548454, 548468, 548728, 548730, 548732, 548784, 549300, 549326, 549612, 549614, 549618, 549766, 549866, 550098, 550244, 550320, 550374, 550432, 551892, 551896, 552370, 552714, 552794, 554800, 555820, 555890, 556142, 556452, 557046, 557300, 559130, 559472, 559524, 559534, 559666, 560202, 560736, 560960, 561718, 561720, 561722, 561724, 561960, 562198, 562200, 562208, 562212, 564306, 565466, 565520, 566476, 566512, 567022, 567806, 568292, 568312, 568498, 568524, 568614, 568646, 568706, 568850, 568878, 568994, 569182, 569246, 569344, 569598, 569958, 569968, 570042, 570062, 570068, 570072, 570074, 570082, 570102, 570104, 570144, 570226, 570250, 570264, 570302, 570352, 570408, 570454, 570462, 570488, 570500, 570504, 570574, 570582, 570596, 570598, 570660, 570702, 570730, 570732, 570842, 570848, 570960, 570966, 570970, 571000, 571004, 571056, 571060, 571062, 571066, 571080, 571458, 572072, 572126, 575376, 580620, 580654, 581058, 581192, 582278, 585582, 585876, 585994, 586036, 586148, 586356, 586796, 586798, 586956, 587724, 587902, 588126, 588890, 589038, 589654, 590034, 590946, 591270, 592184, 592414, 595290, 595860, 597362, 597706, 600802, 604748, 606894, 608772, 609224, 612074, 612258, 628284, 648324    
Bug Blocks: 603260    

Description Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2015-01-18 15:52:58 UTC
This is the tracker for GCC 5.0.  Do NOT report bugs here.

- create a NEW bug assigned to the maintainer of the package in question (ie. NOT gcc-porting@gentoo.org)
- Don't use this bug for issues in GCC 5.0 itself.  File a new bug and assign
it to the toolchain team.
 - Please keep this tracker free from comments.  Discussion should take place
on the relevant bugs.
Comment 1 Marek Bartosiewicz 2015-04-23 07:46:23 UTC
GCC 5.1 released: https://gcc.gnu.org/gcc-5/
Shouldn't we change the name of the tracker?
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2015-05-06 04:02:05 UTC
One thing to look out for.  If you're getting packages failing with undefined references to std::__cxx11 or [abi:cxx11], eg:

cmGlobalGenerator.cxx:(.text+0x12781): undefined reference to `Json::Value::Value(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'

it's not a bug.  It just means you need to rebuild the package that provided that symbol first.  See https://gcc.gnu.org/onlinedocs/libstdc++/manual/using_dual_abi.html for more info.
Comment 3 Alex Xu (Hello71) 2016-01-02 16:33:55 UTC
*** Bug 570446 has been marked as a duplicate of this bug. ***
Comment 4 Andreas K. Hüttel archtester gentoo-dev 2017-12-16 19:08:22 UTC
We can probably close this now.