Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 531466

Summary: net-wireless/irda-utils-0.9.18-r3 - In file included from irkbd.c:37:0: /usr/src/linux/include/linux/types.h:14:26: error: conflicting types for ‘fd_set’
Product: Gentoo Linux Reporter: ta2002 <throw_away_2002>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED TEST-REQUEST    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description ta2002 2014-12-02 17:53:57 UTC
* Package:    net-wireless/irda-utils-0.9.18-r3
 * Repository: gentoo
 * Maintainer: maintainer-needed@gentoo.org
 * USE:        abi_x86_32 elibc_glibc kernel_linux userland_GNU x86
 * FEATURES:   sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking irda-utils-0.9.18.tar.gz to /var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/work
 * Applying irda-utils-rh1.patch ...                                                                                                            [ ok ]
 * Applying irda-utils-0.9.18-makefile.diff ...                                                                                                 [ ok ]
 * Applying irda-utils-0.9.18-smcinit.diff ...                                                                                                  [ ok ]
 * Applying irda-utils-0.9.18-io.h.diff ...                                                                                                     [ ok ]
 * Applying irda-utils-0.9.18-dofail.patch ...                                                                                                  [ ok ]
 * Applying irda-utils-0.9.18-asneeded.patch ...                                                                                                [ ok ]
>>> Source unpacked in /var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/work
>>> Compiling source in /var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/work/irda-utils-0.9.18 ...
make -j3 'RPM_OPT_FLAGS=-O2 -pipe -fomit-frame-pointer -mfpmath=sse -march=core2 -mcx16 -msahf --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=2048 -mtune=core2 -fno-strict-aliasing' RPM_BUILD_ROOT=/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/image/ ROOT=/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/image/ 
 [CC]  irattach.c
 [CC]  dongle_attach.c
 [CC]  util.c
irattach.c: In function ‘main’:
irattach.c:657:6: warning: variable ‘modname’ set but not used [-Wunused-but-set-variable]
  int modname = 0; /* True is first arg is a module name */
      ^
irattach.c: In function ‘get_devlist’:
irattach.c:327:7: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
  fgets(buff, sizeof(buff), fh);
       ^
irattach.c:328:7: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
  fgets(buff, sizeof(buff), fh);
       ^
 [CC]  dongle_attach
 [CC]  irattach
 [CC]  irdaping.c
 [CC]  irdaping
 [CC]  irnetd.c
irnetd.c: In function ‘main’:
irnetd.c:84:12: warning: ignoring return value of ‘fgets’, declared with attribute warn_unused_result [-Wunused-result]
       fgets(line, 255, irnet);
            ^
 [CC]  irnetd
 [CC]  irpsion5
irpsion5.c: In function ‘discover_devices’:
irpsion5.c:131:13: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
   for (i=0;i<list->len;i++) {
             ^
irpsion5.c:144:12: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  for (i=0;i<list->len;i++) {
            ^
irpsion5.c:151:12: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  for (i=0;i<list->len;i++) {
            ^
irpsion5.c: In function ‘sendfile’:
irpsion5.c:271:9: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  if (rc != strlen(buf)) {
         ^
irpsion5.c: In function ‘handle_client’:
irpsion5.c:499:13: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  while (cnt < fsize) {
             ^
irpsion5.c:535:10: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  if (cnt != fsize) {
          ^
 [CC]  irkbd.c
In file included from irkbd.c:37:0:
/usr/src/linux/include/linux/types.h:14:26: error: conflicting types for ‘fd_set’
 typedef __kernel_fd_set  fd_set;
                          ^
In file included from /usr/include/sys/types.h:219:0,
                 from /usr/include/sys/uio.h:23,
                 from /usr/include/sys/socket.h:26,
                 from irkbd.c:31:
/usr/include/sys/select.h:75:5: note: previous declaration of ‘fd_set’ was here
   } fd_set;
     ^
In file included from irkbd.c:37:0:
/usr/src/linux/include/linux/types.h:15:25: error: conflicting types for ‘dev_t’
 typedef __kernel_dev_t  dev_t;
                         ^
In file included from /usr/include/sys/uio.h:23:0,
                 from /usr/include/sys/socket.h:26,
                 from irkbd.c:31:
/usr/include/sys/types.h:60:17: note: previous declaration of ‘dev_t’ was here
 typedef __dev_t dev_t;
                 ^
In file included from irkbd.c:37:0:
/usr/src/linux/include/linux/types.h:17:26: error: conflicting types for ‘mode_t’
 typedef __kernel_mode_t  mode_t;
                          ^
In file included from /usr/include/sys/uio.h:23:0,
                 from /usr/include/sys/socket.h:26,
                 from irkbd.c:31:
/usr/include/sys/types.h:70:18: note: previous declaration of ‘mode_t’ was here
 typedef __mode_t mode_t;
                  ^
In file included from irkbd.c:37:0:
/usr/src/linux/include/linux/types.h:25:26: error: conflicting types for ‘timer_t’
 typedef __kernel_timer_t timer_t;
                          ^
In file included from /usr/include/sys/types.h:132:0,
                 from /usr/include/sys/uio.h:23,
                 from /usr/include/sys/socket.h:26,
                 from irkbd.c:31:
/usr/include/time.h:103:19: note: previous declaration of ‘timer_t’ was here
 typedef __timer_t timer_t;
                   ^
In file included from irkbd.c:37:0:
/usr/src/linux/include/linux/types.h:134:23: error: conflicting types for ‘blkcnt_t’
 typedef unsigned long blkcnt_t;
                       ^
In file included from /usr/include/sys/uio.h:23:0,
                 from /usr/include/sys/socket.h:26,
                 from irkbd.c:31:
/usr/include/sys/types.h:235:20: note: previous declaration of ‘blkcnt_t’ was here
 typedef __blkcnt_t blkcnt_t;  /* Type to count number of disk blocks.  */
                    ^
irkbd.c: In function ‘irkbd_handle_mouse’:
irkbd.c:302:7: warning: ignoring return value of ‘write’, declared with attribute warn_unused_result [-Wunused-result]
  write(self->fifo, &scancode, 1);
       ^
Makefile:62: recipe for target 'irkbd.o' failed
make[1]: *** [irkbd.o] Error 1
Makefile:34: recipe for target 'all' failed
make: *** [all] Error 1
emake failed
 * ERROR: net-wireless/irda-utils-0.9.18-r3::gentoo failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2196:  Called die
 * The specific snippet of code:
 *       emake RPM_OPT_FLAGS="${CFLAGS}" RPM_BUILD_ROOT="${D}" ROOT="${D}" || die "emake failed"
 * 
 * If you need support, post the output of `emerge --info '=net-wireless/irda-utils-0.9.18-r3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=net-wireless/irda-utils-0.9.18-r3::gentoo'`.
 * The complete build log is located at '/var/log/portage/net-wireless:irda-utils-0.9.18-r3:20141202-163121.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/temp/environment'.
 * Working directory: '/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/work/irda-utils-0.9.18'
 * S: '/var/tmp/portage/net-wireless/irda-utils-0.9.18-r3/work/irda-utils-0.9.18'

Reproducible: Always
Comment 1 Pacho Ramos gentoo-dev 2015-11-08 11:25:11 UTC
I cannot reproduce with irda-utils-0.9.18-r4, please retry