Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 528770

Summary: www-apache/mod_wsgi-3.5 with /bin/sh -> dash - /usr/share/build-1/libtool: 1555: /usr/share/build-1/libtool: preserve_args+= --silent: Permission denied
Product: Gentoo Linux Reporter: Bodo Graumann <mail>
Component: [OLD] LibraryAssignee: Dirkjan Ochtman <djc>
Status: RESOLVED WORKSFORME    
Severity: normal CC: alexander
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 526268    
Attachments: build.log

Description Bodo Graumann 2014-11-09 22:44:10 UTC
When dash is used as the system shell, mod_wsgi fails to build with errors similar to that of apache in
https://bugs.gentoo.org/show_bug.cgi?id=526178

Reproducible: Always
Comment 1 Bodo Graumann 2014-11-09 22:46:14 UTC
Created attachment 388980 [details]
build.log
Comment 2 Dirkjan Ochtman gentoo-dev 2014-11-10 09:04:20 UTC
So I guess the same thing goes here, I guess, that you have to re-emerge apr.
Comment 3 Bodo Graumann 2014-11-10 09:46:34 UTC
Reinstalling dev-libs/apr-1.5.0-r2 indeed solved the problem. /usr/share/build-1/libtool now explicitely depends on /bin/bash. Maybe apr should be bumped to dev-libs/apr-1.5.0-r3?
Comment 4 Alexander Tsoy 2014-11-10 10:51:35 UTC
See bug 528798
Comment 5 Dirkjan Ochtman gentoo-dev 2016-02-08 08:37:08 UTC
I don't think this is still relevant.