Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 526176

Summary: net-misc/networkmanager-l2tp-0.9.8.7 - L2TP support for NetworkManager
Product: Gentoo Linux Reporter: Yichao Zhou <broken.zhou>
Component: New packagesAssignee: Default Assignee for New Packages <maintainer-wanted>
Status: RESOLVED FIXED    
Severity: enhancement CC: alexander, gnome, hermes.trismegistos, hiwatari.seiji, lkd-gentoo, maggu2810, peter.volkov, xms-00
Priority: Normal Keywords: EBUILD
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://github.com/seriyps/NetworkManager-l2tp
See Also: https://bugs.gentoo.org/show_bug.cgi?id=553162
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: networkmanager-l2tp-0.9.8.7.ebuild
networkmanager-l2tp-0.9.8.7-r1.ebuild

Description Yichao Zhou 2014-10-21 06:34:11 UTC
NetworkManager L2TP plugin

Reproducible: Always
Comment 1 Yichao Zhou 2014-10-21 06:36:24 UTC
Created attachment 387108 [details]
networkmanager-l2tp-0.9.8.7.ebuild
Comment 2 Lars 2015-04-07 22:58:45 UTC
The attached ebuild should depend on gnome-base/libgnome-keyring.

Without it emerge fails with:

configure: error: Package requirements (gnome-keyring-1) were not met
Comment 3 Lars 2015-04-07 23:10:28 UTC
The ebuild should also rdepend on net-dialup/xl2tpd

Otherwise connection fails with:

<warn>  VPN connection 'VPN connection 1' failed to connect: 'Could not find the xl2tpd binary.'.


But apart from this, the plug-in works for me! Thank you!
Comment 4 Lars 2015-04-10 18:49:55 UTC
Created attachment 400988 [details]
networkmanager-l2tp-0.9.8.7-r1.ebuild
Comment 5 Lars 2015-04-10 18:50:45 UTC
Comment on attachment 400988 [details]
networkmanager-l2tp-0.9.8.7-r1.ebuild

Ebuild depending on gnome-base/libgnome-keyring and net-dialup/xl2tpd
Comment 6 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2020-03-03 20:28:53 UTC
Closing as we have in the tree it under net-vpn/networkmanager-l2tp