Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 525410

Summary: LXQt 0.8.0 version bump
Product: Gentoo Linux Reporter: Alpha Bravo <aos>
Component: Current packagesAssignee: Jauhien Piatlicki (RETIRED) <jauhien>
Status: RESOLVED FIXED    
Severity: normal CC: doug.hunley, gentoo, jrmalaq, lxqt, Manfred.Knick, orzel, pageexec, paolo.pedroni, tdalman, v10lator, wireless, zemarialm
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=527446
https://bugs.gentoo.org/show_bug.cgi?id=524650
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 454132, 528070, 528676    
Bug Blocks:    
Attachments: Ugly ebuild for dev-qt/qtmimetypes-9999
Fixed ebuild for dev-qt/qtmimetypes-9999
liblxqt-9999.ebuild
lxqt : a minimal config-randr.conf for 4 separate screens

Description Alpha Bravo 2014-10-14 13:57:30 UTC
LXQt 0.8.0 released 2014/13/10
(cf. http://sourceforge.net/p/lxde/mailman/message/32927295/)

In case someone needs ebuilds, there's a pull request pending for the qt-overlay:
https://github.com/gentoo/qt/pull/81

Reproducible: Always
Comment 1 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-14 18:31:22 UTC
I will look at LXQt related issues this weekend (or before it).

Thanks for reporting.
Comment 2 Thomas 2014-10-15 04:45:47 UTC
(In reply to Alpha Bravo from comment #0)
> In case someone needs ebuilds, there's a pull request pending for the
> qt-overlay:
> https://github.com/gentoo/qt/pull/81

Did you write these ebuilds? Cause they have errors. What I found so far:
- razorqt-base/libqtxdg-1.0.0 won't compile with QT 4:

-- checking for module 'QtMimeTypes'
--   package 'QtMimeTypes' not found
CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:284 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPkgConfig.cmake:338 (_pkg_check_modules_internal)
  CMakeLists.txt:160 (pkg_check_modules)

This is solveable by setting -DUSE_QTMIMETYPES=OFF but then lxqt-base/lxqt-config-0.8.0 fails to compile. Does anyone know how to fix this the right way?
- The tar.xz package for lxqt-base/lxqt-policykit-0.8.0 has a new subdirectory. A quick&dirty workaround is to add this to the ebuild:

src_prepare() {
	cd "${S}"
	mv lxqt-policykit-0.8.0/* ./
	rm lxqt-policykit-0.8.0/.git*
	rmdir lxqt-policykit-0.8.0 || die
	cmake-utils_src_prepare
}

- Almost all manifest files are corruted. Deleting and recreating them worked.
Comment 3 Thomas 2014-10-15 06:04:10 UTC
Created attachment 386706 [details]
Ugly ebuild for dev-qt/qtmimetypes-9999

I tried to hack an ebuild for QtMimeTypes together, be warned that it's ugly.

Anyway, this is what I get:
Building CXX object CMakeFiles/qtxdg.dir/xdgdesktopfile.cpp.o
/usr/bin/x86_64-pc-linux-gnu-g++  -DHAVE_QTMIMETYPES -DQT_CORE_LIB -DQT_GUI_LIB -DQT_XML_LIB -DTRANSLATIONS_DIR=\"/usr/share/libqtxdg\" -Dqtxdg_EXPORTS  -DNDEBUG -march=native -O2 -pipe -fno-ident -flto=3 -fuse-linker-plugin  -fPIC -isystem /usr/include/qt4 -isystem /usr/include/qt4/QtGui -isystem /usr/include/qt4/QtXml -isystem /usr/include/qt4/QtCore -I/usr/include/QtMimeTypes    -Wall -o CMakeFiles/qtxdg.dir/xdgdesktopfile.cpp.o -c /var/tmp/portage/razorqt-base/libqtxdg-1.0.0/work/libqtxdg/xdgdesktopfile.cpp

/var/tmp/portage/razorqt-base/libqtxdg-1.0.0/work/libqtxdg/xdgdesktopfile.cpp:39:25: fatal error: QMimeDatabase: No such file or directory
 #include <QMimeDatabase>
                         ^
compilation terminated.
CMakeFiles/qtxdg.dir/build.make:280: recipe for target 'CMakeFiles/qtxdg.dir/xdgdesktopfile.cpp.o' failed

but:
$ ls -l /usr/include/QtMimeTypes
insgesamt 12
lrwxrwxrwx 1 root root   15 15. Okt 07:53 QMimeDatabase.h -> qmimedatabase.h
lrwxrwxrwx 1 root root   11 15. Okt 07:53 QMimeType.h -> qmimetype.h
lrwxrwxrwx 1 root root   14 15. Okt 07:53 QMime_global.h -> qmime_global.h
-rw-r--r-- 1 root root  985 15. Okt 07:52 qmime_global.h
-rw-r--r-- 1 root root 3467 15. Okt 07:52 qmimedatabase.h
-rw-r--r-- 1 root root 3554 15. Okt 07:52 qmimetype.h

I guess I'll give up for now.
Comment 4 Thomas 2014-10-15 06:30:22 UTC
Created attachment 386708 [details]
Fixed ebuild for dev-qt/qtmimetypes-9999

Damn, why did I try to port the Arch PKGBUILD again? Anyway, here's the fixed ebuild. None the less razorqt-base/libqtxdg-1.0.0 still fails to build:
Linking CXX shared library libqtxdg.so
/usr/bin/cmake -E cmake_link_script CMakeFiles/qtxdg.dir/link.txt --verbose=1    
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -march=native -O2 -pipe -fno-ident -flto=3 -fuse-linker-plugin -fno-lto -fno-use-linker-plugin   -Wl,-O1 -Wl,--as-needed -march=native -O2 -pipe -fno-ident -flto=3 -fuse-linker-plugin -fno-lto -fno-use-linker-plugin -shared -Wl,-soname,libqtxdg.so.1 -o libqtxdg.so.1.0.0 CMakeFiles/qtxdg.dir/xdgaction.cpp.o CMakeFiles/qtxdg.dir/xdgdesktopfile.cpp.o CMakeFiles/qtxdg.dir/xdgdirs.cpp.o CMakeFiles/qtxdg.dir/xdgicon.cpp.o CMakeFiles/qtxdg.dir/xdgmenuapplinkprocessor.cpp.o CMakeFiles/qtxdg.dir/xdgmenu.cpp.o CMakeFiles/qtxdg.dir/xdgmenulayoutprocessor.cpp.o CMakeFiles/qtxdg.dir/xdgmenureader.cpp.o CMakeFiles/qtxdg.dir/xdgmenurules.cpp.o CMakeFiles/qtxdg.dir/xdgmenuwidget.cpp.o CMakeFiles/qtxdg.dir/xmlhelper.cpp.o CMakeFiles/qtxdg.dir/xdgautostart.cpp.o CMakeFiles/qtxdg.dir/qiconfix/qiconloader_qt4.cpp.o CMakeFiles/qtxdg.dir/xdgmimetype.cpp.o CMakeFiles/qtxdg.dir/moc_xdgaction.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenuapplinkprocessor.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenu.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenu_p.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenureader.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenurules.cxx.o CMakeFiles/qtxdg.dir/moc_xdgmenuwidget.cxx.o /usr/lib64/qt4/libQtCore.so /usr/lib64/qt4/libQtGui.so /usr/lib64/qt4/libQtXml.so -lQtMimeTypes -lQtCore -Wl,-rpath,/usr/lib64/qt4: 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.1/../../../../x86_64-pc-linux-gnu/bin/ld: error: cannot find -lQtCore
collect2: error: ld returned 1 exit status
CMakeFiles/qtxdg.dir/build.make:791: recipe for target 'libqtxdg.so.1.0.0' failed
Comment 5 Alpha Bravo 2014-10-15 17:21:13 UTC
It seems the problem with libqtxdg needs to be addressed upstream:
https://github.com/lxde/libqtxdg/issues/29

The lxqt-policykit ebuild meanwhile is fixed in the pull request, it's sufficient to delete/comment out the line that defines the "S"-variable.
Comment 6 Alpha Bravo 2014-10-15 17:40:08 UTC
Upstream suggests to simply build with Qt5 as the next release will drop Qt4 support anyway. I totally agree, LXQt with Qt5 works like a charm!
Maybe the ebuilds should depend on Qt5 and - if in tree - be masked until https://bugs.gentoo.org/show_bug.cgi?id=qt5 is resolved?
Comment 7 Davide Pesavento gentoo-dev 2014-10-15 18:00:55 UTC
(In reply to Alpha Bravo from comment #6)
> Maybe the ebuilds should depend on Qt5 and - if in tree - be masked until
> https://bugs.gentoo.org/show_bug.cgi?id=qt5 is resolved?

Sounds reasonable to me.
Comment 8 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-15 19:02:26 UTC
For me too, so I will do this this week:

1. Fix LXQt 0.7.0 open bugs

2. Review live ebuilds and drop Qt4 support there

3. Review/unify/drop Qt4 support in ebuilds for 0.8.0 and add them (masked) to the tree
Comment 9 Thomas 2014-10-17 08:41:49 UTC
Even with Qt5 there's a issue:
USE="qt5 sysstat" emerge =lxqt-base/lxqt-panel-0.8.0
fails cause there's no Qt5 version of lxqt-base/libsysstat in portage. Also it doesn't look like the LXQt team released such a version so the only way of getting this to work is to patch the live ebuild:

+IUSE="qt5"
 
-DEPEND="dev-qt/qtcore:4"
+DEPEND="
+       !qt5? (
+               dev-qt/qtcore:4
+       )
+       qt5? (
+               dev-qt/qtcore:5
+       )"
 RDEPEND="${DEPEND}"
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_use qt5 QT5)
+       )
+       cmake-utils_src_configure
+}
Comment 10 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-18 11:14:57 UTC
I've started reviewing of live ebuilds in overlay.
Comment 11 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-18 17:05:46 UTC
Created attachment 386902 [details]
liblxqt-9999.ebuild

Could somebody, please, check if this package builds for him. As for me both live and 0.8.0 versions fail with

/usr/bin/cmake -E cmake_link_script CMakeFiles/lxqt-qt5.dir/link.txt --verbose=1
/usr/bin/x86_64-pc-linux-gnu-g++  -fPIC -O2 -pipe  -fPIE -fPIE -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wl,-no-undefined -Wall  -Wl,-O1 -Wl,--as-needed -shared -Wl,-soname,liblxqt-qt5.so.0 -o liblxqt-qt5.so.0.8.0 CMakeFiles/lxqt-qt5.dir/aboutdialog/lxqtaboutdialog.cpp.o CMakeFiles/lxqt-qt5.dir/aboutdialog/technicalinfo.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtxfitman.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtplugininfo.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtpowermanager.cpp.o CMakeFiles/lxqt-qt5.dir/addplugindialog/lxqtaddplugindialog.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtsettings.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtscreensaver.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtapplication.cpp.o CMakeFiles/lxqt-qt5.dir/lxqttranslator.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtprogramfinder.cpp.o CMakeFiles/lxqt-qt5.dir/configdialog/lxqtconfigdialog.cpp.o CMakeFiles/lxqt-qt5.dir/configdialog/lxqtpageselectwidget.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtpower/lxqtpower.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtpower/lxqtpowerproviders.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtnotification.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtautostartentry.cpp.o CMakeFiles/lxqt-qt5.dir/translatorsinfo/translatorsinfo.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtgridlayout.cpp.o CMakeFiles/lxqt-qt5.dir/lxqtrotatedwidget.cpp.o CMakeFiles/lxqt-qt5.dir/notifications_interface.cpp.o CMakeFiles/lxqt-qt5.dir/qrc_translatorsinfo.cpp.o CMakeFiles/lxqt-qt5.dir/lxqt-qt5_automoc.cpp.o /usr/lib64/libQt5Widgets.so.5.3.2 /usr/lib64/libQt5DBus.so.5.3.2 /usr/lib64/libQt5X11Extras.so.5.3.2 -lX11 -lQt5Xdg /usr/lib64/libQt5Widgets.so.5.3.2 /usr/lib64/libQt5Xml.so.5.3.2 /usr/lib64/libQt5Gui.so.5.3.2 /usr/lib64/libQt5Core.so.5.3.2 
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/lxqt-qt5.dir/lxqtplugininfo.cpp.o: warning: relocation against `_ZN4LxQt10PluginInfo6searchERK11QStringListRK7QStringS6_' in readonly section `.text'.
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: CMakeFiles/lxqt-qt5.dir/lxqtsettings.cpp.o: relocation R_X86_64_PC32 against symbol `_ZN4LxQt8SettingsC2ERK7QStringP7QObject' can not be used when making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
CMakeFiles/lxqt-qt5.dir/build.make:866: recipe for target 'liblxqt-qt5.so.0.8.0' failed
make[2]: *** [liblxqt-qt5.so.0.8.0] Error 1
make[2]: Leaving directory '/var/tmp/portage/lxqt-base/liblxqt-0.8.0/work/liblxqt-0.8.0_build'
CMakeFiles/Makefile2:63: recipe for target 'CMakeFiles/lxqt-qt5.dir/all' failed
make[1]: *** [CMakeFiles/lxqt-qt5.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/lxqt-base/liblxqt-0.8.0/work/liblxqt-0.8.0_build'
Makefile:136: recipe for target 'all' failed
make: *** [all] Error 2
Comment 12 Alpha Bravo 2014-10-18 22:04:09 UTC
(In reply to Jauhien Piatlicki from comment #11)
> Created attachment 386902 [details]
> liblxqt-9999.ebuild
> 
> Could somebody, please, check if this package builds for him. As for me both
> live and 0.8.0 versions fail with

for me it works (qt 5.3.2, amd64 no-multilib, gcc-4.8.3)
Comment 13 Alpha Bravo 2014-10-18 22:50:51 UTC
this one builds as well here: https://github.com/hashashini/gentoo-qt/blob/master/lxqt-base/liblxqt/liblxqt-0.8.0.ebuild
Comment 14 Alpha Bravo 2014-10-18 23:08:01 UTC
(In reply to Jauhien Piatlicki from comment #11)
> /usr/lib64/libQt5Gui.so.5.3.2 /usr/lib64/libQt5Core.so.5.3.2 
> /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/
> ld: CMakeFiles/lxqt-qt5.dir/lxqtplugininfo.cpp.o: warning: relocation
> against `_ZN4LxQt10PluginInfo6searchERK11QStringListRK7QStringS6_' in
> readonly section `.text'.

I believe I noticed elsewhere (something with sddm) you used gcc-4.8.3 - I suppose that's intended to also test on stable - but if not I wanted to have pointed it out.
Comment 15 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-18 23:09:38 UTC
Yes, thanks. Forgot to switch it. And may be also this is the reason of the problem with this ebuild.
Comment 16 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-18 23:11:23 UTC
Ah, moment, here everything is ok: gcc-4.7.3 is stable.
Comment 17 Alpha Bravo 2014-10-18 23:52:10 UTC
Ok just testet building with gcc-4.7.3 and voila I get the same error, with both.
Comment 18 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-18 23:56:17 UTC
Thanks for info. I will restrict compiler version in ebuild then.
Comment 19 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-19 20:43:14 UTC
For those who is interested in progress: I am still reviewing live ebuilds. After review is finished I will push them to the qt overlay. Then I hope the same ebuilds could be used for the release and after its testing it will be commited to the tree. For those unpatient: estimation time ~1 week.
Comment 20 Thomas Capricelli 2014-10-19 23:09:02 UTC
(In reply to Jauhien Piatlicki from comment #19)
> For those who is interested in progress

Thanks a lot for the update and for the work.
Comment 21 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-26 00:33:35 UTC
Live ebuilds reviewed and updated, please, test them.

Next steps:

-- versioned release ebuilds will be added to the overlay

-- after week or two they will be propagated to the tree
Comment 22 Manfred Knick 2014-10-26 16:07:15 UTC
(In reply to Jauhien Piatlicki from comment #21)
> Live ebuilds reviewed and updated, please, test them.


_HINT:_


# emerge -p =lxqt-meta-9999
...
emerge: there are no ebuilds to satisfy "sys-auth/polkit-qt[qt5(-)]".


can be resolved by:

1.)   Copying the ebuild for sys-auth/polkit-qt-9999 
          from kde-overlay into e.g.
          /usr/local/portage/local-overlay/sys-auth/polkit-qt

2.)   # echo "-qt5" >> /etc/portage/profile/use.mask

This will result into:

          sys-auth/polkit-qt-9999 [0.112.0] USE="qt5*"
Comment 23 Michael Palimaka (kensington) gentoo-dev 2014-10-26 16:08:59 UTC
(In reply to Manfred Knick from comment #22)
> (In reply to Jauhien Piatlicki from comment #21)
> > Live ebuilds reviewed and updated, please, test them.
> 
> 
> _HINT:_
> 
> 
> # emerge -p =lxqt-meta-9999
> ...
> emerge: there are no ebuilds to satisfy "sys-auth/polkit-qt[qt5(-)]".
> 
> 
> can be resolved by:
> 
> 1.)   Copying the ebuild for sys-auth/polkit-qt-9999 
>           from kde-overlay into e.g.
>           /usr/local/portage/local-overlay/sys-auth/polkit-qt
> 
> 2.)   # echo "-qt5" >> /etc/portage/profile/use.mask
> 
> This will result into:
> 
>           sys-auth/polkit-qt-9999 [0.112.0] USE="qt5*"

0.112.0 has qt5 USE flag, it just needs unmasking.
Comment 24 Manfred Knick 2014-10-26 17:13:37 UTC
(In reply to Michael Palimaka (kensington) from comment #23)
> (In reply to Manfred Knick from comment #22)

Thanks!

_Question:_

I could not find
     lxqt-config-monitor
which was supposed to replace the (buggy)
     lxqt-config-randr
(at least temporarily).
Comment 25 Thomas 2014-10-26 17:24:18 UTC
(In reply to Manfred Knick from comment #24)
> I could not find
>      lxqt-config-monitor

equery b (which lxqt-config-monitor) # Don't wonder about the syntax, I'm experimenting with app-shells/fish atm
 * Searching for /usr/bin/lxqt-config-monitor ... 
lxqt-base/lxqt-config-0.8.0 (/usr/bin/lxqt-config-monitor)

These are still the ebuilds from https://github.com/gentoo/qt/pull/81 so I'm not sure if the live ebuild includes this, too, but I guess so.
Comment 26 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-26 17:27:53 UTC
qt5 USE should be unmasked, obviously.

lxqt-config-monitor is a part of lxqt-config now.

Some specific ebuilds, that are not part of LXQt core are still in progress (e.g. media-gfx/lximage-qt).
Comment 27 Manfred Knick 2014-10-26 17:45:43 UTC
Luckily I would be able to provide a

   multiple device   (2)
   multiple monitor  (4)

-> multiple (separate X-) screens (4)

setup for testing LXQT 0.8 , if you like?

(Please note:
 Not to be mixed up with a Xinerama setup - 
 that _may_ be a different story.)


The details of HW and configuration are already published
in the attachments of BUG #525780 ,

as well as overall survey results in coment #9.


The result with LXQT 0.7 was as follows:

- 'startx /usr/bin/startlxqt' basically succeeded
- first screen working
- others black
- mouse can be correctly moved across all four (resp. five) screens
- with e.g. 'DISPLAY=":0.3" && export DISPLAY && echo $DISPLAY' in xterm on first screen,
- - X Applications can be started on a diffferent screen,
- - mouse actions can be executed,
- - but keyboard input into the application was not possible.

- I created a minimalist .lxqt / config-randr.conf [ c.f. attachment below ]
  in order to guide LXQT window layout,
- - but that did not solve the problem by any means.


My first result with LXQT 0.8 some minutes ago was very similar:

- 'startx /usr/bin/startlxqt' basically succeeded
- first screen more or less working
- others black
- mouse can be correctly moved across all four (resp. five) screens

- Error message window appears:
- - "_Desktop_ crashed too many times.
- -  Its autorestart has been disabled until next login."

- /var/log/Xorg.0.log does not contain any additional enlightenment
  after the usual startup messages ( like after 'startx /usr/bin/twm' ).


Please point out any additional information
that could be of any value for you.

Thanks.
Comment 28 Manfred Knick 2014-10-26 17:46:55 UTC
Created attachment 387470 [details]
lxqt : a minimal config-randr.conf for 4 separate screens
Comment 29 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-26 19:12:53 UTC
=net-misc/lxqt-openssh-askpass-9999 fails with Qt from the overlay for me at the moment.
Comment 30 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-27 18:20:20 UTC
Ok, with Qt from the tree net-misc/lxqt-openssh-askpass fails also now. May be something was broken by upstream. If 0.8.0 version would work I will postpone fixing of live ebuild for it.

Going to push 0.8.0 ebuilds for LXQt to the overlay now.
Comment 31 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-10-30 11:50:15 UTC
LXQt 0.8.0 ebuilds are available in the overlay. Please, test them and report any problems as separated bugs making them blockers of this bug.

emerge -va '=lxqt-base/lxqt-meta-0.8.0'.

I will propagate this ebuilds to the tree in a week if everything is ok.
Comment 32 Thomas Capricelli 2014-10-31 14:52:34 UTC
Hello. I did test 0.8 today (with tree / overlays updated today as well of course).

Everything emerge fine without any problem.

The resulting desktop is a complete mess. I had to switch back to 0.7 to get something usable. The bugs are too many to list them all here, but here are a few :

* desktop switching doesn't work (control-f1, f2, ...). i'm using the same openbox that works well with lxqt 0.7. A commonly working turnaround is to press 'control' once more after a failed switch : often it brings me the right desktop. Reminds me of KDE...

* the panel background is either transparent (or just not there?), especially at start, or black. I can't see the clock for example, but if i click on the big black rectangle where it's supposed to be, i get the usual calendar.

* lxqt-config-appearance segfaulted while i was changing the cursor. As a result, it wouldn't start anymore (segfault at start), and, actually, a lot of other programs had the same problem, most importantly chromium. Using strace, i could figure out the problem was related to /home/orzel/.icons/default/index.theme, whose header says "# Written by lxqt-config-appearance". First, removing the line 
     Inherits=default
would fix it, but not for long : it would be brought back, presumably by some lxqt stuff.
So i've changed it to 
     Inherits=whiteglass
and now it works better. But i dont dare starting lxqt config appearance anymore.


I don't know where those problems come from (lxqt code ? ebuilds ? maybe even some local configuration problems not triggered by lxqt 0.7 ?)
Comment 33 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-11-02 22:27:49 UTC
(In reply to Thomas Capricelli from comment #32)

Seems to be a problem of upstream code related with local configuration, not the ebuild related one. I would ask you, if possible, install LXQt-0.8.0 with clean configuration and see if the problem is still there.

From my side I will also try to test it in VM more (as I did only some basic tests, just seeing that it starts and works properly, because I am still using LXDE as my main desktop and looking at LXQt as being in beta).

Also, other interested ones, please give here some feedback reporting both problems you have (in separated bugs) and normal work of 0.8.0 version (in this bug).
Comment 34 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-11-02 22:36:04 UTC
(In reply to Manfred Knick from comment #27)

Please, ask upstream about it.
Comment 35 Andreas Schürch gentoo-dev 2014-11-03 20:20:39 UTC
(In reply to Jauhien Piatlicki from comment #33)
> Also, other interested ones, please give here some feedback reporting both
> problems you have (in separated bugs) and normal work of 0.8.0 version (in
> this bug).
Works better than 0.7.0 for me so far here! :-)
I'm using slim as DM and openbox as WM right now.
I got no problems with the clock, panel, vt switching and also no segfaults at configuring or such... Seems to be quite usable! :-)
This is quite a fresh install!
Comment 36 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-11-08 17:58:49 UTC
Moved to the tree. Will stay masked until Qt5 unmasking. In case of any problems, please, create separated bugs blocking this one.
Comment 37 Thomas Capricelli 2014-11-21 01:49:11 UTC
the ebuild for 0.8.0 is both in the qt overlay and the main tree, that feels weird.
Comment 38 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-11-21 10:20:11 UTC
@Thomas Capricelli: thanks, I forgot to remove meta ebuild from the overlay.
Comment 39 Jauhien Piatlicki (RETIRED) gentoo-dev 2014-11-21 10:24:11 UTC
@Thomas: all 0.8.0 ebuilds should be fully removed from the overlay now.
Comment 40 Thomas Capricelli 2014-11-21 13:56:46 UTC
(In reply to Jauhien Piatlicki from comment #39)
> @Thomas: all 0.8.0 ebuilds should be fully removed from the overlay now.

yeps, i can confirm, thanks :-)
Comment 41 Ben de Groot (RETIRED) gentoo-dev 2015-02-02 15:22:06 UTC
Unmasked together with Qt5.