Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 523606

Summary: sys-apps/man-db-2.6.6 - Can't locate Locale/Po4a/Chooser.pm in @INC
Product: Gentoo Linux Reporter: Thomas <Thomas.Eschenbacher>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Thomas 2014-09-24 11:35:19 UTC
Today I tried to switch from sys-apps/man to sys-apps/man-db, but compilation failed (see message below).

Compilation worked fine after manually emerging app-text/po4a.
=> Somehow the dependency in the ebuild did not work, although I have the "nls" use flag set !?



----------------------------------------------
make[2]: Entering directory `/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man'
Making all in po4a
make[3]: Entering directory `/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man/po4a'
rm -rf ./tmp-po
/bin/mkdir -p ./tmp-po
set -e; for f in po/man-db-manpages.pot po/da.po po/de.po po/fr.po po/id.po po/ja.po po/nl.po po/pl.po po/ru.po po/zh_CN.po; do \
        base=`basename $f`; \
        cp -p ./$f ./tmp-po/; \
        chmod u+w ./tmp-po/$base; \
done
PERL5LIB=. po4a --variable srcdir=../../man --variable builddir=../../man --variable podir=./tmp-po --keep 0 ./po4a.cfg
Can't locate Locale/Po4a/Chooser.pm in @INC (you may need to install the Locale::Po4a::Chooser module) (@INC contains: . /etc/perl /usr/local/lib/perl5/5.18.2/i686-linux /usr/local/lib/perl5/5.18.2 /usr/lib/perl5/vendor_perl/5.18.2/i686-linux /usr/lib/perl5/vendor_perl/5.18.2 /usr/local/lib/perl5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.18.2/i686-linux /usr/lib/perl5/5.18.2 .) at /usr/bin/po4a line 583.
BEGIN failed--compilation aborted at /usr/bin/po4a line 583.
make[3]: *** [all-local] Error 2
make[3]: Leaving directory `/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man/po4a'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6/man'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/portage/sys-apps/man-db-2.6.6/work/man-db-2.6.6'
make: *** [all] Error 2
 * ERROR: sys-apps/man-db-2.6.6::gentoo failed (compile phase):
Comment 1 Jeroen Roovers gentoo-dev 2014-09-24 12:49:02 UTC

*** This bug has been marked as a duplicate of bug 41124 ***