Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 518162

Summary: =sci-calculators/calculator-1.6.43 stabilization request
Product: Gentoo Linux Reporter: Manuel Rüger (RETIRED) <mrueg>
Component: [OLD] Keywording and StabilizationAssignee: Matti Bickel (RETIRED) <mabi>
Status: RESOLVED FIXED    
Severity: normal CC: pinkbyte, sci
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 512122    

Description Manuel Rüger (RETIRED) gentoo-dev 2014-07-26 12:42:37 UTC
Can we get it stable and remove the EAPI1 ebuild (calculator-1.6.36) please? Thanks!
Comment 1 Sergey Popov gentoo-dev 2014-09-25 06:48:34 UTC
It's not that easy, we should stabilize x11-libs/fox-1.7.47, but bug #523206 is preventing this
Comment 2 Matti Bickel (RETIRED) gentoo-dev 2014-11-10 21:59:34 UTC
The only reason fox:1.7 isn't stable is that it's a development version of the fox toolkit. It was my understanding that this disqualifies it from the stable tree.

Since we have calculator-1.6.43 with EAPI4 readily available since.. ages, arches, can you please stable this version instead?

The installed binaries should be nearly identical to the previous version, so I guess compile & install testing is fine.

If you want to drop stable keywords for this package, just un'cc your arch from the bug. I'll remove the old version once no arch remains.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2014-11-11 12:28:43 UTC
Stable for HPPA.
Comment 4 Myckel Habets 2014-11-16 18:20:26 UTC
Builds and runs fine on x86. Please mark stable for x86.
Comment 5 Raúl Porcel (RETIRED) gentoo-dev 2015-01-15 10:15:01 UTC
sparc/x86 stable
Comment 6 Manuel Rüger (RETIRED) gentoo-dev 2015-02-10 18:07:14 UTC
@ppc, ppc64: ping?
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-02-20 09:21:24 UTC
All done.