Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 51803

Summary: emerge of gentoo-dev-sources fails -- Unable to dry-run patch
Product: Gentoo Linux Reporter: Andrew Miesem <andy>
Component: [OLD] Core systemAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Andrew Miesem 2004-05-23 01:04:24 UTC
I ran 'emerge sync' as I do on a regular basis.  When I subsequently ran 'emerge -vup world', I got the following feedback:
=============================================================
These are the packages that I would merge, in order:
 
Calculating world dependencies ...done!
[ebuild  N    ] sys-kernel/gentoo-dev-sources-2.6.6  -build  0 kB
 
Total size of downloads: 0 kB
=============================================================
When I then run 'emerge -v world', it seems to be going okay, then bails out as follows:
=============================================================
01:44:22 (26.52 KB/s) - `/usr/portage/distfiles/genpatches-2.6-6.30-base.tar.bz2' saved [269049/269049]
 
>>> md5 src_uri ;-) linux-2.6.6.tar.bz2
>>> md5 src_uri ;-) genpatches-2.6-6.30-base.tar.bz2
>>> md5 src_uri ;-) genpatches-2.6-6.30-extras.tar.bz2
>>> Preparing to unpack...
>>> Unpacking source...
>>> Unpacking linux-2.6.6.tar.bz2 to /var/tmp/portage/gentoo-dev-sources-2.6.6/work
 * genpatches-2.6-6.30-base.tar.bz2 unpacked
 * genpatches-2.6-6.30-extras.tar.bz2 unpacked
 * Applying 1310_k8_cardbus_io.patch...                                            [ ok ] * Applying 1315_alpha-sysctl-uac.patch...                                         [ ok ] * Applying 2110_bcm5700_broadcom_gigabit_drvr_11272003.patch...                   [ ok ] * Applying 2115_fa311-mac-address-fix.patch...                                    [ ok ] * Applying 2120_ipw2100-0.40-2.6.5.patch...                                       [ ok ] * Applying 2320_adaptec_dpt_i2o.patch...                                          [ !! ] 
 * Please attach /var/tmp/portage/gentoo-dev-sources-2.6.6/temp/2320_adaptec_dpt_i2o.err to any bug you may post.
 
!!! ERROR: sys-kernel/gentoo-dev-sources-2.6.6 failed.
!!! Function unipatch, Line 485, Exitcode 0
!!! Unable to dry-run patch.
=============================================================

Reproducible: Always
Steps to Reproduce:
1. emerge sync
2. emerge -vup world
3. emerge -v world (or emerge -vu world -- it's the same)

Actual Results:  
The error previously indicated was spit back, and I submitted this bug.

Expected Results:  
Installed the latest gentoo-dev-sources
Comment 1 Tim Yamin (RETIRED) gentoo-dev 2004-05-23 08:20:45 UTC

*** This bug has been marked as a duplicate of 51800 ***