Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 517250

Summary: net-wireless/broadcom-sta-6.30.223.248 - FATAL: modpost: GPL-incompatible module wl.ko uses GPL-only symbol '__init_work'
Product: Gentoo Linux Reporter: farmboy0
Component: [OLD] Core systemAssignee: M. B. <tomboy64>
Status: RESOLVED FIXED    
Severity: normal CC: eva, gentoo, hijacker, hubert.kromer, jbuchert+genbug, matoro, michael.plante, ne3dle, plevine457, proxy-maint, sarnex, tiagosousa
Priority: Normal    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: emerge --info
build log

Description farmboy0 2014-07-16 15:04:57 UTC
The compile fails because the module references a GPL only symbol.

Reproducible: Always

Steps to Reproduce:
1.emerge the package with current default gentoo kernel(linux-3.12.21-gentoo-r1)
2.
3.
Actual Results:  
error building the package

Expected Results:  
successful compile
Comment 1 farmboy0 2014-07-16 15:07:03 UTC
Created attachment 380820 [details]
emerge --info
Comment 2 farmboy0 2014-07-16 15:08:34 UTC
Created attachment 380822 [details]
build log
Comment 3 Matt Turner gentoo-dev 2015-01-27 19:48:04 UTC
I have not experienced this. Please test with broadcom-sta-6.30.223.248-r3 and mark FIXED if you cannot reproduce or reopen if you can. Thanks!
Comment 4 farmboy0 2015-02-05 10:18:59 UTC
Error still happens with broadcom-sta-6.30.223.248-r3.
I have tried with the newest official gentoo kernel linux-3.17.8-gentoo-r1.

One information that may be useful to reproduce:
In order to get the module to build at all with kernels > 3.8 or 3.10
I need to patch the kernel kernel source to make the config options for lib80211
selectable. Otherwise the module will state that certain kernel options arent selected and I found no other way to select them implicitly.

This patch needs to be applied to net/wireless/Kconfig:

--- Kconfig.old 2014-06-30 16:36:25.255632552 +0200
+++ Kconfig     2014-06-30 16:37:47.979638675 +0200
@@ -140,7 +140,7 @@
          extensions with cfg80211-based drivers.
 
 config LIB80211
-       tristate
+       tristate "lib 80211"
        default n
        help
          This options enables a library of common routines used
@@ -149,13 +149,13 @@
          Drivers should select this themselves if needed.
 
 config LIB80211_CRYPT_WEP
-       tristate
+       tristate "lib 80211 crypt wep"
 
 config LIB80211_CRYPT_CCMP
-       tristate
+       tristate "lib 80211 crypt ccmp"
 
 config LIB80211_CRYPT_TKIP
-       tristate
+       tristate "lib 80211 crypt tkip"
 
 config LIB80211_DEBUG
        bool "lib80211 debugging messages"
Comment 5 Matt Turner gentoo-dev 2017-09-09 20:36:52 UTC
Dropping myself as a maintainer.

If you are stuck using this unmaintained driver (likely in a MacBook),
you may be interested to know that a newer compatible wireless card
is supported by the in-tree brcmfmac driver. It has a model number 
BCM943602CS and is for sale on the second hand market for less than 
20 USD.

See https://wikidevi.com/wiki/Broadcom_Wireless_Adapters and
    https://wikidevi.com/wiki/Broadcom_BCM943602CS
for more information.
Comment 6 farmboy0 2017-09-10 19:57:22 UTC
I dont care about this driver anymore. If no one else does please close.
Comment 7 Pacho Ramos gentoo-dev 2018-03-13 16:29:45 UTC
Nick mailed me showing interest on fixing and maintaining this. Probably the way to do (until you become a developer) would be to maintain it via proxy-maint and send a PR fixing the existing bugs
https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers
Comment 8 Nikolay Kichukov 2018-03-14 08:39:52 UTC
Not sure why this needs to be removed as it does compile and work okay on 4.14.11-gentoo-r2 kernel, package version: net-wireless/broadcom-sta-6.30.223.271-r4...

This driver so far works best on Dell Latitude E64xx series.

My local repo continues to grow from removals like this... just mask it if you believe it is unsafe and leave it in the portage tree! Allow the user to decide if they want to have an unsupported package on their system.

Thanks,
-N
Comment 9 Nick Sarnie gentoo-dev 2018-03-14 12:22:33 UTC
(In reply to Nikolay Kichukov from comment #8)
> Not sure why this needs to be removed as it does compile and work okay on
> 4.14.11-gentoo-r2 kernel, package version:
> net-wireless/broadcom-sta-6.30.223.271-r4...
> 
> This driver so far works best on Dell Latitude E64xx series.
> 
> My local repo continues to grow from removals like this... just mask it if
> you believe it is unsafe and leave it in the portage tree! Allow the user to
> decide if they want to have an unsupported package on their system.
> 
> Thanks,
> -N

Hi Nikolay,

I am planning to maintain this package through proxy-maintainers until I finish becoming a developer, and then take it fully from there.

Thanks,
Sarnex
Comment 10 Jose Silva 2018-03-14 19:45:29 UTC
The b43 driver is about 70% slower on my MacBook pro 8.2 (BCM4331) and I don't have any particular problem with broadcom-sta except that the connection drops sometimes but I didn't test if the b43 drops as well.

So, for me, I don't see any reason to shut-off sta. Why not just leave it there to the people that want to use it?
Comment 11 needle 2018-03-15 16:00:01 UTC
I agree with previous posts.
This closed source broadcom-sta driver builds and works properly on a MacBookPro 11.1. Do not understand the reason for removing this driver from portage.
Comment 12 needle 2018-03-15 21:03:08 UTC
So it looks Sarnex will proxy maintain the broadcom-sta ebuild.
Let's hope this driver will really stay in portage.
This would be really great.

The eselect news is then a bit misleading.

#Pacho Ramos <pacho@gentoo.org> (13 Mar 2018)
#Dead driver and with many incompatibilities with current kernels 

Sorry for the rush reply, I should read the bug report entries more carefully.


(In reply to Nick Sarnie from comment #9)
> 
> Hi Nikolay,
> 
> I am planning to maintain this package through proxy-maintainers until I
> finish becoming a developer, and then take it fully from there.
> 
> Thanks,
> Sarnex
Comment 13 Jan Henke 2018-03-16 21:28:34 UTC
This driver is the only working one for the wireless card that came with my Dell XPS13 laptop. I am not really willing to swap that card to any other one, because it always worked fine with this driver, also being very stable and very useful.

I would be happy to use a mainline driver instead, but there seems none that supports my device. So I really do not see the point of removing this from tree?
Comment 14 Michael K. Plante 2018-03-17 01:47:58 UTC
This should not be removed.  Someone wants to maintain it.

I have a 2013-ish Dell/AW 17.  Up until a year ago, I couldn't find a wifi driver that worked.  I had given up for awhile on ever getting wifi working  In desperation, I turned to this one recently.  I ignored a lot of the comments because people were talking about macbooks or something, and I've always avoided everything Apple, so I figured whoever was saying it didn't know what they were talking about.

I looked through the 4 bugs listed in the news item.

517250 -- this bug.  It looks like there are some patches.

523356 -- ok, I guess I won't use hardened.  I would guess most people don't based on the comments there.  There is a patch, though.

551834 -- there's a solution posted

646106 -- there's a patch (I'm not yet on that kernel anyway, so I can't confirm)

In short, it's potentially fixable, and it works for me on 4.4.111-r1, an LTS line.
Comment 15 Michael K. Plante 2018-03-17 01:53:03 UTC
Sorry, I'll add separately, this is a built-in module inside a laptop.  Dell, in their infinite wisdom, failed to include an expresscard slot (one of many complaints I have about AW -- don't buy one).  I am stuck.  Yes, I usually use wired at home, but not at airports.  Matt's proposed "solution" is not possible.  I wish he would drop the speculation about macs and just say he doesn't care and doesn't have time.  At least that would be honest and respectable.
Comment 16 Peter Levine 2018-03-17 06:36:51 UTC
I can't reproduce the issue with net-wireless/broadcom-sta-6.30.223.271-r4 and linux-4.15.7-gentoo-r1.  It might have been a brief module license issue fixed upstream.  Could the reporter test and confirm the issue with the latest sources or, if not, please close the bug.

AFAIK, this is the only driver for the BCM4352 802.11ac wireless adapter on my ASUS Maximus VII Formula motherboard.
Comment 17 farmboy0 2018-03-17 23:53:38 UTC
I dont have the hardware for this anymore so I cant retest.
Please close.
Comment 18 nezharen1995 2018-03-19 07:04:29 UTC
This driver works fine for my DELL XPS desktop with BCM4352 wireless card.
I'll be worried how to find an alternative driver if this driver is masked.
Comment 19 Tiago Sousa 2018-03-19 09:51:14 UTC
I'd like to add HP Envy 17 to the list of laptops using this driver for the BCM4352 chip. It works just fine with the latest stable kernel (4.9.76-r1 ATM) and has always done so for me. PLEASE don't remove it!
Comment 20 Hubert Kromer 2018-03-22 09:33:57 UTC
Works perfectly fine with 4.15.12-gentoo kernel after applying patch from #646106.

Out of curiosity I tried to make my BCM4360 (Late 2014 MacBook Pro) work with b43 driver, even though it is not officially supported by the driver - unfortunately it is not an option:

[  101.772694] b43-phy1: Broadcom 4360 WLAN found (core revision 42)
[  101.773075] b43-phy1 ERROR: FOUND UNSUPPORTED PHY (Analog 12, Type 11 (AC), Revision 1)
[  101.773088] b43: probe of bcma0:1 failed with error -95

The broadcom-sta driver is the only option for me. Please don't kill it.
Comment 21 nmindz 2018-03-22 14:58:16 UTC
Have also been using this driver on a linux-4.14.15-gentoo kernel without problems. Currently running a Dell Inspiron 7000 with modified hardware, including this wireless card.

Replacing the card is not an option unless it absolutely does not work. This card is great and works as expected. I have no problems with this card whatsoever using the sta driver. Have been running it with XFCE and i3 along with NetworkManager and surprisingly no bugs or quirks at all. (If it is worth mentioning)

To be honest I don't even see a point in masking it (even if it's unmaintained as of right now) since it absolutely works without any patching or fixing whatsoever. For my BCM4352 it is the only option available. Mask it if you will, but don't kill it.
Comment 22 Yi Yang 2018-03-23 06:58:08 UTC
I support the mask since whoever attempts to continue using this driver needs to know about the current situation.

However, as we have seen, there is still demand on this driver and there are still people around who would like to maintain it. Maybe masking but not removing would be a logical decision.

broadcom-sta always compiles for me, from v3.4.* era until now (v4.14.*), so I also see no point in removing it. The connection occasionally drops, which is indeed annoying, but a shabby connection is better than no connection at all...
Comment 23 jacktoo 2018-03-23 18:17:55 UTC
Works perfectly with 4.14.18-gentoo. 
Moreover this seems to be the only option for my:

04:00.0 Network controller: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter (rev 03)

Why removing it?
Comment 24 guoyingshou 2018-03-24 01:01:05 UTC
Works perfectly for me with 4-14-15-aufs, but not with an upgrading to 4-15-8-aufs. I cann't find other options for my Broadcom Limited BCM4352 802.11ac network controller. Anyone has any recommendations? Thanks.
Comment 25 guoyingshou 2018-03-24 01:01:34 UTC
Works perfectly for me with 4-14-15-aufs, but not with an upgrading to 4-15-8-aufs. I cann't find other options for my Broadcom Limited BCM4352 802.11ac network controller. Anyone has any recommendations? Thanks.
Comment 26 Gilles Dartiguelongue gentoo-dev 2018-03-25 22:10:16 UTC
Closing this bug as I couldn't trigger this error message with either 4.12, 4.14 or 4.15. Also kernels configuration checks are handled in ebuild already so comment #4 should be covered.
Comment 27 guoyingshou 2018-03-26 03:03:22 UTC
Works perfectly with 4.15.8-aufs now, thanks!