Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 516162

Summary: Plasma 5: systray icon issues
Product: Gentoo Linux Reporter: gerion <gerion.entrup>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: aspotashev, darkbasic, eugene.shalygin, jacobgodserv, lukas.schneiderbauer
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 503880, 516488    
Bug Blocks:    

Description gerion 2014-07-03 13:04:00 UTC
When emerging Plasma Next from kde overlay, some programs (including gtk apps) does not has a systray icon anymore.

Martin Gräßlin write a blogpost therefore a few days ago.
Would be nice if you implement/package his solution:
    GTK2: needs libappindicator1 and all packages having an optional
    dependency to it should get compiled with it.
    GTK3: needs libappindicator3-1 and all packages having an optional
    dependency to it should get compiled with it.
    Qt4: needs sni-qt and a patch to Qt 4.8
    Qt5: Won’t need adjustments starting with Qt 5.4, but with Qt 5.3 this commit should be cherry-picked.
(http://blog.martin-graesslin.com/blog/2014/06/where-are-my-systray-icons/)


Reproducible: Always
Comment 1 Michael Palimaka (kensington) gentoo-dev 2014-07-03 14:17:33 UTC
GTK2: we don't have a gtk2 version of libappindicator at the moment, I pinged ssuominen about it
GTK3: gtk3 version of libappindicator is in tree
Qt4: sni-qt is in the kde overlay, and patch will be handled in bug #503880
Qt5: I will handle this patch shortly

As for pulling in libappindicator/sni-qt, I don't think there's any good way for us to handle it. We can document it and maybe even abuse USE flags in a meta package, but that's about it.
Comment 2 Michael Palimaka (kensington) gentoo-dev 2014-07-03 14:25:37 UTC
Sorry, Qt5 is already fixed in qtwidgets-5.3.1-r1.
Comment 3 Michael Palimaka (kensington) gentoo-dev 2014-07-03 15:25:10 UTC
It looks like packaging libappindicator for gtk2 will be infeasible due to upstream build issues unfortunately.
Comment 4 gerion 2014-07-03 15:52:07 UTC
GTK2: Damn!
GTK3: Can you add it as dependency (maybe with a useflag switch, so it is build by default, but can be deactivated)?
Qt4: Thanks.
Qt5: Thanks.
Comment 5 Michael Palimaka (kensington) gentoo-dev 2014-07-03 15:54:29 UTC
(In reply to gerion from comment #4)
> GTK3: Can you add it as dependency (maybe with a useflag switch, so it is
> build by default, but can be deactivated)?

To which package should the dependency be added?
Comment 6 gerion 2014-07-03 16:19:55 UTC
The component, which draws the tray on the desktop, I think. Maybe plasma-workspace (there seems to be the qml files, that draws the tray)?
Comment 7 Michael Palimaka (kensington) gentoo-dev 2014-07-04 17:21:42 UTC
Qt4 patching fixed in dev-qt/qtgui-4.8.5-r3.
Comment 8 Eugene Shalygin 2015-01-06 13:05:50 UTC
Could you please add miltilib version of sni-qt? It is hard to control Skype without its icon.
Comment 9 Manuel Rüger gentoo-dev 2015-01-06 20:04:05 UTC
(In reply to Eugene Shalygin from comment #8)
> Could you please add miltilib version of sni-qt? It is hard to control Skype
> without its icon.

Please see bug #516488
Comment 10 darkbasic 2015-02-10 19:19:05 UTC
Any news regarding a gtk2 version of libappindicator?
Comment 11 natrix 2015-02-26 00:34:54 UTC
Gtk2 and Gtk3 don't work
Comment 12 Michael Palimaka (kensington) gentoo-dev 2015-02-26 09:26:38 UTC
(In reply to darkbasic from comment #10)
> Any news regarding a gtk2 version of libappindicator?

There's some good patches here, I hope we can try to get them integrated soon: https://github.com/karolherbst/kde/tree/systray-stuff-gentoo-bug
Comment 13 Michael Palimaka (kensington) gentoo-dev 2015-02-26 09:26:58 UTC
(In reply to natrix from comment #11)
> Gtk2 and Gtk3 don't work

Did you install libappindicator?
Comment 14 Michael Palimaka (kensington) gentoo-dev 2015-02-26 12:53:23 UTC
Multilib sni-qt is now in tree thanks to Karol Herbst.
Comment 15 natrix 2015-03-06 02:55:47 UTC
(In reply to Michael Palimaka (kensington) from comment #13)
> (In reply to natrix from comment #11)
> > Gtk2 and Gtk3 don't work
> 
> Did you install libappindicator?

Yes, and your dependencies

=dev-libs/libindicator-12.10.1-r300 ~amd64
=dev-libs/libdbusmenu-12.10.2 ~amd64
=dev-libs/libappindicator-12.10.0 ~amd64
Comment 16 Alexander Potashev 2015-03-17 16:35:32 UTC
After bug#516488 is technically fixed, I still can't easily install sni-qt on my x86_64 system to make the Skype icon visible.

I think @darkbasic is right in his comment #8 at https://bugs.gentoo.org/show_bug.cgi?id=516488#c8. Because sni-qt[abi_x86_32] is not happy with app-emulation/emul-linux-x86-qtlibs and pulls qt*[abi_x86_32] instead, you have rebuild qtcore, qtgui, qtdbus and all their dependencies for both ABIs. (Of course only if you have a x86_64 system.)

I'm not going to unmask the abi_x86_32 flag and reinstall a few dozen packages just to make the icon visible: it's going to be too much mess :(
Comment 17 Michael Palimaka (kensington) gentoo-dev 2015-03-17 16:39:48 UTC
(In reply to Alexander Potashev from comment #16)
> After bug#516488 is technically fixed, I still can't easily install sni-qt
> on my x86_64 system to make the Skype icon visible.
> 
> I think @darkbasic is right in his comment #8 at
> https://bugs.gentoo.org/show_bug.cgi?id=516488#c8. Because
> sni-qt[abi_x86_32] is not happy with app-emulation/emul-linux-x86-qtlibs and
> pulls qt*[abi_x86_32] instead, you have rebuild qtcore, qtgui, qtdbus and
> all their dependencies for both ABIs. (Of course only if you have a x86_64
> system.)
> 
> I'm not going to unmask the abi_x86_32 flag and reinstall a few dozen
> packages just to make the icon visible: it's going to be too much mess :(

That's the point of multilib. Soon abi_x86_32 will be unmasked and emul-linux-x86* removed anyway.
Comment 18 darkbasic 2015-03-18 15:24:15 UTC
No, in the meantime emul-linux-x86* packages should have a abi_x86_32 use flag to tell them "provide me your libraries using multilib instead of binaries".
Almost all emul-linux-x86* packages already have an abi_x86_32 use flag, excpet the qt one.
Comment 19 Michael Palimaka (kensington) gentoo-dev 2015-03-18 15:34:42 UTC
That wouldn't serve any purpose, since the contents of emul-linux-x86-qtlibs is fully migrated to multilib. abi_x86_32 only exists in other emul packages to remove libraries that are migrated.
Comment 20 darkbasic 2015-03-18 18:57:04 UTC
It is fully migrated of course, but some apps still depend on emul-linux-x86-qtlibs so you cannot install both multilib and emul-linux-x86-qtlibs: that's the purpose of abi_x86_32 in multilib packages.
Comment 21 Michael Palimaka (kensington) gentoo-dev 2015-03-20 14:02:34 UTC
Which packages still depend on emul-linux-x86-qtlibs? They should all have updated deps.
Comment 22 darkbasic 2015-03-21 11:27:12 UTC
I guess steam from the steam overlay (for the steam runtime), but I'm not on my gentoo box right now.
Comment 23 Michael Palimaka (kensington) gentoo-dev 2015-03-21 17:12:33 UTC
Please tell them to fix their overlay then. There's not much we can do about it.
Comment 24 Manuel Rüger gentoo-dev 2015-05-08 11:32:06 UTC
libappindicator1 for gtk+:2 applications is now available as dev-libs/libappindicator:2
Those who want to test it might give x11-plugins/pidgin-indicator a try.
Comment 25 Johannes Huber gentoo-dev 2015-06-21 18:47:41 UTC
Thanks all. Seems in cvs available and fixed. Closing then.