Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 513844

Summary: sys-apps/portage - "required by" package list in autounmask comment is often incorrect/misleading
Product: Portage Development Reporter: theodor
Component: Core - Interface (emerge)Assignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bkohler
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description theodor 2014-06-19 11:31:26 UTC
Please make emerge display which package forces the keyword change it complains about. For example, after the last emerge --sync I got the following output:
# emerge -puvD @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] media-libs/freetype-2.5.3-r1:2 [2.4.11:2] USE="X adobe-cff%* bzip2 infinality png%* -auto-hinter -bindist -debug -doc -fontforge (-harfbuzz) -static-libs -utils" ABI_X86="(64%*) -32% (-x32)" 1,825 kB

Total: 1 package (1 upgrade), Size of downloads: 1,825 kB

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-video/mplayer-1.2_pre20130729[truetype]
# required by @selected
# required by @world (argument)
=media-libs/freetype-2.5.3-r1 ~amd64

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

It took me a very long time to figure out that the harfbuzz package changed it dependency from
media-libs/freetype:2=[${MULTILIB_USEDEP}]
to
>=media-libs/freetype-2.5.0.1:2=[${MULTILIB_USEDEP}]
(without changing its version number), which forced the freetype update.
Having harfbuzz listed instead of mplayer would have been a great help.

Reproducible: Always
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2014-06-19 13:02:16 UTC
As an aside, the reason for the harfbuzz change is this: http://article.gmane.org/gmane.linux.gentoo.devel/91615
Comment 2 Ben Kohler gentoo-dev 2014-12-06 23:37:48 UTC
I have seen this kind of thing come up a lot, I think there is a bug in portage where sometimes it gives a bogus reason for the unmask.  Here's another random example:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-apps/xcursorgen-1.0.5
# required by x11-base/xorg-x11-7.4-r2
# required by @selected
# required by @world (argument)
=media-libs/libpng-1.6.15 ~amd64
# required by www-client/firefox-34.0.5-r1
# required by @selected
# required by @world (argument)
=dev-libs/nspr-4.10.7-r1 ~amd64



xcursorgen here has an unversioned dep on libpng but it gets the blame... something else in the depgraph does need unstable libpng, most likely firefox.  The above is actually from another #gentoo user's box, I test "emerge -pv =firefox-34*" on my stable box and I get similar bogus output from autounmask, mine blames php:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by media-libs/mesa-10.3.4
# required by www-client/firefox-34.0.5-r1
# required by =firefox-34* (argument)
=x11-libs/libdrm-2.4.58 ~amd64
# required by www-client/firefox-34.0.5-r1
# required by =firefox-34* (argument)
=dev-libs/nspr-4.10.7-r1 ~amd64
# required by www-client/firefox-34.0.5-r1
# required by =firefox-34* (argument)
=dev-libs/nss-3.17.3 ~amd64
# required by dev-lang/php-5.5.18
# required by @selected
# required by @world (argument)
=media-libs/libpng-1.6.15 ~amd64
# required by www-client/firefox-34.0.5-r1
# required by =firefox-34* (argument)
=media-libs/mesa-10.3.4 ~amd64
# required by =firefox-34* (argument)
=www-client/firefox-34.0.5-r1 ~amd64
Comment 3 Zac Medico gentoo-dev 2014-12-06 23:45:06 UTC

*** This bug has been marked as a duplicate of bug 419381 ***