Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 513478

Summary: x11-themes/qtcurve-1.8.18 - add qt5 support
Product: Gentoo Linux Reporter: David Heidelberg (okias) <david>
Component: [OLD] LibraryAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED FIXED    
Severity: normal CC: qt, uwelk
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 454132    
Bug Blocks:    

Description David Heidelberg (okias) 2014-06-16 14:12:13 UTC
upstream commit, since with qt 5.3.0 is build broken.

Can be found in ::ixit overlay [1] fixed.

[1] https://github.com/okias/ixit/tree/master/x11-themes/qtcurve

Reproducible: Always
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2014-06-16 14:16:25 UTC
Please attach a diff of your ebuild to this bug report.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2014-08-08 15:39:11 UTC
Please attach a unified diff (diff -u) of the ebuild changes here.
Comment 3 David Heidelberg (okias) 2014-08-11 01:32:08 UTC
--- /usr/portage/x11-themes/qtcurve/qtcurve-1.8.18.ebuild       2014-02-04 15:31:38.000000000 +0100
+++ /var/lib/layman/ixit/x11-themes/qtcurve/qtcurve-1.8.18-r1.ebuild    2014-06-16 16:09:05.463610978 +0200
@@ -52,7 +52,8 @@
 
 DOCS=( AUTHORS ChangeLog.md README.md TODO.md )
 
-PATCHES=( "${DISTDIR}/${P}-dont_use_c++11.patch" )
+PATCHES=( "${DISTDIR}/${P}-dont_use_c++11.patch"
+                 "${FILESDIR}/${P}-remove_qt_filedialog_api.patch" )
 
 pkg_setup() {
        # bug #498776

patch is here: https://raw.githubusercontent.com/okias/ixit/master/x11-themes/qtcurve/files/qtcurve-1.8.18-remove_qt_filedialog_api.patch or in their cvs/svn/git.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2014-08-25 20:52:01 UTC
+  25 Aug 2014; Lars Wendler <polynomial-c@gentoo.org> qtcurve-1.8.18.ebuild,
+  +files/qtcurve-1.8.18-remove_qt_filedialog_api.patch:
+  Fixed qt5 support. Thanks to David Heidelberger who reported this in bug
+  #513478.
+

I cannot test this fix as I don't have qt5 installed on any of my systems. So I hope this really works for qt5 users.