Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 513232

Summary: www-servers/apache-2.4.9 - mod_macro should be present in httpd.conf by default
Product: Gentoo Linux Reporter: Nilesh Govindrajan <me>
Component: [OLD] ServerAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED NEEDINFO    
Severity: normal CC: hydrapolic, leho, pacho
Priority: Normal Keywords: NeedPatch
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 477702    
Bug Blocks: 468302    

Description Nilesh Govindrajan 2014-06-14 18:32:05 UTC
mod_macro is enabled by default in apache, but it is not present in httpd.conf.
Comment 1 Tomáš Mózes 2015-06-03 11:16:05 UTC
We need "macro" in IUSE_MODULES. Then it compiles with/without the macro module.

Tested with 2.4.12-r1.
Comment 2 Pacho Ramos gentoo-dev 2015-06-07 19:26:55 UTC
+  07 Jun 2015; Pacho Ramos <pacho@gentoo.org> -apache-2.4.12.ebuild,
+  apache-2.4.12-r1.ebuild, metadata.xml:
+  mod_macro is now provided by apache itself (#477702 by Jan Vansteenkiste, and
+  Tomas Mozes)
+

What more is needed?

Thanks
Comment 3 Pacho Ramos gentoo-dev 2015-06-16 09:30:08 UTC
(In reply to Pacho Ramos from comment #2)
> +  07 Jun 2015; Pacho Ramos <pacho@gentoo.org> -apache-2.4.12.ebuild,
> +  apache-2.4.12-r1.ebuild, metadata.xml:
> +  mod_macro is now provided by apache itself (#477702 by Jan Vansteenkiste,
> and
> +  Tomas Mozes)
> +
> 
> What more is needed?
> 
> Thanks