Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 51045

Summary: Foomatic-configure crashes with error when trying to add printer to system
Product: Gentoo Linux Reporter: Chris <grooveman>
Component: [OLD] PrintingAssignee: Printing Team <printing>
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Chris 2004-05-14 06:42:35 UTC
I issue this on the command line:
foomatic-configure -s cups -p HP-LaserJet_8150 -c "smb://MYDOMAIN/MYSERVER/accthp8150" -n "accthp8150" -d Postscript

it crashes with this:
Use of uninitialized value in substitution (s///) at /usr/lib/perl5/vendor_perl/5.8.2/Foomatic/ line 3389.

I have done this many times on other (older) gentoo systems with no problems (installed this very printer with this very command)

I have tried renamaing the printer, I have tried installing other printers, always crashes -- whether local or network.

Printers are not installed.


Cupsd is running.

Entire system is up to date as of today (5/14/2004).  No unstable packages installed.

Reproducible: Always
Steps to Reproduce:
1.Issue this command:
foomatic-configure -s cups -p HP-LaserJet_8150 -c "smb://MYDOMAIN/MYSERVER/accthp8150" -n "accthp8150" -d Postscript
2.Read error output: Use of uninitialized value in substitution (s///) at /usr/lib/perl5/vendor_perl/5.8.2/Foomatic/ line 3389   (line # varies depending upon printer model)
3.Curse, swear, rant and rave then finally post to gentoo forum.  
4.After post to forum is ignored, then post bug :0)

Actual Results:  

Printer not installed.

Expected Results:  
My printer should have installed to cups
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2004-05-14 13:48:15 UTC

*** This bug has been marked as a duplicate of 51038 ***