Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 50927

Summary: Gstreamer 0.8.1 segfaults using spider plugin for mp3s and wavs
Product: Gentoo Linux Reporter: Mike Auty <ikelos>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: VERIFIED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Mike Auty gentoo-dev 2004-05-13 06:06:39 UTC
Leaving the mouse over any audio file causes the small audio emblem to appear, shortly after nautilus crashes completely.

Any further information I can provide, please just ask...

Reproducible: Always
Steps to Reproduce:
1. Leave mouse over audio file.
2. Audio preview emblem appears.
3. Crash occurs a few seconds later.

Actual Results:  
Crash occured.

Expected Results:  
I should have heard the music playing instead.

Software versions of note:

Nautilus 2.6.1
gstreamer 0.8.1
gst-plugins-alsa 0.8.1
gst-plugins-gnomevfs 0.8.1
alsa 1.0.4

alsa set to use dmix plugin
gstreamer-properties audiosink set to audioscale ! alsasink (to compensate for
dmix problems)
gst-launch-ext on the file with similar sink works fine.

Portage 2.0.50-r6 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.2-r9, 2.6.6)
=================================================================
System uname: 2.6.6 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.4.10
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=i686 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"CONFIG_PROTECT_MASK="/etc/gconf
/etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=i686 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox sfperms"
GENTOO_MIRRORS="http://212.219.247.13/sites/www.ibiblio.org/gentoo/
http://212.219.247.14/sites/www.ibiblio.org/gentoo/
http://212.219.247.18/sites/www.ibiblio.org/gentoo/
http://212.219.247.19/sites/www.ibiblio.org/gentoo/
http://212.219.247.21/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/bmg-overlay
/usr/local/overlays/freedesktop"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aalib alsa apm avi berkdb cdr crypt cups directfb divx4linux dvd encode
foomaticdb gdbm gif gnome gpm gstreamer gtk gtk2 guile ieee1394 imlib java jpeg
ldap libg++ libwww mad mikmod motif mozilla mpeg ncurses nls nptl oggvorbis
opengl oss pam pda pdflib perl png postgres python quicktime readline sdl slang
spell ssl svga tcltk tcpd tetex truetype x86 xml2 xmms xv xvid zlib"
Comment 1 Mike Auty gentoo-dev 2004-05-13 06:26:36 UTC
Ok, so I had a look in the patch and found that it setups up a pipeline from gnomevfs through spider to the default audiosink.  I quickly tried the same with different sink and src plugins, and then also without the spider plugin.

It produces the following error messages just from gst-launch:

$ gst-launch-0.8 filesrc location="Muppets-Pigsinspace.mp3" ! spider ! audioscale ! alsasink
RUNNING pipeline ...
 
** (process:16618): CRITICAL **: how to remove plugins?
 
(process:16618): GStreamer-CRITICAL **: Factory for `id3tag' has no type
Segmentation fault

for an mp3 and

$ gst-launch-0.8 filesrc location="Neutrogena.wav" ! spider ! audioscale ! alsasink
RUNNING pipeline ...
 
** (process:16621): CRITICAL **: how to remove plugins?
 
(process:16621): GStreamer-CRITICAL **: Factory for `ffdemux_wav' has no type
Segmentation fault

for wavs.

Without the ffmpeg plugin many more "how to remove" plugin errors appear, and the wav error message is Factory for "wavparse" has no type.  Either way this consitently segfaults.

As always, I'll be happy to provide any further information that might be useful...
Comment 2 Mike Auty gentoo-dev 2004-05-13 06:52:34 UTC
Ok,
  Now this is *really* bizarre.  It seems that the spider plugin is now working from gst-launch, unfortunately I slightly missed when that happened.  The steps I took were to re-emerge gst-plugins-ffmpeg but I was fairly certain that I was still getting problems after I'd done that.  I also half re-emerged the gst-plugins package and a few others but since they never got out of their sandbox I have no idea what could have cured it.
  Also this has *not* cured my problems with nautilus, so I'm back to square one with no idea what's going on and no idea what kind of a summary to put for this bug...  HELP!  5:)
Comment 3 foser (RETIRED) gentoo-dev 2004-05-15 12:07:29 UTC
try another sink ?

do other gst using apps exhibit the same problem ? Is it just these particular files or does it happen on every file ?
Comment 4 Mike Auty gentoo-dev 2004-05-15 13:56:58 UTC
Hi,
    Sorry about the wrong priority, the bug guidance wizard gives poor suggestions (technically this should have been marked critical since it's a crasher)...
    Seemingly it works ok with the osssink.  Perhaps it is the dmix plugin.  I remember having had trouble with the old xine because it doesn't return the correct period values or something weird.  I do remember having tried oss in the past and having had it fail, but perhaps that was when the spider plugin was segfaulting.  It's not easy to debug this gstreamer stuff is it, there's so much going on?  
    I've had trouble in the past with a BMG build of totem which was also using gstreamer, but I think the last time I tried that was when I hadn't put the audioscale into my default sink pipeline.  Since the dmix plugin emulates mixing it can only accept audio at a certain rate, so the audioscale plugin is required to convert all streams to the correct rate (48000 in my case)...
    Hope this helps, as always, if there's anything you want me to try just ask (and tell me how to do it) and I'll give it a go.  Thanks...
Comment 5 Mike Auty gentoo-dev 2004-05-15 13:58:36 UTC
Forgot to mention,
    This has been happening with all audio files I've tried (and nautilus doesn't preview video files) so I don't think it's anything in particular with the files...
Comment 6 Mike Auty gentoo-dev 2004-06-30 09:37:04 UTC
This is now fixed with gstreamer 0.8.3 and gst-plugins 0.8.2.
Comment 7 foser (RETIRED) gentoo-dev 2004-06-30 14:41:43 UTC
can't remember reading your #4 comment, but using BMG ebuilds made this an INVALID bug afaic. I'm pretty sure that it is connected to your crashes.