Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 507770

Summary: ipv6 "default" routes not added when using routes_iface="default"
Product: Gentoo Hosted Projects Reporter: Jakub Jirutka <jakub>
Component: netifrcAssignee: netifrc Team <netifrc>
Status: IN_PROGRESS ---    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://dev.gentoo.org/~vapier/openrc/projects/openrc/ticket/152.html
Whiteboard:
Package list:
Runtime testing required: ---

Description Jakub Jirutka 2014-04-15 23:51:05 UTC
My problem is described on the provided URL, there’s also a patch for it. However, it seems that it was not merged into current netifrc repository on git://git.overlays.gentoo.org/proj/netifrc.git.

Reproducible: Always
Comment 1 Pavel Šimerda (pavlix) 2016-03-16 20:18:42 UTC
I just verified that this is still a problem.
Comment 2 Pavel Šimerda (pavlix) 2016-03-16 22:18:01 UTC
To be honest now I would say it works for me. I might have used an older package the first time. It would be nice if someone could confirm independently and the bug could then be closed.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2016-03-16 22:52:54 UTC
@Pavel:
I couldn't follow the original bug's actual complaint.

Roy's first patch (http://dev.gentoo.org/~vapier/openrc/projects/openrc/attachment/ticket/152/family.diff.html) on that bug is definitely present in netifrc (was committed in openrc before the split).

Maybe you can explain better what OpenVZ is doing with default routes.