Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 506608

Summary: app-office/akonadi-server-1.12.0: Unable to initialize database. "Column 'name' cannot be null QMYSQL3
Product: Gentoo Linux Reporter: Viacheslav Gagara <viacheslavg>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: optimusgd, randy-andy-, stephan.menzel
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=331867
Whiteboard: fixed in 1.12.2
Package list:
Runtime testing required: ---
Attachments: akonadiserver.error
mysql error
mysql.conf

Description Viacheslav Gagara 2014-04-02 22:05:23 UTC
akonadi-server unable to start after upgrade (using QMYSQL3 backend).
Most likely problem caused by akonadi DB upgrade.

Reproducible: Always

Steps to Reproduce:
1. emerge -1v akonadi-server
2. akonadictl restart

Actual Results:  
akonadi-server failed to start

Expected Results:  
should start OK.

emerge --info
Portage 2.2.10 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.19, 3.13.7-gentoo x86_64)
=================================================================
System uname: Linux-3.13.7-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.2
KiB Mem:     3087548 total,    680984 free
KiB Swap:    4184896 total,   4184808 free
Timestamp of tree: Sun, 30 Mar 2014 18:30:01 +0000
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.6.9, 2.7.6, 3.2.5-r3, 3.3.5, 3.4.0
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10 AdobeFlash-10.1 AdobeFlash-10.3 AdobeFlash-11.x Oracle-BCLA-JavaSE google-chrome skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.1/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
USE="7zip X Xaw3d a52 aac acpi adplug alsa amd64 amr apache2 arts artworkextra avahi berkdb bluetooth bonobo branding bzip2 cairo cdda cdr chardet cli consolekit cracklib crypt cups cxx dbus dga djvu dri dts dvd dvdr dvdread dvi eap-tls emboss encode esd exif fam fastcgi ffmpeg firefox flac fortran fuse gd gdbm gif gimp glitz gnutls gphoto2 gpm gsm gstreamer gtk gtk2 gtk3 gtkhtml guile howl-compat iconv idle imap ipv6 irda java java5 jingle jpeg kde keyring kqemu lcms ldap libnotify lm_sensors mad matroska mdnsresponder-compat minizip mmx mmxext mng modules mono mozilla mp3 mp4 mpeg multilib mysql ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcmcia pcre pdf plasma pmu png policykit postgres ppds python qt3 qt3support qt4 readline regex samba sasl seamonkey semantic-desktop session smp sourceview spamassassin spell srv sse sse2 ssl ssse3 startup-notification static-libs subversion svg syslog tcpd theora threads tiff trayicon truetype udev udisks unicode upower usb v4l v4l2 valgrind vcd vim-syntax vim-with-x vorbis wavpack wma wmf wxwidgets x264 xcb xface xforms xhtml xinerama xml xscreensaver xulrunner xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="access access_compat auth auth_dbm auth_anon auth_digest alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host authn_core authz_core unixd socache_shmcb" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev touchpad synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="uk uk_UA en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4 php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau v4l v4l2" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Viacheslav Gagara 2014-04-02 22:07:12 UTC
Created attachment 374120 [details]
akonadiserver.error
Comment 2 Viacheslav Gagara 2014-04-02 22:07:45 UTC
Created attachment 374122 [details]
mysql error
Comment 3 Viacheslav Gagara 2014-04-02 22:08:21 UTC
Created attachment 374124 [details]
mysql.conf
Comment 4 Viacheslav Gagara 2014-04-02 22:15:21 UTC
MySQL error observed in akonadiserver.error is:
DATABASE ERROR: 
  Error code: 1048 
  DB error:  "Column 'name' cannot be null" 
  Error text: "Column 'name' cannot be null QMYSQL3: Unable to execute statement" 
  Query: "INSERT INTO PartTypeTable (ns, name) VALUES (:0, :1)" 
"Column 'name' cannot be null QMYSQL3: Unable to execute statement" 
Update failed 
Failed to commit transaction for database update 
Unable to initialize database.
Comment 5 Viacheslav Gagara 2014-04-03 08:15:30 UTC
Possible workaround is to remove ~/.local/share/akonadi dir and restart akonadi service. Works fine for me.
Comment 6 Johannes Huber gentoo-dev 2014-04-03 08:17:12 UTC
Please report this upstream and link back here.
Comment 7 Viacheslav Gagara 2014-04-03 08:41:48 UTC
Respective bug from upstream: https://bugs.kde.org/show_bug.cgi?id=331867
Comment 8 Johannes Huber gentoo-dev 2014-04-12 22:40:38 UTC
IRC talk with an upstream maintainer. Just for the record...

<johu> dvratil: is bug 331867 fixed in 1.12.1?
<bugbot> KDE bug 331867 in Akonadi (server) "mysql: column 'name' can not be null when migrating PartTable" [Grave,Confirmed: ] http://bugs.kde.org/331867
<dvratil> johu, no, migration will still fail if there are invalid data in the database
<johu> :/
<dvratil> johu, it would otherwise require inspecting every single record, which means that migration would take ages
<johu> dvratil: so users on kde-4.13 will end up with broken akonadi if they dont know the workaround?
<dvratil> yes. However their database is alraedy broken so there can be unexpected sideffects anyway
Comment 9 Johannes Huber gentoo-dev 2014-04-22 15:45:06 UTC
Thanks for reporting. This is fixed in cvs now. Please sync in some hours to get the changes.

+
+  22 Apr 2014; Johannes Huber <johu@gentoo.org>
+  +akonadi-server-1.12.1-r1.ebuild,
+  +files/akonadi-server-1.12.1-db-initialize.patch,
+  -akonadi-server-1.12.1.ebuild:
+  Revision bump adds upstream patch which fixes db initialization error, bug
+  #506608. Remove old.
+
Comment 10 Johannes Huber gentoo-dev 2014-04-22 17:49:22 UTC
*** Bug 508442 has been marked as a duplicate of this bug. ***