Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 506042

Summary: =dev-python/py-1.4.20 =dev-python/pytest-2.4.2 =dev-python/pexpect-3.0 =dev-python/pyyaml-3.10-r1 =dev-python/cython-0.19.1-r1 stabilization request
Product: Gentoo Linux Reporter: Ian Delaney (RETIRED) <idella4>
Component: [OLD] Keywording and StabilizationAssignee: Python Gentoo Team <python>
Status: RESOLVED FIXED    
Severity: enhancement Keywords: STABLEREQ
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 506488    
Bug Blocks: 502536    

Description Ian Delaney (RETIRED) gentoo-dev 2014-03-28 09:38:39 UTC
Due
Comment 1 Ian Delaney (RETIRED) gentoo-dev 2014-03-28 09:42:06 UTC
*** Bug 506040 has been marked as a duplicate of this bug. ***
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2014-03-28 13:50:32 UTC
Stable for HPPA.
Comment 3 Akinori Hattori gentoo-dev 2014-06-08 09:03:53 UTC
ia64 stable
Comment 4 Tobias Klausmann gentoo-dev 2014-07-19 18:04:16 UTC
As mentioned on the dependent bug (py failing its test suite), I think this version of py should depend on >=pytest-2.4.2 since with that version, py's failures go away.
Comment 5 Tobias Klausmann gentoo-dev 2014-07-19 18:46:29 UTC
After some more investigation, it seems that pytest-2.4.2 or newer is needed everywhere. This triggers and additional set of dependencies.

Specifically, these packages need to go stable together with py-1.4.20:

=dev-python/pytest-2.4.2
=dev-python/pexpect-3.0
=dev-python/pyyaml-3.10-r1
=dev-python/cython-0.19.1-r1


Re-adding IA64 and HPPA, since it's very likely their stable'd versions of py-1.4.20 are broken, too
Comment 6 Mike Gilbert gentoo-dev 2014-07-19 18:48:28 UTC
(In reply to Tobias Klausmann from comment #5)

Thanks for the investigation. It should be fine to stabilize these.
Comment 7 Tobias Klausmann gentoo-dev 2014-07-19 21:22:14 UTC
Stabilized all four on alpha.
Comment 8 Markus Meier gentoo-dev 2014-07-24 19:26:41 UTC
arm stable
Comment 9 Agostino Sarubbo gentoo-dev 2014-08-02 12:42:09 UTC
amd64 stable
Comment 10 Agostino Sarubbo gentoo-dev 2014-08-02 12:44:15 UTC
x86 stable
Comment 11 Jeroen Roovers (RETIRED) gentoo-dev 2014-08-07 09:03:16 UTC
Stable for HPPA.
Comment 12 Agostino Sarubbo gentoo-dev 2014-11-10 11:21:48 UTC
ppc stable
Comment 13 Agostino Sarubbo gentoo-dev 2014-11-10 11:22:12 UTC
ppc64 stable
Comment 14 Jack Morgan (RETIRED) gentoo-dev 2015-05-28 15:13:19 UTC
sparc stable
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-24 12:35:17 UTC
Quite old bug, all needed versions or newer are stable on ia64 already.