Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 505646

Summary: x11-apps/mesa-progs-8.1.0 USE=egl with x11-drivers/nvidia-drivers - .../work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:133: undefined reference to `eglGetScreensMESA'
Product: Gentoo Linux Reporter: Justin Lecher <jlec>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: RESOLVED DUPLICATE    
Severity: normal CC: bircoph, dmitry.ghost99, help, powerman-asdf, ville.aakko
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: mesa-progs-8.1.0:20140325-114431.log

Description Justin Lecher gentoo-dev 2014-03-25 11:45:52 UTC
/bin/sh ../../../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -I/usr/include/libdrm  -I/usr/include/GL -I/usr/include/libdrm  -I/usr/include/libdrm  -D_GNU_SOURCE -DPTHREADS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -I/usr/include/libdrm  -I../../../src/egl/eglut -I../../../src/util -O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g -Wimplicit-function-declaration -lGL  -lGLEW -lGLU -lGL  -lGLU -lGL  -lm -lEGL  -Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -o eglinfo eglinfo.o  
libtool: link: x86_64-pc-linux-gnu-gcc -I/usr/include/libdrm -I/usr/include/GL -I/usr/include/libdrm -I/usr/include/libdrm -D_GNU_SOURCE -DPTHREADS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -I/usr/include/libdrm -I../../../src/egl/eglut -I../../../src/util -O2 -pipe -ftracer -march=native -frecord-gcc-switches -g -Wimplicit-function-declaration -Wl,-O1 -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -o eglinfo eglinfo.o  -lGLEW -lGLU -lGL -lm -lEGL -Wl,--as-needed
eglinfo.o: In function `PrintModes':
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:133: undefined reference to `eglGetScreensMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:139: undefined reference to `eglGetModesMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:147: undefined reference to `eglGetModeAttribMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:148: undefined reference to `eglGetModeAttribMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:149: undefined reference to `eglGetModeAttribMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:150: undefined reference to `eglGetModeAttribMESA'
/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl/eglinfo.c:151: undefined reference to `eglQueryModeStringMESA'
collect2: error: ld returned 1 exit status
Makefile:511: recipe for target 'eglinfo' failed
make: *** [eglinfo] Error 1



$ einfo mesa-progs
Portage 2.2.9-r1 (default/linux/amd64/13.0, gcc-4.8.2-asneeded, glibc-2.19, 3.13.7-lh x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.13.7-lh-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16467972 total,   1117120 free
KiB Swap:    4194300 total,   4123456 free
Timestamp of tree: Tue, 25 Mar 2014 07:30:01 +0000
ld GNU ld (GNU Binutils) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.4
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.1.2, 4.7.3-r1, 4.8.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19
Repositories: gentoo sunrise bicatali betagarden dummy Neurogeek science last-hope
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g -Wimplicit-function-declaration"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/eselect/ /usr/share/gnupg/qualified.txt /usr/share/nano/ /var/lib/hsqldb /var/spool/munin-async/.ssh /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g -Wenum-compare"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" -vt --keep-going --autounmask-write --autounmask --quiet-build=n"
FCFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g"
FEATURES="assume-digests binpkg-logs buildsyspkg ccache cgroup collision-protect compressdebug distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms sign split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe -ftracer   -march=native -frecord-gcc-switches -g"
GENTOO_MIRRORS=" /mnt/tmpfs/ http://gentoo.j-schmitz.net/mirror/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common"
MAKEOPTS="-j8 -l5"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-z -e -9 -v"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--omit-dir-times"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/local/overlays/sunrise-reviewed /local/overlays/bicatali /local/overlays/betagarden /local/overlays/dummy /local/overlays/neurogeek /local/overlays/sci /local/overlays/lh-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 avx bash-completion berkdb branding bzip2 cairo caps cli cracklib crypt cups cxx dbus dri egl fortran gdbm gif gmp gstreamer gtk gtk3 iconv icu ipv6 jpeg jpeg2k ldap logrotate mmx mmxext modules ncurses network-cron nls nptl nsplugin numa opengl openmp pam pcre pgo png pulseaudio qt3support readline session smp sse sse2 sse2_4way sse2check sse3 sse4 sse41 sse4_1 sse4a sse5 ssl ssse3 startup-notification tcpd threads tiff truetype unicode vaapi vdpau xattr xinerama zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport scripting-javascript wiki-publisher nlpsolver" LINGUAS="en" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_ip_hash userid uwsgi stub_status" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64 arm armeb" QEMU_USER_TARGETS="i386 x86_64 arm armeb" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND

=================================================================
                        Package Settings
=================================================================

x11-apps/mesa-progs-8.1.0 was built with the following:
USE="egl -gles1 -gles2"
Comment 1 Justin Lecher gentoo-dev 2014-03-25 11:46:07 UTC
Created attachment 373492 [details]
mesa-progs-8.1.0:20140325-114431.log

build.log
Comment 2 Jeroen Roovers gentoo-dev 2014-03-25 12:54:11 UTC
The workaround is to switch to the xorg-x11 implementation using eselect-opengl temporarily.
Comment 3 Ville Aakko 2014-12-04 19:55:25 UTC
Still a problem with x11-apps/mesa-progs-8.1.0 and x11-drivers/nvidia-drivers-346.16. The workaround of changing opengl implementation to xorg-x11 temporarily works.
Comment 4 Alexander 2015-03-17 12:15:15 UTC
I confirm.
Still a problem with x11-apps/mesa-progs-8.2.0 and x11-drivers/nvidia-drivers-340-76.
The workaround of changing opengl implementation to xorg-x11 temporarily works.
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2015-03-30 20:44:08 UTC
*** Bug 544976 has been marked as a duplicate of this bug. ***
Comment 6 Andrew Savchenko gentoo-dev 2015-04-02 11:32:26 UTC

*** This bug has been marked as a duplicate of bug 501328 ***