Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 504604

Summary: media-sound/teamspeak-client-bin-3.0.16 version bump
Product: Gentoo Linux Reporter: Markus Saarinen <heroine>
Component: Current packagesAssignee: Karol Herbst <gentoo>
Status: RESOLVED FIXED    
Severity: normal CC: ablepharus, genzilla, hauschild.markus, om, proxy-maint, spreetec, vylaern, wschlich
Priority: Normal Keywords: LATER
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 454132    
Bug Blocks:    
Attachments: teamspeak-client-bin 3.0.16 ebuild
new version
new version 3.0.16

Description Markus Saarinen 2014-03-14 15:37:34 UTC
Teamspeak client 3.0.14 is now released.

Got the new version installed by copying the ebuild to new name. However,
when running the client, I get this:

/opt/teamspeak3-client/ts3client: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory

So I guess this new version depends on QT5?
...which is kind of bad, since I don't think we have that in official tree yet? ;)



Reproducible: Always
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-03-16 14:39:34 UTC
Yes, we'll need to wait until Qt 5 reaches the Portage tree.
Comment 2 Jacob Godserv 2014-08-01 17:47:20 UTC
We're on to 3.0.15.1, but still no Qt 5 in the tree, so I guess we continue to wait.
Comment 3 Karol Herbst 2014-09-17 10:33:23 UTC
Created attachment 384928 [details]
teamspeak-client-bin 3.0.16 ebuild
Comment 4 Karol Herbst 2014-09-17 15:42:31 UTC
Created attachment 384940 [details]
new version

qt.conf has to be removed, too
Comment 5 Michael Lawrence 2014-09-24 02:54:31 UTC
3.0.16

bumped upstream again.
Comment 6 Michael Lawrence 2014-09-24 03:08:10 UTC
http://gpo.zugaina.org/Overlays/farmboy0/media-sound/teamspeak-client-bin
teamspeak-client-bin-3.0.16
Comment 7 Karol Herbst 2014-09-24 12:48:21 UTC
Created attachment 385388 [details]
new version 3.0.16

I fixed some minor stuff:
 * year in copyright
 * required USE-flag sqlite added to qtsql dep
 * add error message if removing bundled Qt files fails
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2014-11-04 08:25:17 UTC
*** Bug 528160 has been marked as a duplicate of this bug. ***
Comment 9 Karol Herbst 2015-01-14 23:17:30 UTC
I could maintain the ebuild, but I don't think anybody would let me yet :/
Comment 10 Pacho Ramos gentoo-dev 2015-01-15 10:52:41 UTC
Why do you think people wouldn't let you do that? Proxy maintainers are highly welcome (and needed) for maintainer-needed packages :)
https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers
Comment 11 Manuel Rüger (RETIRED) gentoo-dev 2015-01-15 11:14:57 UTC
(In reply to Pacho Ramos from comment #10)
> Why do you think people wouldn't let you do that? Proxy maintainers are
> highly welcome (and needed) for maintainer-needed packages :)
> https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers

s/Proxy maintainers/Proxied maintainers/ Yes this is confusing. :)

@Karol as I know you from #g-kde, if you're interested in helping out, ping me there.
Comment 12 Manuel Rüger (RETIRED) gentoo-dev 2015-01-15 16:42:06 UTC
*teamspeak-client-bin-3.0.16 (15 Jan 2015)

  15 Jan 2015; Manuel Rüger <mrueg@gentoo.org>
  +teamspeak-client-bin-3.0.16.ebuild, -teamspeak-client-bin-3.0.11.1.ebuild,
  -teamspeak-client-bin-3.0.12.ebuild, -teamspeak-client-bin-3.0.13.ebuild,
  metadata.xml:
  Proxy commit for Karol Herbst. Add him as proxied maintainer. Version bump.
  Remove old. Fixes bug #504604.
Comment 13 Christophe PEREZ 2015-02-02 21:10:12 UTC
why doesn't depend on qt > 5.0 ?

RDEPEND="
        dev-qt/qtcore:5
        dev-qt/qtgui:5[accessibility]
        dev-qt/qtnetwork:5
        dev-qt/qtsql:5[sqlite]
        dev-qt/qtwidgets:5

really essential ?
Comment 14 Karol Herbst 2015-02-03 14:43:24 UTC
(In reply to Christophe PEREZ from comment #13)
> why doesn't depend on qt > 5.0 ?
> 
It does?

> RDEPEND="
>         dev-qt/qtcore:5
>         dev-qt/qtgui:5[accessibility]
>         dev-qt/qtnetwork:5
>         dev-qt/qtsql:5[sqlite]
>         dev-qt/qtwidgets:5
> 
> really essential ?

I am not sure about dev-qt/qtgui:5[accessibility], but the Qt4 version of teamspeak-client.bin depends on that and so I guess there is no change for the Qt5 one, but never tried it out myself. The others are required though.