Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 50419

Summary: kvim python vimpython Error detected while processing /usr/share/vim/vimfiles/plugin/python.vim:
Product: Gentoo Linux Reporter: Aaron Peterson <alpeterson>
Component: Current packagesAssignee: Gentoo KDE team <kde>
Severity: normal    
Priority: High    
Version: 2004.1   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Aaron Peterson 2004-05-07 15:52:23 UTC
vimpython 1.7

when running it, a window pops up
Error <2> is the window title
line 58 - off my screen
then E10 \ should be followed by /,? or &


Reproducible: Always
Steps to Reproduce:
1. emerge kvim
2. run kvim
3. see error message
4. have python menu not work.
5. reemerge vimpython
6. it still doesn't work
7. try gvim, the python menu works

this might be upstream

bash-2.05b# emerge --info
Portage 2.0.50-r6 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3_pre20040420-r0,
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(TM) XP 1700+
Gentoo Base System version 1.4.10
distcc 2.14 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r3
Automake: sys-devel/automake-1.8.3
CFLAGS="-march=athlon-xp -mmmx -m3dnow -msse -fomit-frame-pointer -O2 -pipe -Wall"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -mmmx -m3dnow -msse -fomit-frame-pointer -O2 -pipe -Wall"
FEATURES="autoaddcvs ccache sandbox"
USE="X aalib acpi acpi4linux alsa amd apache2 apm arts artswrappersuid avi
berkdb bidi bonobo canna cdr cjk cjkcrypt crypt cscope cups dga directfb doc dv
dvb dvd encode esd evms2 faad fbcon ffmpeg flac flash foomaticdb freetype
freewnn fs gdbm ggi gif gnome gpm gstreamer gtk gtk2 gtkhtml guile imagemagick
imap imlib jack java javascript joystick jpeg kde kerberos krb4 ldap libcss
libdvdread libg++ libwww mad maildir md5sum mdb mikmod mmx motif mozilla mpeg
mpeg4 mule mysql nas ncurses net nls nptl nvidia oggvorbis opengl oss pam pdflib
perl pic png postgres python qt quicktime readline samba sasl scanner sdl slang
spell sse ssl svga tcltk tcpd tetex tiff transcode truetype unicode usb v4l
vhosts virus-scan x86 xine xinerama xml2 xmms xv xvid zeo zlib"

Comment 1 Caleb Tennis (RETIRED) gentoo-dev 2004-05-18 17:09:38 UTC
sounds like it probably is upstream - i don't use any vim so I can't verify that though.
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2004-07-25 14:00:27 UTC
Please raise your voice in bug 56992, if necessary. I'll close this bug, if kvim gets hard masked.
Comment 3 Aaron Peterson 2004-07-25 17:35:00 UTC
well, I don't really use kvim in kde anyway... but sometimes my documents have extra 'i's in there, and an occasional ':wq' ... 

I haven't tried loading kvim in a while.

Yeah, I guess masking it would be good, and then when it gets reintroduced I'll be happy to try it then.

(resolved LATER is probably the way to close this bug)
Comment 4 Carsten Lohrke (RETIRED) gentoo-dev 2004-07-31 09:06:49 UTC
>(resolved LATER is probably the way to close this bug)
Since there's no one, who integrates the >500 bugfixes Ciaran spoke about, there's no reason to resolve it as later.