Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 503914

Summary: net-misc/iputils: patches for building against sys-libs/musl
Product: Gentoo Linux Reporter: David Heidelberg (okias) <david>
Component: [OLD] Core systemAssignee: Gentoo's Team for Core System packages <base-system>
Status: RESOLVED FIXED    
Severity: normal CC: gentoo, herrtimson, musl, tsmksubc
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 430702    
Attachments: 0001-add-missing-limits.h.patch
0002-in-case-HZ-undefined-define-it.patch
0003-fix-include-paths-now-compile-with-both-glibc-and-mu.patch
0004-protocol-timed.h-is-no-longer-required.patch
0005-workaround-only-uclibc-and-glibc-2.patch
0006-replace-non-POSIX-compilant-caddr_t-with-char.patch
0007-replace-u_TYPE-with-compilant-unsigned-TYPE.patch
patch to enable building with USE="idn"

Description David Heidelberg (okias) 2014-03-08 22:59:23 UTC
Patches for fixing warning and errors. Also sent to upstream.

This will make transition from glibc to musl-libc cleaner, please include.

Reproducible: Always
Comment 1 David Heidelberg (okias) 2014-03-08 23:02:56 UTC
Created attachment 372126 [details, diff]
0001-add-missing-limits.h.patch
Comment 2 David Heidelberg (okias) 2014-03-08 23:03:17 UTC
Created attachment 372128 [details, diff]
0002-in-case-HZ-undefined-define-it.patch
Comment 3 David Heidelberg (okias) 2014-03-08 23:03:32 UTC
Created attachment 372130 [details, diff]
0003-fix-include-paths-now-compile-with-both-glibc-and-mu.patch
Comment 4 David Heidelberg (okias) 2014-03-08 23:03:48 UTC
Created attachment 372132 [details, diff]
0004-protocol-timed.h-is-no-longer-required.patch
Comment 5 David Heidelberg (okias) 2014-03-08 23:04:03 UTC
Created attachment 372134 [details, diff]
0005-workaround-only-uclibc-and-glibc-2.patch
Comment 6 David Heidelberg (okias) 2014-03-08 23:04:16 UTC
Created attachment 372136 [details, diff]
0006-replace-non-POSIX-compilant-caddr_t-with-char.patch
Comment 7 David Heidelberg (okias) 2014-03-08 23:04:32 UTC
Created attachment 372138 [details, diff]
0007-replace-u_TYPE-with-compilant-unsigned-TYPE.patch
Comment 8 David Heidelberg (okias) 2014-04-23 21:45:40 UTC
All of them are inside [1] as described in [2].

[1] https://github.com/iputils/iputils
[2] http://marc.info/?l=linux-netdev&m=139816495412457
Comment 9 Anthony Basile gentoo-dev 2014-10-18 22:36:29 UTC
(In reply to David Heidelberger (okias) from comment #8)
> All of them are inside [1] as described in [2].
> 
> [1] https://github.com/iputils/iputils
> [2] http://marc.info/?l=linux-netdev&m=139816495412457

Thanks for these.  Did they ever make it upstream?

I have my own set of patches on the hardened-dev::musl overlay which I came up with some time ago.
Comment 10 David Heidelberg (okias) 2014-10-19 12:03:36 UTC
I think it's basically upstream (I think RedHat guys already using, but not 100% sure). "Old upstream" is dead since 2012.

Feel free to send pull request :)
Comment 11 Anthony Basile gentoo-dev 2014-10-19 12:50:32 UTC
(In reply to David Heidelberger (okias) from comment #10)
> I think it's basically upstream (I think RedHat guys already using, but not
> 100% sure). "Old upstream" is dead since 2012.
> 
> Feel free to send pull request :)

This is your fork of iputils with some patches added.  That's not exactly what I meant by "upstream".  Upstream is not dead:

git clone git://www.linux-ipv6.org/gitroot/iputils
cd iputils
git log

commit 9a9e6e366b4de2bab81d76d3ae50308486582476
Author: YOSHIFUJI Hideaki <hideaki.yoshifuji@miraclelinux.com>
Date:   Fri Jun 20 14:40:15 2014 +0900

    make,spec: Add rpm target.
    
    Signed-off-by: YOSHIFUJI Hideaki <hideaki.yoshifuji@miraclelinux.com>

commit d81a44625b04d487c895473aa77af13420b7afdd
Author: YOSHIFUJI Hideaki <hideaki.yoshifuji@miraclelinux.com>
Date:   Thu Jun 19 17:25:49 2014 +0900

    tftpd: Exit if setuid()/setgid() failed.
    
    Signed-off-by: YOSHIFUJI Hideaki <hideaki.yoshifuji@miraclelinux.com>


... etc.

Looks active to me.  Get your patches into Hideaki's repo and we'll pull from there.  Ping us back when we're good to go and I'll see about pushing them out to the gentoo mirrors.
Comment 12 David Heidelberg (okias) 2014-10-19 15:10:41 UTC
Oh, so he started maintaining it again. I send him email, also about if he want take over github and other infrastructure I build.

So, if he start responding to emails, problem solved :)
Comment 13 David Heidelberg (okias) 2014-10-25 20:07:23 UTC
As I noticed, he only pushed some his patches. Still no answer, no other changes.

I feel like it's his personal repository, where changes are pushed when he needs them.

I synced all relevant commits and pushed them to github https://github.com/iputils/iputils .
Comment 14 SpanKY gentoo-dev 2016-06-02 17:28:07 UTC
*** Bug 551608 has been marked as a duplicate of this bug. ***
Comment 15 SpanKY gentoo-dev 2016-06-02 17:28:51 UTC
upstream just merged a bunch of my patches ... might be a good time to patch bomb them again :)
Comment 16 Anthony Basile gentoo-dev 2016-06-02 18:39:07 UTC
@David, I have lot of patches against iputils on the musl overlay.  Are these duplicates of those?  Thanks for sending these upstream!
Comment 17 David Heidelberg (okias) 2016-06-02 20:17:34 UTC
@Anthony:
git://git.linux-ipv6.org/gitroot/iputils.git - no musl support, just some nitpicks (not even complete as I saw recent patches)..

https://github.com/iputils/iputils/ - lot of fixes, active patch accepting, after big cleanup, small development (mostly Red Hat guys), musl support (tested)... Fedora & Debian also already using this one (any I'm really happy for that)

@vapier:
well... I don't get reason why YOSHIFUJI works this way, but I think it cause more harm than good.. anyway, at least big players switched to github based iputils :) (also, still, I love unified ping.. I hate that because I knew in windows you can just do ping ::1 instead of ping6 ::1 ...)
Comment 18 David Heidelberg (okias) 2016-06-02 21:19:14 UTC
oh I see, latest Gentoo version is already based on github :)

Great, thank you! :)
Comment 19 Stijn Tintel 2016-07-29 08:01:13 UTC
net-misc/iputils-20151218-r99::musl doesn't build with USE=idn. Do I attach build.log here, or open a new bug?
Comment 20 David Heidelberg (okias) 2016-11-05 17:39:10 UTC
MUSL guys, could you drop ::musl version of iputils?

Latest iputils based of github included in portage is completly musl compatible :)

So closing as resolved.
Comment 21 Felix Janda 2016-11-05 17:53:44 UTC
Since no stable version works with musl, iputils cannot yet be removed
from the overlay. (Also note that the latest version is still masked.)
Comment 22 David Heidelberg (okias) 2016-11-05 19:18:15 UTC
oh, today is new release 20161105, which should fix all 201603xx bugs, so I guess it will be unmasked soon. Also guys from Debian will package it soon, so I hope there will be no problem..

Anyway, reopening for now, thanks for notification about masking..
Comment 23 Thomas Deutschmann gentoo-dev Security 2017-10-28 15:16:47 UTC
=net-misc/iputils-20171016_pre should be now available, unmasked. Closing as fixed. Please re-open if you still have the reported issue with latest version.
Comment 24 Aric Belsito 2017-10-29 21:22:56 UTC
Created attachment 500958 [details, diff]
patch to enable building with USE="idn"

@whissi
This still isn't fixed. 20171016_pre still requires the following patch is USE="idn" is used.
Comment 25 Thomas Deutschmann gentoo-dev Security 2017-10-29 22:26:53 UTC
Thanks, I created a PR for upstream: https://github.com/iputils/iputils/pull/111

Will be fixed in Gentoo in a minute...
Comment 26 Larry the Git Cow gentoo-dev 2017-10-29 22:29:22 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4c0166edf28e7359be5d1057a9cf5a7415b42653

commit 4c0166edf28e7359be5d1057a9cf5a7415b42653
Author:     Thomas Deutschmann <whissi@gentoo.org>
AuthorDate: 2017-10-29 22:25:38 +0000
Commit:     Thomas Deutschmann <whissi@gentoo.org>
CommitDate: 2017-10-29 22:29:14 +0000

    net-misc/iputils: Fix build issue on MUSL
    
    Closes: https://bugs.gentoo.org/503914
    Package-Manager: Portage-2.3.13, Repoman-2.3.4

 net-misc/iputils/files/iputils-99999999-musl.patch | 92 ++++++++++++++++++++++
 net-misc/iputils/iputils-20171016_pre.ebuild       |  5 +-
 net-misc/iputils/iputils-99999999.ebuild           |  5 +-
 3 files changed, 100 insertions(+), 2 deletions(-)