Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 496146

Summary: app-text/libetonyek-0.0.3 - KEY2StyleParser.cpp:65:86: error: no matching function for call to 'readNumber(const libetonyek::KEYXMLReader&, libetonyek::KEY2Token::<anonymous enum>, <unresolved overloaded function type>)'
Product: Gentoo Linux Reporter: Frank Krömmelbein <kroemmelbein>
Component: [OLD] LibraryAssignee: Gentoo Office Team <office>
Status: VERIFIED FIXED    
Severity: normal CC: cbatdotcom, devurandom, holger, mark+gentoobugs
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log

Description Frank Krömmelbein 2013-12-27 10:13:04 UTC
emerge -pv1 libetonyek
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] app-text/libetonyek-0.0.3 [0.0.0] USE="-doc -static-libs {-test%}" 0 

Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.12.6-gentoo x86_64)
=================================================================
System uname: Linux-3.12.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-2630QM_CPU_@_2.00GHz-with-gentoo-2.2
KiB Mem:    20579064 total,  16396064 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Fri, 27 Dec 2013 09:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo steam-overlay lokal
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/steam /usr/local/portage"
USE="X a52 aac aacplus aacs acl acoustid acpi addns addressbook ads airplay alsa amd64 ap aspell aufs berkdb bittorrent bluetooth bluray branding btrfs bzip2 cairo cdda cddb cdr cec chipcard chm chromaprint clamav cli consolekit corefonts cover cracklib crypt cryptsetup css cups cxx dbus dc1394 declarative device-mapper directfb dlna dmraid doc-pdf dos dri dts dv dvb dvd dvdr ebook efiemu emboss encode epub exif faad fam fbcon ffmpeg firefox flac flite floppy fontconfig fortran freerdp fuse g3dvl gallium gdbm geoip gif gimp git gles gles1 gles2 google gphoto2 gpm gps gtk hbci hdri iconv id3tag idn ieee1394 infinality ipv6 java joystick jpeg jpeg2k kde kdepim kipi ladspa lame lcms ldap libass libcaca libnotify libsamplerate libv4l libvisual lirc lm_sensors lyrics lzma mad maildir marble matroska mbox mbx mdnsresponder-compat mjpeg mmx mmxext mng mobi modemmanager modules mount mp3 mp4 mpeg mplayer mtp mudflap multilib multimedia musicbrainz mysql natspec ncurses netboot network networkmanager nfs nls nptl ntfs ofa offlinehelp ogg opencl openexr opengl openmp opus osmesa p2p pam pango pcmcia pcre pdf phonon plasma png policykit postscript ppds ppp projectm pvr qt3support qt4 radius rar raw rdesktop rdp readline reiserfs rtmp samba scanner sdl semantic-desktop sensord sensors session sftp smartcard smp sna sndfile spell sse sse2 ssh ssl startup-notification subversion svg taglib tcpd telepathy tiff tor tor-hardening transcode tray truetype tslib twolame udev udisks unicode upcall upnp upower usb uxa v4l vaapi vasarajanauloja vcd vdpau vdr video videoslideshow virtualbox vnc vorbis vpx wifi wimax winbind windeco wmf wxwidgets x264 xcb xcomposite xfs xinerama xml xmp xorg xscreensaver xv xvid xvmc zeroconf zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="plymouth btrfs cifs crypt crypt-gpg crypt-loop dmraid iscsi lvm mdraid multipath nfs ssh-client bootchart caps nbd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64 pc qemu emu" INPUT_DEVICES="evdev keyboard mouse joystick synaptics tslib vmmouse lirc" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver presenter-minimizer wiki-publisher" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="x86_64 arm i386" QEMU_USER_TARGETS="x86_64 arm i386" RUBY_TARGETS="ruby18 ruby19 ruby20" SANE_BACKENDS="*" USERLAND="GNU" VIDEO_CARDS="intel nvidia dummy radeon vmware v4l virtualbox modesetting vesa radeonsi fbdev nouveau i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


Reproducible: Always
Comment 1 Frank Krömmelbein 2013-12-27 10:15:14 UTC
Created attachment 366280 [details]
build.log
Comment 2 Stoian Ivanov 2013-12-27 12:27:00 UTC
same here!

hristo ~ # emerge -pv1 libetonyek 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-text/libetonyek-0.0.3 [0.0.0] USE="-doc -static-libs {-test%}" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB
hristo ~ # emerge --info '=app-text/libetonyek-0.0.3::gentoo'
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.17, 3.12.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.12.1-gentoo-x86_64-AMD_Athlon-tm-_II_X3_450_Processor-with-gentoo-2.2
KiB Mem:     5600192 total,   1226260 free
KiB Swap:    5858996 total,   5439852 free
Timestamp of tree: Fri, 27 Dec 2013 10:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.2.5-r3, 3.3.3
dev-util/cmake:           2.8.12.1-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.3, 4.7.3, 4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo alice my_local_overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=k8 "
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=k8 "
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/alice /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gnutls gpm iconv jpeg kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby20 ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="r128 radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 3 Holger Hoffstätte 2013-12-27 12:46:01 UTC
This seems to be a generic upstream error aka a broken "release".
Clang says:

--snip--
In file included from KEY2StyleParser.cpp:17:
In file included from ./KEYStyles.h:19:
./KEYEnum.h:36:27: warning: commas at the end of enumerator lists are a C++11 extension [-Wc++11-extensions]
  KEY_CAPITALIZATION_TITLE,
                          ^
KEY2StyleParser.cpp:65:10: error: no matching function for call to 'readNumber'
  return readNumber<double>(reader, KEY2Token::f, &lexical_cast<double, const char *>);
         ^~~~~~~~~~~~~~~~~~
KEY2StyleParser.cpp:34:13: note: candidate template ignored: couldn't infer template argument 'C'
optional<T> readNumber(const KEYXMLReader &reader, const int type, const C converter)
            ^
KEY2StyleParser.cpp:70:10: error: no matching function for call to 'readNumber'
  return readNumber<int>(reader, KEY2Token::i, &lexical_cast<int, const char *>);
         ^~~~~~~~~~~~~~~
KEY2StyleParser.cpp:34:13: note: candidate template ignored: couldn't infer template argument 'C'
optional<T> readNumber(const KEYXMLReader &reader, const int type, const C converter)
            ^
1 warning and 2 errors generated.
--snip--
Comment 4 Frank Krömmelbein 2013-12-27 13:28:35 UTC
(In reply to Holger Hoffstätte from comment #3)
> This seems to be a generic upstream error aka a broken "release".

It looks like.

I have now "downgraded" the Ebuild to Version 0.0.2:

In portage libetonyek directory
cp libetonyek-0.0.3.ebuild libetonyek-0.0.2.ebuild 
ebuild libetonyek-0.0.2.ebuild manifest
emerge -1 =app-text/libetonyek-0.0.2

Compile of version 0.0.2 was successfull.

I will report back in ~2h when 
emerge app-office/libreoffice-4.1.4.2 
is finished....
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2013-12-27 15:33:20 UTC
Hopefully fixed in cvs.
Comment 6 Holger Hoffstätte 2013-12-27 17:17:21 UTC
(In reply to Tomáš Chvátal from comment #5)
> Hopefully fixed in cvs.

Works - great job! Thanks :)
Comment 7 Frank Krömmelbein 2013-12-28 22:30:27 UTC
For the records version 0.0.2 worked fine here.

But now 0.0.3 compiles here also.
Thanks!