Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 495990

Summary: net-libs/webkit-gtk-2.0.4
Product: Gentoo Linux Reporter: Marko Weber B├╝rgermeister <weber>
Component: Current packagesAssignee: Gentoo Linux bug wranglers <bug-wranglers>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Marko Weber B├╝rgermeister 2013-12-25 13:26:54 UTC
emerge hangs after a while compiling net-libs/webkit-gtk 2.0.4

it starts compiling and after a while it stucks at this:

(process:10562): GLib-GObject-CRITICAL **: g_object_class_install_property: assertion `class->set_property != NULL' failed
Source/WebKit2/UIProcess/API/gtk/WebKitJavascriptResult.cpp:91: Warning: WebKit2: webkit_javascript_result_get_global_context: return value: Unresolved type: 'JSGlobalContextRef'
Source/WebKit2/UIProcess/API/gtk/WebKitJavascriptResult.cpp:105: Warning: WebKit2: webkit_javascript_result_get_value: return value: Unresolved type: 'JSValueRef'
Source/WebKit2/UIProcess/API/gtk/WebKitWebView.cpp:2477: Warning: WebKit2: webkit_web_view_get_javascript_global_context: return value: Unresolved type: 'JSGlobalContextRef'
DerivedSources/webkitdom/WebKitDOMCustom.h:31: Warning: WebKit2: webkit_dom_blob_webkit_slice: return value: Missing (transfer) annotation
DerivedSources/webkitdom/WebKitDOMCustom.h:34: Warning: WebKit2: webkit_dom_html_element_get_class_list: return value: Missing (transfer) annotation
DerivedSources/webkitdom/WebKitDOMEventTarget.h:61: Warning: WebKit2: webkit_dom_event_target_add_event_listener: argument handler: Missing (scope) annotation for callback without GDestroyNotify (valid: call, async)
DerivedSources/webkitdom/WebKitDOMEventTarget.h:67: Warning: WebKit2: webkit_dom_event_target_remove_event_listener: argument handler: Missing (scope) annotation for callback without GDestroyNotify (valid: call, async)
DerivedSources/webkitdom/WebKitDOMCustom.h:39: Warning: WebKit2: webkit_dom_webkit_named_flow_get_content_nodes: return value: Missing (transfer) annotation
DerivedSources/webkitdom/WebKitDOMCustom.h:40: Warning: WebKit2: webkit_dom_webkit_named_flow_get_regions_by_content_node: return value: Missing (transfer) annotation
/usr/bin/g-ir-compiler --includedir ./Source/WebKit2 --includedir . WebKit2-3.0.gir -o WebKit2-3.0.typelib

nothing happens until i press strg+c

multiple retries dont solve it.


# emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.10.25_weber3.10.25 x86_64)
=================================================================
System uname: Linux-3.10.25_weber3.10.25-x86_64-AMD_Phenom-tm-_II_X4_905e_Processor-with-gentoo-2.2
KiB Mem:    16437784 total,   1509144 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Wed, 25 Dec 2013 11:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.6.8-r3, 2.7.5-r3, 3.2.5-r3, 3.3.2-r2
dev-util/cmake:           2.8.11.2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo squeezebox x-databunka
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/squeezebox /usr/portage/local/databunka"
USE="X a52 aac acl acpi aio alsa amd64 berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib cups cxx dbus declarative device-mapper dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm graphite gtk iconv icu jpeg kde kipi lcms libnotify mad mmx mng modules mp3 mp4 mpeg mplayer mtp mudflap multilib ncurses network-cron nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline samba sdl semantic-desktop session spell sql sse sse2 ssl startup-notification svg syslog tcpd tiff truetype udev udisks unicode upower usb vorbis wav webkit wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby19 ruby18" SANE_BACKENDS="canon" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON



any ideas why emerging this package stops at this position?

marko
Comment 1 Pacho Ramos gentoo-dev 2013-12-25 13:33:10 UTC

*** This bug has been marked as a duplicate of bug 463960 ***