Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 49524

Summary: RealAudio codecs does not install properly (media-video/mplayer bug ?)
Product: Gentoo Linux Reporter: Viacheslav Kaloshin <multik>
Component: [OLD] LibraryAssignee: media-video herd <media-video>
Status: RESOLVED FIXED    
Severity: trivial CC: chriswhite, flash3001, rizzo
Priority: High    
Version: 2004.1   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 53634    
Bug Blocks:    

Description Viacheslav Kaloshin 2004-04-30 11:08:56 UTC
When I try to install media-video/mplayer (1.0_pre4), he fetch next packages:

>>> md5 src_uri ;-) win32codecs-20031001.tar.bz2
>>> md5 src_uri ;-) rp9win32codecs-20031001.tar.bz2
[skip]

But if I am try to listen some RealAudio broadcast radio

mplayer -cache 32 rtsp://media1.abc.net.au/encoder/network2.rm

I see next

........
Error: /usr/lib/real/sipr.so.6.0: cannot open shared object file: No such file or directory
opening win32 dll 'sipr.so.6.0'
Win32 LoadLibrary failed to load: sipr.so.6.0, /usr/lib/win32/sipr.so.6.0, /usr/local/lib/win32/sipr.so.6.0
Error loading dll
ERROR: Could not open required DirectShow codec sipr.so.6.0.
Read the RealAudio section of the DOCS!
......
Opening audio decoder: [realaud] RealAudio decoder
opening win32 dll 'sipr3260.dll'
......

Btw, i can hear radio stantion, but sound is ugly and volume is too low

Possible solutions, thats works when compile mplayer manually with the same options (when do emerge media-video/mplayer after looking at sipr.so.6.0 - configuration script skip something and error happens again. I am too newbie to find bad line in ebuild file):

Solution1:

use RealAudio codecs pack from http://www1.mplayerhq.hu/MPlayer/releases/codecs/rp9codecs.tar.bz2

instead of current

Solution 1.1 (bad)

Add RealAudio codecs from above to rp9win32codecs

Solution2:

Call scripts from /usr/share/doc/mplayer-1.0_pre4/TOOLS/realcodecs

IMHO, All actions must be done (e.g. /usr/lib/win32/sipr.so.6.0 must exist) before running of MPlayer configure script.
Comment 1 Chris White (RETIRED) gentoo-dev 2004-06-28 11:45:19 UTC
http://www.abc.net.au/streaming/

The one you listed didn't work, so I tried some from here.  My issue is that NONE of them play.  I'm going to check out the mplayer codecs you mentioned and see if it does any good.  If so, I'll recommend for commit.  If not, I'll take it upstream :).
Comment 2 Don Seiler (RETIRED) gentoo-dev 2004-06-29 12:16:22 UTC
FWIW, the URL to updated codecs is http://ftp3.mplayerhq.hu/MPlayer/releases/codecs/
Comment 3 Chris White (RETIRED) gentoo-dev 2004-06-30 14:29:34 UTC
I'm going to do an all in one and post all the ebuilds/etc to bug #53634.

The codecs are implemented using #1 in a USE flag.
Comment 4 Chris White (RETIRED) gentoo-dev 2004-11-10 18:36:06 UTC
Had to work around the codec thingy a bit, but the lastest win32 codecs does
everything ok.  I tried triple j since the news part was down, plays just fine, in
fact, plays so fine, I think I'll listen to it some more :P (Testing is fun!).