Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 494518

Summary: app-emulation/emul-linux-x86-baselibs should install sys-libs/ncurses with USE=tinfo
Product: Gentoo Linux Reporter: Patrick McMunn <doctorwhoguy>
Component: [OLD] LibraryAssignee: Multilib team <multilib>
Status: RESOLVED OBSOLETE    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 544876    
Bug Blocks: 457530    

Description Patrick McMunn 2013-12-17 09:40:03 UTC
Some binary packages require libtinfo.so.5 which is not provided by app-emulation/emul-linux-x86-baselibs. It would be helpful if ncurses was compiled with the tinfo USE flag enabled so that this library would be provided for these packages. At this time the only workaround is to create a symlink pointing to libncurses.so.5.

Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2013-12-17 12:54:21 UTC
Lots of other packages fail when sys-libs/ncurses is built with USE=tinfo, since they expect certain symbols to be exposed by libncurses and not libtinfo, so we have a long way to go before this can be safely done. The tracker bug in question is probably incomplete as of now and even the remaining bugs will take some time to fix.