Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 49410

Summary: GCC fails compile, G5 is a bad switch value for mcpu tag
Product: Gentoo Linux Reporter: Tim Morgan <MorganBolt>
Component: [OLD] GCC PortingAssignee: Please assign to toolchain <gcc-porting>
Status: VERIFIED INVALID    
Severity: normal    
Priority: High    
Version: 2004.1   
Hardware: PPC64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Tim Morgan 2004-04-29 12:52:51 UTC
In the process of installing Gentoo on my G5.  I emerge system, and it gets to the GCC compile and install.  GCC compiles for a while, but emerge exits with an error stating that G5 was an invalid value for the mcpu switch in one of the source files (do you need to know which one?).  Other source files in GCC have correctly compiled at this point.  I've tried the usebinpkg tag to no avail. (I think I don't have PORTAGE_BINHOSTS configured correctly; I'll have to fix that problem...)

Reproducible: Always
Steps to Reproduce:
1. emerge gcc
2. Wait for error described above
3. Pull out hair

Actual Results:  
The source is downloaded.  The config file runs.  GCC begins compiling.  After 
a bit of a wait, the compile is halted due to the above error.

Expected Results:  
Compiled and installed gcc and continued on its merry way to the next package.

Running a DP G5/1.8GHz.  Altivec enabled.

(Do you really need the emerge info output?  Let me know if you do.)

I realize that G5 support is experimental at this point, but any insight you 
could give would be appreciated...
Comment 1 Tim Morgan 2004-04-29 13:58:43 UTC
emerge info can now be found at http://cs.beloit.edu/~morgant/info.txt
Comment 2 Tim Morgan 2004-04-29 21:04:57 UTC
Sorry; realized GCC 3.2 doesn't yet support PPC 970 processor optimization.  Closed bug.
Comment 3 Luca Barbato gentoo-dev 2004-05-04 11:35:10 UTC
try the latest gcc 333-hammer snapshot in portage

gcc-3.3.3_pre20040426

it is currently p.masked but will be put on ~ppc and ~ppc64 after a full test.
Comment 4 Tom Gall (RETIRED) gentoo-dev 2004-05-10 08:43:23 UTC
also be careful to observe the following derivtions

on gentoo-ppc64 use:

-mtune=g5   not -mcpu or you'll be in a world of hurt for your 64 bit toolchain.