Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 489028

Summary: app-emulation/virtualbox-4.3.0 - host hangs on virtualbox start
Product: Gentoo Linux Reporter: Mark Knecht <markknecht>
Component: Current packagesAssignee: Lars Wendler (Polynomial-C) <polynomial-c>
Status: RESOLVED FIXED    
Severity: normal CC: bkohler, metatheorem, patrick, saintdev, sven.koehler
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://forums.virtualbox.org/viewtopic.php?f=7&t=57842
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: virtualbox log file from crash

Description Mark Knecht 2013-10-22 15:51:21 UTC
Machine hangs running virtualbox-4.3. I've reported this into the Virtualbox forums. Oracle is looking at it. There are multiple people experiencing the same sort of symptoms across a number of distros so it's not a Gentoo specific thing. Posting bug report here so that devs here can track it as they wish and hopefully other users don't spend as much time on this as I have. I've gone back to 4.2.18.

https://forums.virtualbox.org/viewtopic.php?f=7&t=57842

Reproducible: Sometimes

Steps to Reproduce:
1. emerge virtualbox virtualbox-modules virtualbox-additions virtualbox-extpack-oracle
2. Run VB as normal

Actual Results:  
Machine is hung, no mouse or keyboard, cannot ssh in from another machine, magic sys keys don't work, hard reset appears to be the only way out. Has happened at least 5 times.

Expected Results:  
Should just work

c2RAID6 ~ # emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.10.17-gentoo x86_64)
=================================================================
System uname: Linux-3.10.17-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_X_980_@_3.33GHz-with-gentoo-2.2
KiB Mem:    24425372 total,   4298948 free
KiB Swap:   12602976 total,  12602976 free
Timestamp of tree: Tue, 22 Oct 2013 15:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo vmware
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 PUEL AdobeFlash-10.3 skype-eula google-chrome skype-4.0.0.7-copyright google-talkplugin Google-TOS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --jobs=5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j13 -l8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/vmware"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gstreamer gtk iconv java jpeg jpeg2k kde kipi lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell sse sse2 ssl ssse3 startup-notification svg tcpd tiff truetype type1 udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

c2RAID6 ~ #
Comment 1 Jeroen Roovers gentoo-dev 2013-10-24 12:01:11 UTC
Is it the virtual machine that hangs or the host system?
Comment 2 Mark Knecht 2013-10-24 13:10:05 UTC
The Gentoo host system is completely hung. No magic sys keys, cannot ping the box or ssh in. Really hung.

I've tried setting up kdump to see if I can catch anything but I don't think I've done it correctly and haven't managed to catch anything yet. I've gone back to 4.2.18 just so I can do my daily work.
Comment 3 Ryan Twitchell 2013-11-02 18:31:17 UTC
I am having similar problems with a gentoo amd64 host with 4.3.0-r2.  But I am not having issues on VM start, only eventually within an hour or two of a VM running.

Exact same symptoms though: no mouse, no keyboard, no SysRq magic.  Sound, if playing, continuously loops for about a second.  Hard reset necessary.

Was running 4.2 versions with same VMs (Linux and Windows machines) with no problems.

$ emerge --info
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.16-gentoo x86_64)
=================================================================
System uname: Linux-3.10.16-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.2
KiB Mem:     8105828 total,   5629396 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Sat, 02 Nov 2013 06:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r4, 3.2.5-r3, 3.3.2-r2
dev-util/ccache:          3.1.9-r3
dev-util/cmake:           2.8.12
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1, 4.8.1-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.11 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.1/conf /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo http://mirrors.rit.edu/gentoo/ "
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo ccache cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fontconfig fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng mod
ules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio python qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets
x264 xcb xft xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="auth
n_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expire
s ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CA
MERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 ti
ming tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_
TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="vga nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p if
ace geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 Mark Knecht 2013-11-02 18:35:54 UTC
Yes, I never said it hung right away. Jeroen change the name of the post. In my case it sometimes hung right away but most of the time hung after some period time - 5 minutes, 30 minutes, etc. I went back to 4.2.18 and haven't had any trouble.

There was a text version supplied in my thread in the Virtualbox forums. Others said it fixed the problem for them. I currently have >=4.3 masked so I haven't tried the version you're referring to. Is it using that same install package or building completely from source?
Comment 5 Mark Knecht 2013-11-02 18:41:08 UTC
Ryan: I see this morning that there is a 4.3.2 version in portage. Have you tried it yet?
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2013-11-02 20:33:21 UTC
Please test virtualbox-4.3.2 and report back if this version works for you.
Comment 7 Mark Knecht 2013-11-02 22:13:05 UTC
I tested 4.3.2 this afternoon. Unfortunately it did not fix the problem. My whole Gentoo box crashed within about 30 minutes of starting. I was lightly loaded at the time. Only 1 VM running. The box crashed as I was working in Handbrake in Linux. The VM was doing nothing to the best of my knowledge. 

I normally run about 3 VMs in parallel - 2 VBox and 1 VMWare player. Ran all 3 this morning with no problems. Upgraded to 4.3.2 and hit the problem quite quickly.

I will attach the VBox log file from the crash in a minute.
Comment 8 Mark Knecht 2013-11-02 22:14:05 UTC
Created attachment 362446 [details]
virtualbox log file from crash
Comment 9 Sven 2013-11-09 14:02:23 UTC
I don't understand the subject of this bug. As far as I understood Mark on the virtualbox forums, running a virtual machine with multiple CPUs (in particular windows guests) will make the Linux host crash after a while.
If Mark really means, that starting virtualbox crashes the host, then we're really discussing different issues here (in particular, Mark has mentioned that runs VMWare and virtualbox in parallel, which I don't).
Comment 10 Mark Knecht 2013-11-09 14:29:16 UTC
The title of the bug is no longer mine. Jeroen changed it in his first post. IIRC I had called it "virtualbox-4.3.0 - hard crashes / machines completely hung". It's the same bug. I started the report here as a head's up because I don't want to see 4.2.18 removed from portage until this is understood.

My crashes do not happen at a reproducible time. Sometimes 1-2 minutes, sometimes 30-90 minutes. Always the machine seems to be 100% hung not responding to magic sys keys or anything else I might have tried.
Comment 11 Ryan Twitchell 2013-11-10 01:17:15 UTC
Tried the 4.3.2 version in portage with the same results: locks the host within a few hours each time.
Comment 12 Nathan Caldwell 2013-11-11 20:31:44 UTC
I just posted my kernel log and virtual machine info on the forum thread. I can attach them here also, if anyone would like me to.
Comment 13 Ben Kohler gentoo-dev 2013-11-18 19:58:32 UTC
Some posts on the forum thread suggest that "Preemptible Kernel (Low-Latency Desktop)" (aka CONFIG_PREEMPT=y) is to blame, can you try easing that back to "Voluntary Kernel Preemption (Desktop)" (aka CONFIG_PREEMPT_VOLUNTARY=y) to see if this helps?  On your host, that is.

If so we can look at adding a config check in the ebuild, probably non-fatal but with a stern warning =)
Comment 14 Mark Knecht 2013-11-18 20:03:49 UTC
I've seen that in the forum thread since last week but been hesitant to put my server through another hard crash but if there's nothing posted here or in that thread by 2PM today I'll give it a try.
Comment 15 Mark Knecht 2013-11-19 01:03:18 UTC
Just a status report. Please don't take any action. 

I've rebuilt the gentoo-sources-3.10.19 and now have the same PREEMPT options set as the forum thread:

mark@c2RAID6 ~ $ zcat /proc/config.gz | grep PREEMPT
# CONFIG_PREEMPT_RCU is not set
CONFIG_PREEMPT_NOTIFIERS=y
# CONFIG_PREEMPT_NONE is not set
CONFIG_PREEMPT_VOLUNTARY=y
# CONFIG_PREEMPT is not set
mark@c2RAID6 ~ $ uname -a
Linux c2RAID6 3.10.19-gentoo #2 SMP Mon Nov 18 15:26:22 PST 2013 x86_64 Intel(R) Core(TM) i7 CPU X 980 @ 3.33GHz GenuineIntel GNU/Linux
mark@c2RAID6 ~ $

I've built virtualbox-4.3.2 and all of it's other packages and have started one VM. I have not installed the 4.3.2 Guest Additions in the VM at this time. The VM is logged into Win 7 and just sitting quietly at the Windows desktop. I'm going to run it pretty lightly for the next few hours. If that goes OK I'll run the second Win 7 VM and see how it goes.

I intend to take this slowly at first. If there is still a problem maybe I'll be able to catch something that helps.

So far so good, but it's only been up 30 minutes which in that past was probably a 70% chance of catching the problem but not a guarantee of it. All previous crashes had all the Guest Additions for 4.3.x installed so this may not crash at all. We'll see...

Back later,
Mark
Comment 16 Mark Knecht 2013-11-19 19:53:06 UTC
OK, with about 10-12 hours of reasonable use I've not seen a crash yet which is good. I've just installed the Guest Additions stuff for Ver. 4.3.2 in both VMs and will run that for a couple of days but so far switching to CONFIG_PREEMPT_VOLUNTARY=y seems to have helped. I never made it longer than I think 2 hours before.

I'll report status back here in a couple of days. I'll also throw a similar message in the Virtualbox forums updating this info for non-Gentoo folks.
Comment 17 Ben Kohler gentoo-dev 2013-11-30 15:52:09 UTC
From recent forum updates: https://forums.virtualbox.org/viewtopic.php?f=7&t=57842&sid=1284319b196f311a2d30809734c9c882&start=90#p273274

>I found one issue which only happens on such fully preemptible kernels. I cannot yet say if this is what the cause of the host crashes are, but might be able to put out a test build once the fix is in.

>Update: It seems release builds are affected too. There might be corruption of TSC AUX MSR on fully preemptible linux kernels. Fix is coming soon, hopefully it -is- the cause of the issues being reported here.

>An attempted fix is in 4.3.4, feel free to give it a whirl.
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2013-12-03 09:38:06 UTC
Any news here now that virtualbox-4.3.4 is in the tree?
Comment 19 Mark Knecht 2013-12-03 17:04:35 UTC
I'm running virtualbox-4.3.4 with the following kernel PREEMPT settings

c2RAID6 linux # zcat /proc/config.gz | grep PREEMPT
CONFIG_TREE_PREEMPT_RCU=y
CONFIG_PREEMPT_RCU=y
CONFIG_PREEMPT_NOTIFIERS=y
# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
CONFIG_PREEMPT=y
CONFIG_PREEMPT_COUNT=y
CONFIG_DEBUG_PREEMPT=y
c2RAID6 linux # 

c2RAID6 linux # lsmod | grep vbox
vboxpci                10376  0 
vboxnetflt             13592  1 
vboxnetadp             17120  0 
vboxdrv               223330  5 vboxnetadp,vboxnetflt,vboxpci
c2RAID6 linux #

Other than the DEBUG_PREEMPT I think I'm back to the kernel config when these problems started. I've now been up for a couple of days with no crashes so it's looking pretty good here.

I'm not totally clear on when the vboxpci driver came online. I really don't remember that being there a year ago but it's in my /etc/conf.d/modules file now so I likely added it somewhere along the way:

c2RAID6 linux # cat /etc/conf.d/modules | grep vbox
modules="agpgart nvidia vboxdrv vboxnetadp vboxnetflt vboxpci"
c2RAID6 linux #

Anybody know what that module's purpose is?

I'll wait for others to confirm but I'm starting to think the problem is solved.

- Mark
Comment 20 Sven 2013-12-03 17:33:29 UTC
(In reply to Mark Knecht from comment #19)
> Anybody know what that module's purpose is?

I believe the vboxpci module is for allowing virtualbox guests to access pci devices of the host, i.e. pci passthrough:
http://www.virtualbox.org/manual/ch09.html#pcipassthrough
Comment 21 Mark Knecht 2013-12-03 17:37:44 UTC
Thanks Sven. Your analysis seems likely and it's not at this time something I need in my VMs so I'll consider not loading that module.

Thanks.
Comment 22 Walter 2013-12-05 10:56:12 UTC
My computer still hangs shortly after starting a VirtualBox machine with virtualbox-bin 4.3.4 (no problem with 4.2.x). I can restart using magic sysrq heys.

$ zcat /proc/config.gz | grep PREEMPT
CONFIG_TREE_PREEMPT_RCU=y
CONFIG_PREEMPT_RCU=y
CONFIG_PREEMPT_NOTIFIERS=y
# CONFIG_PREEMPT_NONE is not set
# CONFIG_PREEMPT_VOLUNTARY is not set
CONFIG_PREEMPT=y
CONFIG_PREEMPT_COUNT=y
# CONFIG_DEBUG_PREEMPT is not set

# emerge --info
Portage 2.2.7 (default/linux/x86/13.0/desktop/kde, gcc-4.7.3, glibc-2.16.0, 3.12.2-gentoo i686)
=================================================================
System uname: Linux-3.12.2-gentoo-i686-AMD_Athlon-tm-_Dual_Core_Processor_5400B-with-gentoo-2.2
KiB Mem:     7249600 total,   3864960 free
KiB Swap:    1060284 total,   1060284 free
Timestamp of tree: Thu, 05 Dec 2013 10:30:01 +0000
ld ld di GNU (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r3, 3.2.5-r3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo local
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA skype-eula PUEL AdobeFlash-10.1 google-talkplugin googleearth AdobeFlash-10.3 skype-4.0.0.7-copyright Intel-SDP AdobeFlash-11.x"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local"
USE="X a52 aac acl acpi alsa apache2 attica avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli clucene consolekit cracklib cron crypt cups cxx dbus declarative djvu dri dts dvd dvdr embedded emboss encode exif extensions fam ffmpeg firefox flac fontconfig fortran fpm gd gdbm gif gles google-gadgets gpm gtk gzip handbook iconv icu inotify ipv6 javascript jpeg kde kipi kvm lcms ldap libkms libnotify lzma mad mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses network-cron nls nouveau nptl nsplugin ogg opengl openmp pam pango passenger pcre pdf phonon php plasma png policykit ppds pygments qt3support qt4 readline ruby samba sdl semantic-desktop session slp spell sqlite sse sse2 ssl ssse3 startup-notification svg symlink syslog tcpd threads tiff truetype udev udisks unicode upower usb vboxwebsrv vdpau vim-syntax vlc vorbis wayland wxwidgets x264 x86 xcb xcomposite xft xinerama xml xorg xrandr xscreensaver xv xvid zeroconf zip zlib" ABI_X86="32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_coresocache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport" LINGUAS="it en en_GB" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_req limit_zone map memcached proxy referer rewrite scgi split_clients ssi stub_status upstream_ip_hash upload userid uwsgi" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3 php5-4 php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

Tell me if you need more informations
Comment 23 Mark Knecht 2013-12-06 16:41:30 UTC
If I read your emerge --info correctly the machine in question is running 32-bit Gentoo? Not sure why that would matter exactly but mine is 64-bit and it's been completely stable here over the last few days.

I would suggest that you report this in the Virtualbox forums and see what help you can find there. The link for that thread is in my first post.

Good luck
Comment 24 Sven 2013-12-06 17:00:33 UTC
Also, his system is AMD while mine is Intel (Mark is also on Intel).
Walter should report his problems here:
https://forums.virtualbox.org/viewtopic.php?f=7&t=57842