Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 480182

Summary: =dev-qt/qtgui-4.8.5 with media-libs/jpeg-9-r1 - In function ‘boolean qt_fill_input_buffer(j_decompress_ptr)’: ../../../gui/image/qjpeghandler.cpp:163:12: error: cannot convert ‘bool’ to ‘boolean’ in return
Product: Gentoo Linux Reporter: Kobboi <gentoo>
Component: [OLD] LibraryAssignee: Qt Bug Alias <qt>
Status: RESOLVED FIXED    
Severity: normal CC: achurch+gentoo, hwoarang, levertond, mbays
Priority: Normal Keywords: PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 479818    
Attachments: build.log
Patch

Description Kobboi 2013-08-07 17:30:25 UTC
x86_64-pc-linux-gnu-g++ -c -march=core2 -msse4 -mcx16 -mpopcnt -msahf -O2 -pipe -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -fvisibility=hidden -fvisibility-inlines-hidden -D_REENTRANT -Wall -W -fPIC -DQT_NO_DEBUG -DQT_PLUGIN -DQT_GUI_LIB -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_HAVE_SSE4_1 -DQT_HAVE_SSE4_2 -DQT_HAVE_AVX -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -DQT_SHARED -I../../../../mkspecs/linux-g++ -I. -I../../../../include/QtCore -I../../../../include/QtGui -I../../../../include -I../../../gui/image -I.moc/release-shared -o .obj/release-shared/main.o main.cpp
../../../gui/image/qjpeghandler.cpp: In function ‘boolean qt_fill_input_buffer(j_decompress_ptr)’:
../../../gui/image/qjpeghandler.cpp:163:12: error: cannot convert ‘bool’ to ‘boolean’ in return
../../../gui/image/qjpeghandler.cpp: In function ‘boolean qt_empty_output_buffer(j_compress_ptr)’:
../../../gui/image/qjpeghandler.cpp:495:12: error: cannot convert ‘bool’ to ‘boolean’ in return
../../../gui/image/qjpeghandler.cpp: In function ‘bool write_jpeg_image(const QImage&, QIODevice*, int)’:
../../../gui/image/qjpeghandler.cpp:591:83: error: cannot convert ‘bool’ to ‘boolean’ for argument ‘3’ to ‘void jpeg_set_quality(j_compress_ptr, int, boolean)’
../../../gui/image/qjpeghandler.cpp:592:41: error: cannot convert ‘bool’ to ‘boolean’ for argument ‘2’ to ‘void jpeg_start_compress(j_compress_ptr, boolean)’
../../../gui/image/qjpeghandler.cpp: In member function ‘bool QJpegHandlerPrivate::readJpegHeader(QIODevice*)’:
../../../gui/image/qjpeghandler.cpp:757:48: error: cannot convert ‘bool’ to ‘boolean’ for argument ‘2’ to ‘int jpeg_read_header(j_decompress_ptr, boolean)’
../../../gui/image/qjpeghandler.cpp: In function ‘boolean qt_empty_output_buffer(j_compress_ptr)’:
../../../gui/image/qjpeghandler.cpp:497:1: warning: control reaches end of non-void function [-Wreturn-type]
../../../gui/image/qjpeghandler.cpp: In function ‘boolean qt_fill_input_buffer(j_decompress_ptr)’:
../../../gui/image/qjpeghandler.cpp:165:1: warning: control reaches end of non-void function [-Wreturn-type]
make: *** [.obj/release-shared/qjpeghandler.o] Error 1

Reproducible: Always
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2013-08-07 18:33:49 UTC
jpeg-9 is known to be broken, use at least jpeg-9-r1

if you can still reproduce with -r1, reopen the bug and attach complete build.log

*** This bug has been marked as a duplicate of bug 479808 ***
Comment 2 Kobboi 2013-08-09 09:25:24 UTC
Created attachment 355466 [details]
build.log

Still there with media-libs/jpeg-9-r1 (never had 9 on my system actually)
Comment 3 Andrew Church 2013-08-13 04:04:56 UTC
Created attachment 355836 [details, diff]
Patch

Another case of breakage due to the jpeg-9 API change.
Comment 4 Davide Pesavento gentoo-dev 2013-08-13 10:22:41 UTC
(In reply to Andrew Church from comment #3)
> Created attachment 355836 [details, diff] [details, diff]
> Patch
> 

Is this upstream? If not, can you submit it there?
Comment 5 Anders Lundström 2013-08-25 19:48:35 UTC
could someone submit this?
downgrade is unsupported - users like me might loose KDE
ive tried an hour to emerge the patch different ways with no luck
Comment 6 Davide Pesavento gentoo-dev 2013-08-25 20:19:50 UTC
Andrew, is the patch compatible with older media-libs/jpeg? Have you submitted it upstream?
Comment 7 Andrew Church 2013-08-26 00:54:44 UTC
Yes, it is (in theory; I haven't actually tested) compatible with older libjpeg; no, I haven't submitted it upstream.
Comment 8 Davide Pesavento gentoo-dev 2013-08-26 00:58:47 UTC
(In reply to Andrew Church from comment #7)
> Yes, it is (in theory; I haven't actually tested) compatible with older
> libjpeg; no, I haven't submitted it upstream.

Ok, can you please submit it to gerrit https://codereview.qt-project.org/ ?
Comment 9 Andrew Church 2013-08-26 01:28:47 UTC
I didn't see any obvious way to create a Gerrit account, so I filed https://bugreports.qt-project.org/browse/QTBUG-33166 instead.
Comment 10 Davide Pesavento gentoo-dev 2013-08-27 08:42:36 UTC
(In reply to Andrew Church from comment #9)
> I didn't see any obvious way to create a Gerrit account, so I filed
> https://bugreports.qt-project.org/browse/QTBUG-33166 instead.

They don't accept patches attached to jira bug reports. You have to sign the CLA and submit through gerrit. See http://qt-project.org/wiki/Setting-up-Gerrit
Comment 11 Andrew Church 2013-08-27 08:51:23 UTC
Sorry, I'm not interested in signing random agreements just to submit a patch.  Feel free to submit it yourself if you'd like.
Comment 12 Michael Palimaka (kensington) gentoo-dev 2013-09-03 12:55:00 UTC
I will try to upstream this.
Comment 13 Michael Palimaka (kensington) gentoo-dev 2013-10-06 16:28:42 UTC
This is fixed upstream for 4.8.6 and 5.1.2

https://qt.gitorious.org/qt/qt/commit/2a9ea11f4dea51f9e75036aab8e7a23f0eb4bd1f/diffs
Comment 14 Davide Pesavento gentoo-dev 2013-11-28 01:52:48 UTC
*** Bug 492746 has been marked as a duplicate of this bug. ***
Comment 15 Stolz 2014-02-11 16:08:25 UTC
Any progess on this topic?
Comment 16 Michael Palimaka (kensington) gentoo-dev 2014-02-11 16:22:08 UTC
(In reply to Stolz from comment #15)
> Any progess on this topic?

(In reply to Michael Palimaka (kensington) from comment #13)
> This is fixed upstream for 4.8.6 and 5.1.2
> 
> https://qt.gitorious.org/qt/qt/commit/
> 2a9ea11f4dea51f9e75036aab8e7a23f0eb4bd1f/diffs
Comment 17 Stolz 2014-02-12 09:42:14 UTC
(In reply to Michael Palimaka (kensington) from comment #16)
> (In reply to Stolz from comment #15)
> > Any progess on this topic?
> 
> (In reply to Michael Palimaka (kensington) from comment #13)
> > This is fixed upstream for 4.8.6 and 5.1.2
> > 
> > https://qt.gitorious.org/qt/qt/commit/
> > 2a9ea11f4dea51f9e75036aab8e7a23f0eb4bd1f/diffs

I know it's fixed upstream. Also Andrew Church patch works. I just wonder why the only available version of dev-qt/qtgui in Portage is 4.8.5-r1 if the upstream version has fixed this problem.
Comment 18 Michael Palimaka (kensington) gentoo-dev 2014-02-12 15:43:37 UTC
Upstream hasn't yet released a new version. It's not backported into portage due to qt team being seriously understaffed.
Comment 19 Davide Pesavento gentoo-dev 2014-07-04 00:06:39 UTC
Fixed in qtgui-4.8.5-r3

  04 Jul 2014; Davide Pesavento <pesa@gentoo.org>
  +files/qtgui-4.8.5-libjpeg-9.patch, qtgui-4.8.5-r3.ebuild:
  Backport patch to fix build with media-libs/jpeg-9 (bug 480182).