Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 477656

Summary: x11-misc/dzen-0.9.5-r1[-xft] outputs random characters
Product: Gentoo Linux Reporter: Philipp Wagner <wagner.philipp>
Component: Current packagesAssignee: Desktop Misc. Team <desktop-misc>
Severity: normal CC: frostyx, ionen, wagner.philipp
Priority: Normal Keywords: PullRequest
Version: unspecified   
Hardware: AMD64   
OS: Linux   
See Also:
Package list:
Runtime testing required: ---
Attachments: Output given by `locale`
`emerge --info`

Description Philipp Wagner 2013-07-21 17:02:25 UTC
After updating dzen2 0.8.5 to 0.9.5, herbstlufwm doesn't longer start, 

anyway, it's not herbstluftwm's fault, trying "{ echo foo; cat; } | dzen2" does not create the expected bar with "foo" in the middle, instead i get random characters ("X" or "8bj" or similar)

emerge --info is here:

returning to dzen2 0.8.5 fixes the issue
Comment 1 Jakub Kadlčík 2013-09-22 01:20:47 UTC
Code `{ echo foo; cat; } | dzen2` works for me as its expected. It prints 'foo' in the top middle.

This is where I have problem: `{ echo foo-ěščřžýáíé; cat; } | dzen2`. Output is 'foo-     ýáíé' so characters 'ěščřž' are missing.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2013-09-22 15:16:37 UTC
Is this still the case for x11-misc/dzen-0.9.5-r1 ? I can't reproduce the issue. Both commands show the expected output.
Comment 3 Philipp Wagner 2013-09-23 06:46:44 UTC
It works for me with x11-misc/dzen-0.9.5-r1, there are no random characters anymore.
Comment 4 Jakub Kadlčík 2013-09-26 21:00:47 UTC
It seems it doesnt work for me.

   Latest version installed: 0.9.5-r1

When I run that command from my previous comment (#1) it has same result
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2013-09-27 15:29:29 UTC
(In reply to Jakub Kadlčík from comment #4)
> When I run that command from my previous comment (#1) it has same result

Please tell us more about your locale settings. Also, post your `emerge --info' output in a separate comment.
Comment 6 Jakub Kadlčík 2013-09-27 17:05:12 UTC
Created attachment 359632 [details]
Output given by `locale`
Comment 7 Jakub Kadlčík 2013-09-27 17:06:02 UTC
Created attachment 359634 [details]
`emerge --info`
Comment 8 Jakub Kadlčík 2013-09-27 17:06:56 UTC
If any other informations are important, please let me know.
Comment 9 Ionen Wolkens gentoo-dev 2021-02-23 14:38:50 UTC
Since planning to start maintaining had a look at this and, nearly 8 years later, I'm able to reproduce when built with USE=-xft (all good otherwise).

Observing other bad locales behavior with -xft and don't really see a reason to support disabling this, so my plans are just to force enable xft. I'll be happy to bring it back if anyone has a patch to fix this though.
Comment 10 Larry the Git Cow gentoo-dev 2021-02-25 09:15:56 UTC
The bug has been closed via the following commit(s):

commit 8341f84f368eb4942e4021cefb92912432b89a64
Author:     Ionen Wolkens <>
AuthorDate: 2021-02-25 09:15:08 +0000
Commit:     David Seifert <>
CommitDate: 2021-02-25 09:15:08 +0000

    x11-misc/dzen: near-complete rework
    Replaced large 8kB Makefile patch by smaller (not pretty) ebuild
    workarounds leaving things up to pkg-config. This notably fix lld,
    prefix, and crossdev builds.
    Removed unused-but-set patch, its only purpose was to silence
    build-time warnings.
    Removed USE=minimal and disabled by default. Gadgets are small, quick
    to build, and with no extra deps.
    Removed USE=xft and enabled by default (like upstream). Alternate code
    path is unreliable with locales and there's little reasons to support
    it (doubtful will be brought back, so removing rather than forcing).
    New tarball to drop obsolete SRC_URI.
    Package-Manager: Portage-3.0.15, Repoman-3.0.2
    Signed-off-by: Ionen Wolkens <>
    Signed-off-by: David Seifert <>

 x11-misc/dzen/Manifest             |  1 +
 x11-misc/dzen/dzen-0.9.5_p2.ebuild | 63 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 64 insertions(+)