Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 476606

Summary: kde-base/kwin-4.10.4: crashes after unlocking session when locked for 8-10 hours and foss radeon driver is used
Product: Gentoo Linux Reporter: Nikoli <nikoli>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: x11
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 475480    
Bug Blocks:    
Attachments: kwin gdb
glxgears gdb

Description Nikoli 2013-07-12 03:32:53 UTC
With FOSS radeon driver kwin crashes after unlocking session when it was locked for several (8-10) hours. If it was locked only for several minutes it will not crash. Sometimes it does not crash even when locked for hours. No 3D apps are working until X is restarted. dmesg is full of such messages:
[160451.303725] [TTM] Out of kernel memory
[160451.303733] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (4096, 2, 4096, -12)
[160451.303797] [TTM] Out of kernel memory
[160451.303800] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (4096, 2, 4096, -12)
[160451.303840] [TTM] Out of kernel memory
[160451.303843] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (4096, 2, 4096, -12)
...
[160464.314760] [TTM] Out of kernel memory
[160464.314766] [TTM] Out of kernel memory
[160464.314770] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (4096, 6, 4096, -12)
[160464.314812] kwin_opengl_tes[21167]: segfault at 0 ip 00000359e01c16ab sp 000003fc05767db0 error 4 in r600g_dri.so[359dfe59000+570000]
[160464.314829] grsec: Segmentation fault occurred at            (nil) in /usr/lib64/kde4/libexec/kwin_opengl_test[kwin_opengl_tes:21167] uid/euid:1000/1000 gid/egid:1000/1000, parent /usr/bin/kwin[Thread (pooled):21165] uid/euid:1000/1000 gid/egid:1000/1000
[160464.314867] grsec: denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 for /usr/lib64/kde4/libexec/kwin_opengl_test[kwin_opengl_tes:21167] uid/euid:1000/1000 gid/egid:1000/1000, parent /usr/bin/kwin[Thread (pooled):21165] uid/euid:1000/1000 gid/egid:1000/1000
[160798.666351] [TTM] Out of kernel memory
[160798.666359] [TTM] Out of kernel memory
...
[160798.666893] [TTM] Out of kernel memory
[160798.666896] [TTM] Out of kernel memory
[160798.666898] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (4096, 6, 4096, -12)
[160798.666925] glxgears[21844]: segfault at 0 ip 000002bba584a6ab sp 000003d32c3e2060 error 4 in r600g_dri.so[2bba54e2000+570000]
[160798.666941] grsec: Segmentation fault occurred at            (nil) in /usr/bin/glxgears[glxgears:21844] uid/euid:1000/1000 gid/egid:1000/1000, parent /bin/bash[bash:4166] uid/euid:1000/1000 gid/egid:1000/1000
[160798.667024] grsec: denied resource overstep by requesting 4096 for RLIMIT_CORE against limit 0 for /usr/bin/glxgears[glxgears:21844] uid/euid:1000/1000 gid/egid:1000/1000, parent /bin/bash[bash:4166] uid/euid:1000/1000 gid/egid:1000/1000
[161298.452684] [TTM] Out of kernel memory
[161298.452695] [TTM] Out of kernel memory
[161298.452700] [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (65536, 6, 4096, -12)

Seems the problem is well known and fixed in kwin-4.10.3 and mesa-9.1.3, user needs update both for fixing them problem. kwin-4.10.4 is now marked stable, but mesa-9.1.3 is not yet.

KDE upstream bug:
https://bugs.kde.org/show_bug.cgi?id=315089
Mesa upstream bug:
https://bugs.freedesktop.org/show_bug.cgi?id=61182
Commit in 9.1 branch:
http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=54cfc3fd3ae119b3292a96fe9a0562feafd07c65
Comment 1 Nikoli 2013-07-24 15:26:59 UTC
Created attachment 354104 [details]
kwin gdb

Not fixed, it happened again 2 times. My versions:
[ebuild   R   ~] media-libs/mesa-9.1.4  USE="egl gallium gbm gles2 nptl openvg pax_kernel shared-glapi wayland xa xorg -bindist -classic -debug -gles1 -llvm -osmesa -pic (-r600-llvm-compiler) (-selinux) -vdpau -xvmc" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" VIDEO_CARDS="r600 radeon -i915 -i965 -intel -nouveau -r100 -r200 -r300 (-radeonsi) -vmware" 0 kB                                                                                                                                                                                              
[ebuild   R    ] x11-libs/libdrm-2.4.45  USE="libkms -static-libs" VIDEO_CARDS="radeon (-exynos) (-freedreno) -intel -nouveau (-omap) -vmware" 0 kB                                                
[ebuild   R    ] x11-base/xorg-server-1.13.4:0/1.13.4  USE="ipv6 nptl suid udev xorg xvfb -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -xnest" 0 kB                                   
[ebuild   R    ] kde-base/kwin-4.10.4:4  USE="opengl (-aqua) -debug -gles" 0 kB                                                                                                                    
[ebuild   R   ~] x11-drivers/xf86-video-ati-7.1.0  USE="udev -glamor" 0 kB
Comment 2 Nikoli 2013-07-24 15:28:01 UTC
Created attachment 354106 [details]
glxgears gdb

glxgears does not work until X server is restarted, after restarting KDE session it works fine again.
Comment 3 Johannes Huber gentoo-dev 2013-10-09 19:48:26 UTC
Blocking bug is fixed, so i guess this is fixed too.