Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 475008

Summary: media-tv/xbmc : does not respect NM
Product: Gentoo Linux Reporter: Agostino Sarubbo <ago>
Component: Current packagesAssignee: Xbox herd <xbox>
Status: RESOLVED DUPLICATE    
Severity: QA    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=475006
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 243502    

Description Agostino Sarubbo gentoo-dev 2013-06-27 17:57:27 UTC
You receive this bug because this package does not respect my system's NM (x86_64-pc-linux-gnu-nm) and calls directly /usr/bin/nm
The possible solutions to fix this issue are:
1)Fix the buildsystem, if you can;
2)inherit toolchain-funcs and use tc-export NM
3)inherit toolchain-funcs and use emake NM="$(tc-getNM)"


From the build log:

nm wrapper.o | grep __wrap | awk '{printf("%s ", $3);}' | sed "s/___wrap_/__wrap_/g" | sed "s/__wrap_/-Wl,-wrap,/g" > wrapper.def
Comment 1 SpanKY gentoo-dev 2013-06-27 20:45:13 UTC

*** This bug has been marked as a duplicate of bug 475006 ***