Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 47365

Summary: net-misc/rsync-2.6.0: stderr logging support
Product: Gentoo Linux Reporter: Sascha Silbe <sascha-gentoo-bugzilla>
Component: Current packagesAssignee: Mr. Bones. (RETIRED) <mr_bones_>
Status: VERIFIED UPSTREAM    
Severity: enhancement CC: mholzer
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: stderr logging support for rsync-2.6.0
patch for net-misc/rsync/rsync-2.6.0.ebuild to add stderr logging support

Description Sascha Silbe 2004-04-09 10:21:03 UTC
The attached patch for rsync-2.6.0 adds stderr logging support to rsyncd. It's needed for running rsyncd in a fully chrooted, supervised [1] environment.
I've also sent it upstream.

[1] http://cr.yp.to/daemontools.html



Reproducible: Always
Steps to Reproduce:
Comment 1 Sascha Silbe 2004-04-09 10:21:36 UTC
Created attachment 28961 [details, diff]
stderr logging support for rsync-2.6.0
Comment 2 Sascha Silbe 2004-04-09 10:22:14 UTC
Created attachment 28962 [details, diff]
patch for net-misc/rsync/rsync-2.6.0.ebuild to add stderr logging support
Comment 3 Martin Holzer (RETIRED) gentoo-dev 2004-04-27 09:10:21 UTC
wanna handle this ?
Comment 4 Martin Holzer (RETIRED) gentoo-dev 2004-05-08 08:28:08 UTC
is this fixed with 2.6.2 ?
Comment 5 Aron Griffis (RETIRED) gentoo-dev 2004-06-03 08:31:10 UTC
Let's wait for Martin Pool to put this upstream before integrating it into Gentoo.  Rsync is pretty critical to Gentoo so I'd rather not be introducing custom patches without Martin's blessing.
Comment 6 Mr. Bones. (RETIRED) gentoo-dev 2004-06-03 16:01:32 UTC
Yep.  I totally agree.  I'm going to mark this UPSTREAM for now.
Comment 7 Martin Pool 2004-06-03 17:37:46 UTC
Don't send it to me, send it to rsync@lists.samba.org.
Comment 8 Martin Pool 2004-06-03 17:39:03 UTC
Why don't you just use log file=/dev/fd/2 ?
Comment 9 Martin Pool 2004-06-03 17:40:17 UTC
I don't think you should add special behaviour unless there is something wrong with using /dev/fd/2.  I would be fine with a documentation patch to suggest this.
Comment 10 Mr. Bones. (RETIRED) gentoo-dev 2004-06-03 21:35:02 UTC
Martin -  thanks for the comments.  That clears things up for me.  I'm going to close this bug since the patch doesn't seem to be necessary.  The docs are a separate issue that can be chased by someone else if they like.
Comment 11 Sascha Silbe 2004-06-06 16:55:42 UTC
/dev/fd/2 is only available if devfs is mounted within the chroot (it's just a symlink, not a real device). I'm using the chroot to restrict access to /dev and /proc, so mounting devfs would be counterproductive.