Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 473354

Summary: mail-client/evolution-3.8.3 links against installed library - /usr/lib64/evolution/3.8/ undefined reference to `e_attachment_get_description'
Product: Gentoo Linux Reporter: Helmut Jarausch <jarausch>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Severity: normal CC: alexander, base-system, gentoo.power, harrisl
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 463242    
Attachments: build log

Description Helmut Jarausch 2013-06-15 10:21:02 UTC
evolution-3.8.3 fails to build with an error from the linker

/usr/lib64/evolution/3.8/ undefined reference to `e_attachment_get_file_info'
collect2: error: ld returned 1 exit status
make[4]: *** [evolution-alarm-notify] Error 1
make[4]: Leaving directory `/var/tmp/portage/mail-client/evolution-3.8.3/work/evolution-3.8.3/calendar/alarm-notify'

emerge --info mail-client/evolution
Portage 2.2.0_alpha179_p4 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.0-rc5 x86_64)
                        System Settings
System uname: Linux-3.10.0-rc5-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.2
KiB Mem:     7908212 total,    900900 free
KiB Swap:    1048572 total,   1032764 free
Timestamp of tree: Sat, 15 Jun 2013 07:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.3.3_pre20130526::progress
dev-util/ccache:          3.1.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.2
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.4, 4.7.3, 4.8.1, 4.9.0_pre9999::local
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo local sunrise
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-mtune=native -march=native -O2 -msse3 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mtune=native -march=native -O2 -msse3 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise"
USE="3dnow 3dnowext 3dnowprefetch X a52 aac acl acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg fftw firefox flac fortran fuse gdbm gfortran gif gimp gnome gpm gtk gtk2 iconv ipv6 jpeg kde lapack lcms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp openrc pam pango pcre pdf png policykit ppds qt qt3support qt4 readline sdl session smp spell sqlite sqlite3 sse sse2 sse3 sse4a ssl startup-notification svg tcl tcpd threads tiff tk truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeonhd radeon fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

                        Package Settings

mail-client/evolution-3.8.2 was built with the following:
USE="bogofilter crypt gnome-online-accounts ssl weather -gstreamer -highlight -kerberos -ldap -map -spamassassin"
Comment 1 Helmut Jarausch 2013-06-15 10:22:52 UTC
Created attachment 350986 [details]
build log
Comment 2 Iván Atienza 2013-06-15 10:59:55 UTC
/usr/lib64/evolution/3.8/ why is using a installed lib? i manage to compile 3.8.3 removing first 3.8.2, then update world.

Comment 3 Pacho Ramos gentoo-dev 2013-06-15 15:17:30 UTC

elibtoolize fixes it for me :/, not sure why it doesn't work for you
Comment 4 Pacho Ramos gentoo-dev 2013-06-15 15:20:18 UTC
Maybe this is caused by libtool-2.4.2 (I run 2.4-r1 and elibtoolize fixes the issue)
Comment 5 Rafał Mużyło 2013-06-15 16:02:23 UTC
Out of idle curiosity: see if this is a dupe of bug 367975.
Comment 6 Rafał Mużyło 2013-06-15 16:17:38 UTC
(In reply to Rafał Mużyło from comment #5)
> Out of idle curiosity: see if this is a dupe of bug 367975.

Actually, looking at the diff in the gnome bug, is does seem to be the case.
Comment 7 Mark R. Pariente 2013-06-15 21:01:20 UTC
Unmerging mail-client/evolution-3.8.2 and then merging mail-client/evolution-3.8.3 fixed the issue for me as well.
Comment 8 Pacho Ramos gentoo-dev 2013-06-15 21:06:01 UTC
Or maybe full eautoreconf is needed
Comment 9 Rafał Mużyło 2013-06-15 23:03:14 UTC
(In reply to Pacho Ramos from comment #8)
> Or maybe full eautoreconf is needed

Nah, if it's really a dupe of bug 367975, all that's needed is a patch to, reverting Debian patch, that causes the problem.
Comment 10 Pacho Ramos gentoo-dev 2013-07-23 20:56:49 UTC
Looks solved in 3.8.4