Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 471592

Summary: www-apache/mod_spdy-0.9.3.3: Apache 2.4 compatibility
Product: Gentoo Linux Reporter: Timo Gurr (RETIRED) <tgurr>
Component: New packagesAssignee: SpanKY <vapier>
Status: RESOLVED OBSOLETE    
Severity: enhancement CC: candrews, denny.reeh, leho, svzj, tb
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://code.google.com/p/mod-spdy/issues/detail?id=64
See Also: http://code.google.com/p/mod-spdy/issues/detail?id=64
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 471512    
Bug Blocks:    
Attachments: mod_spdy-0.9.3.3_apache24_compat.patch
mod_spdy_changed_files.tar.bz2
apache-2.4.4-mod_ssl_with_npn.patch

Description Timo Gurr (RETIRED) gentoo-dev 2013-05-28 12:22:31 UTC
Current ebuild and upstream version restricts the required apache version to 2.2. There's an upstream bug which has patches to add apache 2.4 compatibility, attached are is a patch against mod_spdy-0.9.3.3.ebuild incorporating the required patches and ebuild work and a tarball containing the changed files only.

Reproducible: Always
Comment 1 Timo Gurr (RETIRED) gentoo-dev 2013-05-28 12:24:20 UTC
Created attachment 349440 [details, diff]
mod_spdy-0.9.3.3_apache24_compat.patch
Comment 2 Timo Gurr (RETIRED) gentoo-dev 2013-05-28 12:24:45 UTC
Created attachment 349442 [details]
mod_spdy_changed_files.tar.bz2
Comment 3 Timo Gurr (RETIRED) gentoo-dev 2013-05-28 12:25:27 UTC
Created attachment 349444 [details, diff]
apache-2.4.4-mod_ssl_with_npn.patch

Apache NPN patch for 2.4 I used for testing.
Comment 4 SpanKY gentoo-dev 2013-05-28 15:59:41 UTC
Comment on attachment 349444 [details, diff]
apache-2.4.4-mod_ssl_with_npn.patch

having apache support npn in mod_ssl is bug 471512.  there's not really anything the mod_spdy ebuild can do here (well, i could have it optionally build+install a custom mod_ssl, but i don't think that's the route we want to take).
Comment 5 SpanKY gentoo-dev 2013-05-28 16:02:13 UTC
Comment on attachment 349440 [details, diff]
mod_spdy-0.9.3.3_apache24_compat.patch

sorry, but this is a non-starter:
-need_apache2_2
+need_apache2_4

we probably need to update depend.apache.eclass to include want_apache2_4 so that we can then call want_apache_2_{2,4} and set REQUIRED_USE to be one of those.
Comment 6 Zoltán Halassy 2014-06-04 11:21:31 UTC
Hm, it's cool to see the patch I provided on code.google.com here (mod_spdy-0.9.3.3-2.2_to_2.4.patch) :)

Anyway, it's true the ebuild shouldn't mess with mod_ssl, only three files need to be patched (apache_spdy_stream_task_factory.cc , log_message_handler.cc and mod_spdy.cc). 

Make this issue dependent on Bug 471512 .

Would it be ok, if the patches would be modifed with #if macros, and the ebuild would simply use need_apache2 ?
Comment 7 SpanKY gentoo-dev 2014-06-15 01:49:37 UTC
(In reply to Zoltán Halassy from comment #6)

i don't think we need to depend on bug 471512 as it's orthogonal to mod_spdy supporting a newer version of apache

your patch isn't the blocker here ... we need the ebuild itself to support multiple versions of apache.  i'm not really sure what is needed to make that happen.
Comment 8 Zoltán Halassy 2014-06-16 07:22:59 UTC
(In reply to SpanKY from comment #7)
> i don't think we need to depend on bug 471512 as it's orthogonal to mod_spdy
> supporting a newer version of apache

Well I get it supporting 2.4 is orthogonal for requiring mod_ssl with NPN, but mod_spdy ebuild doesn't make much sense without requiring NPN in mod_ssl, as SPDY will not be negotiated without it.

> your patch isn't the blocker here ... we need the ebuild itself to support
> multiple versions of apache.  i'm not really sure what is needed to make
> that happen.

I don't have much time at the moment to solve that problem, but it shouldn't be that difficult (you can use #ifdef directives for detecting versions in the code). If I will have the time, I will work on a version-independent patch for mod_spdy.
Comment 9 Zoltán Halassy 2014-06-16 07:24:41 UTC
(In reply to SpanKY from comment #7)
> we need the ebuild itself to support
> multiple versions of apache.

BTW, check how www-apache/mod_fcgid ebuild works, it supports both 2.2 and 2.4.
Comment 10 SpanKY gentoo-dev 2014-07-30 03:55:20 UTC
(In reply to Zoltán Halassy from comment #8)

i'm talking about the ebuild here, not the source code.  ebuilds don't have #ifdef statements.
Comment 11 Zoltán Halassy 2014-07-30 05:54:44 UTC
(In reply to SpanKY from comment #10)
> i'm talking about the ebuild here, not the source code.  ebuilds don't have
> #ifdef statements.

mod_fcgid works both 2.2 and 2.4 . It uses need_apache2 instead of need_apache2_2 or need_apache2_4 .
Comment 12 Zoltán Halassy 2014-07-30 05:57:50 UTC
-need_apache2_2
+need_apache2

would be the solution I think.
Comment 13 SpanKY gentoo-dev 2015-02-17 07:01:22 UTC
don't think it's a stable blocker since we're still waiting for bug 471512

mod_spdy might be a moot point in general though since it's been merged into upstream apache ...
Comment 14 Leho Kraav (:macmaN @lkraav) 2015-02-17 07:02:50 UTC
It appears as if spdy is going away in favor of HTTP/2

http://www.phoronix.com/scan.php?page=news_item&px=Google-Chrome-SPDY-HTTP2
Comment 15 SpanKY gentoo-dev 2015-02-18 15:59:51 UTC
(In reply to Leho Kraav (:macmaN @lkraav) from comment #14)

that's true and eventually things will converge on apache.  but right now, mod_spdy is our only option afaik to support something newer than HTTP/1.1.
Comment 16 SpanKY gentoo-dev 2015-09-26 07:32:26 UTC
mod_spdy is dead and we have mod_h2 now which is apache-2.4 compatible (and included in upstream now)