Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 468750

Summary: =sys-auth/pam_mysql-0.7_rc1-r4 with =sys-devel/automake-1.13 - error: 'AM_CONFIG_HEADER': this macro is obsolete.
Product: Gentoo Linux Reporter: Joakim <moonwalker>
Component: New packagesAssignee: Gentoo Linux MySQL bugs team <mysql-bugs>
Status: RESOLVED FIXED    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 451744    

Description Joakim 2013-05-06 10:18:09 UTC
Another one that Blocks #451744 I think

# cat /var/tmp/portage/sys-auth/pam_mysql-0.7_rc1-r4/temp/aclocal.out 
***** aclocal *****
***** PWD: /var/tmp/portage/sys-auth/pam_mysql-0.7_rc1-r4/work/pam_mysql-0.7RC1
***** aclocal

aclocal-1.13: warning: autoconf input should be named 'configure.ac', not 'configure.in'
configure.in:8: error: 'AM_CONFIG_HEADER': this macro is obsolete.
    You should use the 'AC_CONFIG_HEADERS' macro instead.
/usr/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
configure.in:8: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Reproducible: Always

Steps to Reproduce:
1. emerge sys-auth/pam_mysql
2.
3.
Actual Results:  
 * Messages for package sys-auth/pam_mysql-0.7_rc1-r4:

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/sys-auth/pam_mysql-0.7_rc1-r4/temp/aclocal.out
 * ERROR: sys-auth/pam_mysql-0.7_rc1-r4 failed (prepare phase):
 *   Failed Running aclocal !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 3316:  Called eautoreconf
 *   environment, line  945:  Called eaclocal
 *   environment, line  848:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  679:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";



It should be well known what this is.
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2014-08-19 17:15:39 UTC
*pam_mysql-0.7_rc1-r5 (19 Aug 2014)

  19 Aug 2014;  <grknight@gentoo.org> +pam_mysql-0.7_rc1-r5.ebuild:
  Fix deprecated autotools macros for bug 468750 and EAPI5 bump