Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 467100

Summary: app-text/ghostscript-gpl-9.06 with automake-1.13 - error: 'AM_PROG_CC_STDC': this macro is obsolete
Product: Gentoo Linux Reporter: iGentoo <AlphatPC>
Component: [OLD] PrintingAssignee: Printing Team <printing>
Status: RESOLVED FIXED    
Severity: normal CC: bugs, carlphilippreh, che, chris, even.more.spam.for.me, FlorianManschwetus, hans, jason.mours, mail, meagher.kevin, r3pek, realnc, zorry
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: http://bugs.ghostscript.com/show_bug.cgi?id=693940
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 451744    
Attachments: Patch to use the new AC_CONFIG_HEADERS function
have ijs/configure.ac check for AC_PROC_CC instead of AM_PROG_CC_STDC
patch for the ebuild

Description iGentoo 2013-04-24 19:22:03 UTC
>>> Source unpacked in /var/tmp/portage/app-text/ghostscript-gpl-9.06/work
>>> Preparing source in /var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06 ...
 * Applying various patches (bugfixes/updates) ...
 *   ghostscript-gpl-8.61-multilib.patch ...
 [ ok ]
 *   ghostscript-gpl-8.64-noopt.patch ...
 [ ok ]
 *   ghostscript-gpl-9.04-scripts.patch ...
 [ ok ]
 *   ghostscript-gpl-9.05-cups-filters.patch ...
 [ ok ]
 *   ghostscript-gpl-9.05-icc-missing-check.patch ...
 [ ok ]
 *   ghostscript-gpl-9.06-iccprofiles-initdir.patch ...
 [ ok ]
 *   ghostscript-gpl-9.06-runlibfileifexists.patch ...
 [ ok ]
 * Done with patching
 * Running eautoreconf in '/var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06' ...
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06/ijs' ...
 * Running libtoolize --install --copy --force --automake ...
 [ ok ]
 * Running aclocal ...
 [ !! ]

 * Failed Running aclocal !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/app-text/ghostscript-gpl-9.06/temp/aclocal-1.out

# cat /var/tmp/portage/app-text/ghostscript-gpl-9.06/temp/aclocal-1.out
***** aclocal *****
***** PWD: /var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06/ijs
***** aclocal

configure.ac:120: error: 'AM_PROG_CC_STDC': this macro is obsolete.
    You should simply use the 'AC_PROG_CC' macro instead.
    Also, your code should no longer depend upon 'am_cv_prog_cc_stdc',
    but upon 'ac_cv_prog_cc_stdc'.
/usr/share/aclocal-1.13/obsolete-err.m4:17: AM_PROG_CC_STDC is expanded from...
configure.ac:120: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1


Portage 2.2.0_alpha173 (hardened/linux/amd64/selinux, gcc-4.8.0, glibc-2.17, 3.8.8-pax.x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.8.8-pax.x86_64-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-gentoo-2.2
KiB Mem:     6114284 total,    199548 free
KiB Swap:   10484724 total,  10441360 free
Timestamp of tree: Wed, 24 Apr 2013 18:15:01 +0000
ld GNU gold (GNU Binutils 2.23.2) 1.11
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.5.4-r5, 2.6.8-r1, 2.7.4::custom, 3.1.5-r1, 3.2.3-r2, 3.3.0-r1
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.12.6, 1.13.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.6.4, 4.7.2-r1, 4.8.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo systemd hardened-dev gnome custom
Installed sets: @local
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
DISTDIR="/var/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FCFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox selinux sesandbox sfperms split-elog split-log splitdebug strict test test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-Wall -Wextra -ggdb -march=native -pipe -O3 -fno-tree-vectorize -frecord-gcc-switches"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--icf=safe"
MAKEOPTS="V=1 -j10"
PKGDIR="/var/portage/packages-amd64"
PORTAGE_BZIP2_COMMAND="lbzip2"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9ef"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--ipv4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/hardened-development /var/lib/layman/gnome /usr/local/portage"
SYNC="rsync://mirrors.ustc.edu.cn/gentoo-portage"
USE="X acl alsa amd64 audit bash-completion berkdb bzip2 c++0x cairo caps cli cracklib crypt custom-cflags cxx dbus dri ffmpeg gdbm gmp gnome gpm gtk gtk3 hardened iconv icu ipv6 jit jpeg jpeg2k justify lzma mmx modules mudflap multilib ncurses nls nptl open_perms opengl openmp orc pam pax_kernel pcre png pulseaudio qt4 readline selinux session sse sse2 ssl svg systemd tcpd threads tiff udev unicode urandom vim-syntax xattr xinetd zlib" ABI_X86="x32 32 64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs caps dmsquash-live gensplash livenet lvm nfs ssh-client syslog systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US zh zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="pypy1_9 pypy2_0 python3_1 python3_2 python3_3 python2_5 python2_6 python2_7" QEMU_SOFTMMU_TARGETS="x86_64 arm mips64el ppc64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7-pypy-1.9 2.7-pypy-2.0 3.1 3.2 3.3 2.5 2.6 2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND

=================================================================
                        Package Settings
=================================================================

app-text/ghostscript-gpl-9.06 was built with the following:
USE="X cups dbus gtk jpeg2k (multilib) (selinux) test -bindist -djvu -idn -static-libs" LINGUAS="zh_CN -de -ja -ko -zh_TW"
Comment 1 Jason Mours 2013-04-25 20:04:34 UTC
Having aclocal issues with app-text/ghostscript-gpl-9.06 here is my aclocal-1.out:

***** aclocal *****
***** PWD: /var/tmp/portage/app-text/ghostscript-gpl-9.06/work/ghostscript-9.06/ijs
***** aclocal

configure.ac:120: error: 'AM_PROG_CC_STDC': this macro is obsolete.
    You should simply use the 'AC_PROG_CC' macro instead.
    Also, your code should no longer depend upon 'am_cv_prog_cc_stdc',
    but upon 'ac_cv_prog_cc_stdc'.
/usr/share/aclocal-1.13/obsolete-err.m4:17: AM_PROG_CC_STDC is expanded from...
configure.ac:120: the top level
autom4te-2.69: /usr/bin/m4 failed with exit status: 1
aclocal-1.13: error: echo failed with exit status: 1

Having a similar issue with dev-libs/libmcrypt-2.5.8-r2 ref bug 467058
Comment 2 Jason Mours 2013-04-25 20:30:57 UTC
Not sure if these are necessary but not included in the build logs is emerge failing with an orphaned PID:

/usr/lib64/portage/bin/isolated-functions.sh: line 215: wait: 'Failed running aclocal !': not a pid or valid job spec
Comment 3 Chris Smith 2013-04-27 14:38:47 UTC
same failure here
Comment 4 Jan Bessai 2013-04-27 17:15:10 UTC
Created attachment 346716 [details, diff]
Patch to use the new AC_CONFIG_HEADERS function

Worked for me after inclusion in "ghostscript-gpl-9.06-patchset-1.tar.bz2".
Comment 5 James Cloos 2013-04-27 20:42:29 UTC
This bug still exists in ghostscript 9.07 and master.

I sent them a note about it:

http://bugs.ghostscript.com/show_bug.cgi?id=693940
Comment 6 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-04-28 20:23:46 UTC
*** Bug 467686 has been marked as a duplicate of this bug. ***
Comment 7 Thomas 2013-04-29 22:31:25 UTC
Created attachment 346936 [details, diff]
have ijs/configure.ac check for AC_PROC_CC instead of AM_PROG_CC_STDC

Just ran into the issue in comment #1. Here's the trivial patch that got me past it. Note that I simply added a files directory and hacked the ebuild to epatch this patch, rather than get creative.
Comment 8 James Cloos 2013-04-29 23:34:49 UTC
That patch leads to calling AC_PROC_CC twice in a row.

The offending call to AM_PROG_CC_STDC simply can be deleted instead.
Comment 9 Lee Trager 2013-04-30 08:34:06 UTC
Its easier to just add this to the prep section

# AM_PROG_CC_STDC is obsolete and causes build failure with
# >=sys-devel/automake-1.13.1
sed -i -e '/AM_PROG_CC_STDC/d' ijs/configure.ac || die
Comment 10 Nikos Chantziaras 2013-04-30 11:39:45 UTC
This is still broken. What's the recommended way to deal with this? Should we mask automake-1.13?
Comment 11 stuart.li 2013-04-30 14:13:19 UTC
i was stuck with this bug while i upgrade gentoo.
when could this patch merge into portage?
Comment 12 Chris Smith 2013-04-30 14:25:40 UTC
FYI:
I've installed several packages that don't work with automake-1.13(.1) by simply temporarily unmerging that specific version (ex: emerge -Ca =sys-devel/automake-1.13.1 - don't unmerge all versions!). The package will fall back to using a previous version, in my case automake-1.12.6. A world update will remerge it unless masked.
Comment 13 Tobias B. 2013-05-01 17:21:32 UTC
Created attachment 347056 [details]
patch for the ebuild

Removes the obsolete line in the configure.ac
Comment 14 Timo Gurr (RETIRED) gentoo-dev 2013-05-02 02:08:01 UTC
Fixed in CVS and thanks for taking care of reporting the issue upstream!
Comment 15 James Cloos 2013-05-06 23:29:17 UTC
Upstream has applied a fix, too.  Versions after gs-9.07 will not need patching.