Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 463550

Summary: www-client/chromium - fails to compile with =app-accessibility/speech-dispatcher-0.8
Product: Gentoo Linux Reporter: Denis M. (Phr33d0m) <god>
Component: Current packagesAssignee: Chromium Project <chromium>
Status: RESOLVED FIXED    
Severity: normal CC: ao, attila.jecs, bircoph, darkcircle.0426, denis, jlec, jwbraun, kanelxake, m.debruijne, m.mairkeimberger, mail, marduk, marienz, Martin.vGagern, moses.matthewl, oli.huber, tdalman, tetromino, travisghansen
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
See Also: https://bugs.gentoo.org/show_bug.cgi?id=462356
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: www-client:chromium-26.0.1410.43.tar.xz (build log)
workaround patch

Description Denis M. (Phr33d0m) 2013-03-27 22:26:43 UTC
Created attachment 343482 [details]
www-client:chromium-26.0.1410.43.tar.xz (build log)

After I upgraded speech-dispatcher to 0.8, chromium no longer compiles. 
If I downgrade speech-dispatcher to the previous 0.7.1-r2, chromium compiles without issues.


Portage 2.2.0_alpha170 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.2, glibc-2.16.0, 6.6.6 x86_64)
=================================================================
System uname: Linux-6.6.6-x86_64-Intel-R-_Core-TM-_i7-2600K_CPU_@_3.40GHz-with-gentoo-Gentoo-Powered
KiB Mem:    24661044 total,   1265340 free
KiB Swap:    2000088 total,   2000088 free
Timestamp of tree: Wed, 27 Mar 2013 21:15:02 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.13.1
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.8 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/media/STORAGE/Software/---OS---/gentoo/distfiles"
EMERGE_DEFAULT_OPTS=""
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs config-protect-if-modified distlocks fail-clean fixlafiles merge-sync news nodoc noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ http://mirrors.telepoint.bg/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://gentoo-euetib.upc.es/mirror/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/media/STORAGE/Software/---OS---/gentoo/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_COMPRESS_FLAGS="-9"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="-4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://81.91.242.10/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apng ares avx bash-completion berkdb bluetooth bluray branding bzip2 c++0x cairo cli consolekit cracklib cxx dbus declarative dri dts dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gstreamer gtk iconv icu ipv6 jpeg kde kdm kipi lcms ldap libnotify lm_sensors lzma mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nsplugin ogg opencl opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pulseaudio python qt3support qt4 readline sdl session spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US es es_ES bg" NETBEANS_MODULES="apisupport cnd java javafx php profiler websvccommon mobility webcommon" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, USE_PYTHON
Comment 1 iGentoo 2013-03-28 11:43:43 UTC
Created attachment 343516 [details, diff]
workaround patch
Comment 2 Albert W. Hopkins 2013-03-28 12:13:44 UTC
I experience the same build error with www-client/chromium-27.0.1453.3 and speech-dispatcher 0.8.  It however builds fine with speech-dispatcher-0.7.1-r2.
Comment 3 Ionuț Leonte 2013-03-28 13:46:49 UTC
The patch in Comment #1 worked for me (www-client/chromium-27.0.1453.3, app-accessibility/speech-dispatcher-0.8)
Comment 4 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-03-28 14:23:38 UTC
(In reply to comment #1)
> Created attachment 343516 [details, diff] [details, diff]
> workaround patch

Sorry, this doesn't look correct to me even if it "works".

We shouldn't be using <(sysroot), and using headers that do not match the linked library is recipe for trouble.
Comment 5 André Terpstra 2013-03-28 20:00:28 UTC
I am trying to build www-client/chromium-26.0.1410.43 too and ran into the same issue. I wonder whether first building it with app-accessibility/speech-dispatcher-0.7.1-r2 and afterwards re-upgrading to app-accessibility/speech-dispatcher-0.8-r1 works?
Comment 6 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-03-28 22:25:36 UTC
By the way if you want to test patches <https://projects.archlinux.org/svntogit/packages.git/tree/trunk/chromium-26.0.1410.43-speechd-0.8.patch?h=packages/chromium> looks promising.
Comment 7 Mads 2013-03-29 08:13:08 UTC
(In reply to comment #6)
> By the way if you want to test patches
> <https://projects.archlinux.org/svntogit/packages.git/tree/trunk/chromium-26.
> 0.1410.43-speechd-0.8.patch?h=packages/chromium> looks promising.

It works here. Tested with 27.0.1453.3 on ~amd64.
Comment 8 Marien Zwart (RETIRED) gentoo-dev 2013-03-30 07:48:37 UTC
speech-dispatcher upstream moved their header around, see http://git.freebsoft.org/?p=speechd.git;a=commitdiff;h=7a217e8ef5fcae2cdf3541f326e961982742fc43

"Since we have more than one public header now, they need to be installed in /usr/include/speech-dispatcher."

/usr/include/speech-dispatcher/libspeechd.h looks like it's at least mostly compatible with the former /usr/include/libspeechd.h. Unfortunately the pkg-config file doesn't specify an includedir of /usr/include/speech-dispatcher, and judging from the "#include <speech-dispatcher/speechd_types.h>" in /usr/include/speech-dispatcher/libspeechd.h the intention really might be that everyone goes and updates their includes?

The patch suggested in comment #6 looks reasonable if it also introduces a dependency on speech-dispatcher >= 0.8.
Comment 9 Marien Zwart (RETIRED) gentoo-dev 2013-03-30 07:50:33 UTC
*** Bug 463594 has been marked as a duplicate of this bug. ***
Comment 10 André Terpstra 2013-03-30 09:20:42 UTC
(In reply to comment #5)
> I am trying to build www-client/chromium-26.0.1410.43 too and ran into the
> same issue. I wonder whether first building it with
> app-accessibility/speech-dispatcher-0.7.1-r2 and afterwards re-upgrading to
> app-accessibility/speech-dispatcher-0.8-r1 works?

It works :)
Comment 11 Michael Mair-Keimberger (iamnr3) 2013-03-30 11:10:07 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > By the way if you want to test patches
> > <https://projects.archlinux.org/svntogit/packages.git/tree/trunk/chromium-26.
> > 0.1410.43-speechd-0.8.patch?h=packages/chromium> looks promising.
> 
> It works here. Tested with 27.0.1453.3 on ~amd64.

Works here too. Compiled with 26.0.1410.43 on ~amd64.
Comment 12 Jesús Guerrero Botella (RETIRED) gentoo-dev 2013-03-31 13:37:56 UTC
I had to mask 0.8 and 0.7.1-r2 as well since it won't build in my system (that's an entirely different issue and it's ~arched anyway).

Fortunately 0.7.1-r1 worked fine and I can continue using chromium.
Comment 13 Attila Jecs 2013-04-01 09:49:00 UTC
i can see perfectly,
can't someone please
make this speech-thing
optional?
Comment 14 Martin von Gagern 2013-04-02 06:12:43 UTC
Chromium does call epatch_user, so a workaround for users would be the following steps, which locally apply the patch from comment #6:

# mkdir -p /etc/portage/patches/www-client/chromium-26.0.1410.43
# wget -O /etc/portage/patches/www-client/chromium-26.0.1410.43/bug463550c6.patch 'https://projects.archlinux.org/svntogit/packages.git/plain/trunk/chromium-26.0.1410.43-speechd-0.8.patch?h=packages/chromium'
# emerge -1 chromium

For an in-tree solution, one could either apply that patch conditionally, or apply that patch with a gyp variable instead of a fixed path so that the ebuild can provide the path using a -D argument, or modify speech-dispatcher to provide a backwards-compatible libspeechd.h which simply includes the newer header.
Comment 15 Xake 2013-04-02 19:48:17 UTC
--- /var/portage/www-client/chromium/chromium-26.0.1410.43.ebuild	2013-03-27 03:38:46.000000000 +0100
+++ /var/overlays/mine/www-client/chromium/chromium-26.0.1410.43.ebuild	2013-04-01 16:00:45.334394409 +0200
@@ -141,6 +141,11 @@
 	# Fix build issue with smhasher, bug #459126 .
 	epatch "${FILESDIR}/${PN}-smhasher-r0.patch"
 
+	if has_version '>=app-accessibility/speech-dispatcher-0.8'; then
+		sed s:"<libspeechd.h>":"<speech-dispatcher/libspeechd.h>":g \
+			-i "${S}"/build/linux/system.gyp
+	fi
+
 	epatch_user
 
 	# Remove most bundled libraries. Some are still needed.
Comment 16 Xake 2013-04-02 19:55:05 UTC
(In reply to comment #13)
> i can see perfectly,
> can't someone please
> make this speech-thing
> optional?

It might sound like a no-brainer, but removing the "speech-thing" may change *alot* of stuff in the chrome/chromium-extensions/plugins API/ABI. So it might actually be harder to accomplish (since it might break random things depeding on the API, not just things depending on the "speech-thing"). So let the devs have some time investigate this, or do it yourself and post about it in the bug report for it. Bugging us (users/devs) in random bugs is a good way of making people tired of you.
Comment 17 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-04-03 15:59:33 UTC
  03 Apr 2013; Pawel Hajdan jr
  +files/chromium-speech-dispatcher-0.8-r0.patch, -chromium-27.0.1448.0.ebuild,
  +chromium-27.0.1453.12.ebuild, chromium-9999-r1.ebuild:
  Dev channel bump. Fix build with speech-dispatcher-0.8 (bug #463550 by Denis
  M. "Phr33d0m"). Remove old.

Fix is in 27.x, soon to hit ~arch. 26 will be stabilized soon (bug #463426) so I'm not introducing a dependency on new speech-dispatcher there.

For making speech-dispatcher optional, please see bug #462356 .
Comment 18 Xake 2013-04-04 21:23:09 UTC
(In reply to comment #17)
> Fix is in 27.x, soon to hit ~arch. 26 will be stabilized soon (bug #463426)
> so I'm not introducing a dependency on new speech-dispatcher there.
> 

And what will you do if speech-dispatcher-0.8 goes stable before chromium-27?
Why not a conditional like the one I demonstrated above (worked fine for me)?
Comment 19 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-04-04 21:32:38 UTC
(In reply to comment #18)
> And what will you do if speech-dispatcher-0.8 goes stable before chromium-27?
> Why not a conditional like the one I demonstrated above (worked fine for me)?

Ebuilds can be adjusted then.

Conditional patching makes it more difficult to test the package, and is generally a hack.
Comment 20 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2013-05-22 17:29:24 UTC
FYI chromium-27.0.1453.93 requires speech-dispatcher-0.7 again for security stabilization (bug #470920). chromium-28.x should enter ~arch soon.

chromium-28.x will be easier to handle, since it doesn't require conditional patching (bad), but only conditional code in src_configure (fine).
Comment 21 Attila Jecs 2013-05-23 14:30:12 UTC
 * Messages for package app-accessibility/speech-dispatcher-0.7.1-r2:

 * ERROR: app-accessibility/speech-dispatcher-0.7.1-r2 failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=app-accessibility/speech-dispatcher-0.7.1-r2'`,
 * the complete build log and the output of `emerge -pqv '=app-accessibility/speech-dispatcher-0.7.1-r2'`.
 * The complete build log is located at '/var/tmp/portage/app-accessibility/speech-dispatcher-0.7.1-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-accessibility/speech-dispatcher-0.7.1-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-accessibility/speech-dispatcher-0.7.1-r2/work/speech-dispatcher-0.7.1_build'
 * S: '/var/tmp/portage/app-accessibility/speech-dispatcher-0.7.1-r2/work/speech-dispatcher-0.7.1'