Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 46193

Summary: emerge apache fails with various errors
Product: Gentoo Linux Reporter: Chris Tuft <chris>
Component: New packagesAssignee: Apache Team - Bugzilla Reports <apache-bugs>
Severity: major    
Priority: High    
Version: 2004.0   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Chris Tuft 2004-03-29 20:23:31 UTC
This is a very fresh install of 2004.0. Whenever "emerge apache" is run, it always errors out. Sometimes there will be an issue with "./configure" and sometimes it will end in a segmentation fault or something else. Here's an example:

util.c: In function `substring_conf':
util.c:729: error: unrecognizable insn:
(insn 152 150 76 2 (nil) (UnKnown Unknown) -1 (nil)
util.c:729: internal compiler error: in extract_insn, at recog.c:2175
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
The bug is not reproduceable, so it is likely a hardware or OS problem
make[2]: *** [util.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/apache-2.0.49/work/httpd-2.0.49/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/apache-2.0.49/work/httpd-2.0.49/server'
make: *** [all-recursive] Error 1

!!! ERROR: net-www/apache-2.0.49 failed.
!!! Function src_compile, Line 188, Exitcode 2
!!! problem compiling Apache2 :(

Reproducible: Always
Steps to Reproduce:
1. type "emerge apache"
2. error happens, but not always the same error

Expected Results:  
Completed the emerge successfully
Comment 1 Chuck Short (RETIRED) gentoo-dev 2004-03-30 04:13:47 UTC
Please post emerge info. 
Comment 2 Chuck Short (RETIRED) gentoo-dev 2004-04-05 13:16:41 UTC
You might want to check to see that you are not running out of memory.
Comment 3 Chris Tuft 2004-04-05 13:22:04 UTC
As crazy as it seems, I believe the problem here is bad memory. I ran memtest86 and found multiple issues with my memory. I'm going to close this ticket and do some memory troubleshooting on my system. Thanks for all your efforts!
Comment 4 Elfyn McBratney (beu) (RETIRED) gentoo-dev 2005-04-23 19:49:49 UTC