Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 460438

Summary: www-apache/mod_authnz_external-3.3.2 version bump
Product: Gentoo Linux Reporter: Adam M. Bumpus <adam>
Component: [OLD] LibraryAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED FIXED    
Severity: normal CC: bugzilla-gentoo, drescherjm, smkbot
Priority: Normal Keywords: EBUILD, PATCH
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 468302    
Attachments: Proposed .ebuild file
mod_authnz_external-3.3.1.ebuild
0001-Apache-2.4-compatibility.patch

Description Adam M. Bumpus 2013-03-05 18:53:16 UTC
mod_authz_external has version 3.2.6 which is suitable for use with Apache version 2.2. Now that Apache version 2.4 is stable in the gentoo tree mod_authnz_external needs to be bumped to version 3.3.1 which is compatible with the 2.3/2.4 apache release.

Reproducible: Always

Steps to Reproduce:
1. emerge -pv =www-servers/apache-2.2.24 && emerge www-apache/mod_authnz_external
2. emerge --sync && emerge -DuavN world
Actual Results:  
  (www-servers/apache-2.2.24::gentoo, installed) pulled in by
    =www-servers/apache-2.2* required by (www-apache/mod_authnz_external-3.2.6::gentoo, installed)


Expected Results:  
Apache and mod_authnz_external upgrade to new versions
Comment 1 Adam M. Bumpus 2013-03-05 18:56:43 UTC
Created attachment 341030 [details]
Proposed .ebuild file
Comment 2 Robert Trace 2013-03-06 02:59:38 UTC
Created attachment 341070 [details]
mod_authnz_external-3.3.1.ebuild

Improved ebuild.

- Correct LICENSE is Apache-2.0
- Add www-servers/apache-2.4.1 as [R]DEPEND
- Patch required for >=apache-2.4.1
Comment 3 Robert Trace 2013-03-06 03:00:45 UTC
Created attachment 341072 [details, diff]
0001-Apache-2.4-compatibility.patch

http://code.google.com/p/mod-auth-external/issues/detail?id=8

Patch required for build compatibility with >=apache-2.4.1
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2014-12-13 09:01:26 UTC
*** Bug 532402 has been marked as a duplicate of this bug. ***
Comment 5 Pacho Ramos gentoo-dev 2014-12-16 09:35:12 UTC
+*mod_authnz_external-3.3.2 (16 Dec 2014)
+
+  16 Dec 2014; Pacho Ramos <pacho@gentoo.org> +mod_authnz_external-3.3.2.ebuild:
+  Version bump
+